Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 12:24
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Создание каталога с именем из запроса  (Прочитано 2944 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Compodoctor

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-09-28
  • Сайт: 
  • Профессия: Ученик 1С
Существует вот такой код, содержащийся в модуле менеджера документа ЗаказНаряд

 //проверяет и (или) создает каталог
Процедура ПроверитьСуществованиеКаталога(ИмяКаталога) Экспорт
    КаталогНаДиске = Новый Файл(ИмяКаталога);
Если КаталогНаДиске.Существует() Тогда
Сообщить("Папка с таким именем уже существует");
Иначе
СоздатьКаталог(ИмяКаталога);
Сообщить("Создана новая папка "+ИмяКаталога);
КонецЕсли;

КонецПроцедуры
//делает запрос и формирует ИмяКаталога
Процедура ФайлыДокумента(ИмяКаталога, Ссылка) Экспорт
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЗаказНаряд.Автомобиль.Марка КАК Марка,
| ЗаказНаряд.Автомобиль.Модель КАК Модель,
| ЗаказНаряд.Автомобиль,
| ЗаказНаряд.НомерУбытка
|ИЗ
| Документ.ЗаказНаряд КАК ЗаказНаряд
|ГДЕ
| ЗаказНаряд.Ссылка В (&Ссылка)";

Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
МаркаМодель = Выборка.Марка + " " + Выборка.Модель;
ГосНомер = " " + Выборка.Автомобиль;
Номер = " " + Выборка.НомерУбытка;
КонецЦикла;

ИмяКаталога = "d:\Documents\Прием-сдача машин\" + МаркаМодель + ГосНомер + Номер;
ПроверитьСуществованиеКаталога(ИмяКаталога);

КонецПроцедуры

И вот такой код в модуле команды:

&НаСервере
Процедура ФайлыДокумента(Ссылка);
Документы.ЗаказНаряд.ФайлыДокумента(Ссылка);
КонецПроцедуры

Хочу реализовать выполнение в виде команды на командной панели формы.
Что не так? И что еще нужно написать в модуле команды (я так понимаю &НаКлиенте) чтобы заработало?

Вдумчиво так


Оффлайн softbear

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 1
  • КПД: 33%
  • Регистрация: 2011-10-18
  • Сайт: 
  • Профессия: Программист 1С
Так делаешь команду формы с текстом 
   
Документы.ЗаказНаряд.ФайлыДокумента(Ссылка);

И перетаскиваешь куда хочешь, хоть на форму, хоть на командную панель.

Оффлайн Compodoctor

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-09-28
  • Сайт: 
  • Профессия: Ученик 1С
Подумал, изменил вот так
Модуль команды:
&НаКлиенте
Процедура Создание(ИмяКаталога, Ссылка) Экспорт
ЗапросИмени(ИмяКаталога,Ссылка);
КаталогНаДиске = Новый Файл(ИмяКаталога);
Если КаталогНаДиске.Существует() Тогда
Сообщить("Папка с таким именем уже существует");
Иначе
СоздатьКаталог(ИмяКаталога);
Сообщить("Создана новая папка "+ИмяКаталога);
КонецЕсли;

КонецПроцедуры

&НаСервере
Процедура ЗапросИмени(ИмяКаталога, Ссылка)
Документы.ЗаказНаряд.ФайлыДокумента(ИмяКаталога, Ссылка);
КонецПроцедуры

В менеджере
Процедура ФайлыДокумента(ИмяКаталога, Ссылка) Экспорт
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЗаказНаряд.Автомобиль.Марка КАК Марка,
| ЗаказНаряд.Автомобиль.Модель КАК Модель,
| ЗаказНаряд.Автомобиль,
| ЗаказНаряд.НомерУбытка
|ИЗ
| Документ.ЗаказНаряд КАК ЗаказНаряд
|ГДЕ
| ЗаказНаряд.Ссылка В (&Ссылка)";

// Запрос.Параметры.Вставить("Ссылка", Ссылка);

Выборка = Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл
МаркаМодель = Выборка.Марка + " " + Выборка.Модель;
ГосНомер = " " + Выборка.Автомобиль;
Номер = " " + Выборка.НомерУбытка;
КонецЦикла;


ИмяКаталога = "d:\Documents\Прием-сдача машин\" + МаркаМодель + ГосНомер + Номер;

КонецПроцедуры

Ошибки не выдает, но и каталог не создает
Добавлено: 12 Окт 2013, 14:33

Вот скрины свойств Команды и Кнопки команды Подскажите, где я накосячил?
Вдумчиво так

Последний раз редактировалось: Compodoctor; 12 Окт 2013, 14:33. Причина: Объединение сообщений

Оффлайн Андрей Федотов

  • ***
  • Сообщений: 212
  • РЕПУТАЦИЯ: 36
  • КПД: 17%
  • Регистрация: 2011-07-07
  • Компания: Future IT Solutions
  • Профессия: Разработчик 1С
А куда он проваливается?
В другое ЕСЛИ?
С уважением,
Андрей Федотов
Future IT Solutions

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Кнопка - она существует только на клиенте, соответственно и код который она вызывает должен быть на клиенте

Например процедура команда Создание
&НаКлиенте
Процедура Создание(Команда) Экспорт
   Перем ИмяКаталога;
   ЗапросИмени(ИмяКаталога,Объект.Ссылка);
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Из запроса не выводятся значения полей - выводятся пустые значения

Автор Alex1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 24
Просмотров: 12184
Последний ответ 14 Июн 2012, 17:44
от Alex1111
Программное создание документа на основании документа

Автор GolickoffРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4454
Последний ответ 23 Апр 2015, 08:45
от Golickoff
Автоматическое создание " Заполнение" документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4437
Последний ответ 06 Мар 2014, 14:48
от mashencev_anton
Создание отчета "Отсутствие заказов"

Автор dronspartak9@gmail.comРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3867
Последний ответ 16 Апр 2014, 15:09
от dronspartak9@gmail.com
Создание заказаов на производство на основании заказа на производство.

Автор Елена1986Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 20
Просмотров: 7818
Последний ответ 09 Сен 2015, 13:01
от Елена1986

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 882
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal