Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 19:22
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Открытии формы справочника, через форму документа  (Прочитано 4562 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kot_oo

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-10-11
  • Сайт: 
  • Профессия: Программист 1С
Когда открываешь форму документа, у полей с права есть кнопка ПриОткрытии (Лупа), когда на нее нажимаешь открывается форма справочника этого объекта

вопрос

как сделать так когда открывается эта форма справочника объекта, была она в режиме только для просмотра


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
у поля ввода есть событие - Открытие.
Создайте процедуру-обработчик этого события с вот таким кодом:
Процедура ПолеВвода1Открытие(Элемент, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
ЗначениеЭлемента = Элемент.Значение;
Если ЗначениеЗаполнено(ЗначениеЭлемента) Тогда
ФормаЭлемента = ЗначениеЭлемента.ПолучитьФорму(,,);
ФормаЭлемента.ТолькоПросмотр = Истина;
ФормаЭлемента.Открыть();
КонецЕсли;
КонецПроцедуры

Оффлайн kot_oo

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-10-11
  • Сайт: 
  • Профессия: Программист 1С
у поля ввода есть событие - Открытие.
Создайте процедуру-обработчик этого события с вот таким кодом:
Процедура ПолеВвода1Открытие(Элемент, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
ЗначениеЭлемента = Элемент.Значение;
Если ЗначениеЗаполнено(ЗначениеЭлемента) Тогда
ФормаЭлемента = ЗначениеЭлемента.ПолучитьФорму(,,);
ФормаЭлемента.ТолькоПросмотр = Истина;
ФормаЭлемента.Открыть();
КонецЕсли;
КонецПроцедуры

Спасибо
Добавлено: 11 Окт 2013, 15:56

у поля ввода есть событие - Открытие.
Создайте процедуру-обработчик этого события с вот таким кодом:
Процедура ПолеВвода1Открытие(Элемент, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
ЗначениеЭлемента = Элемент.Значение;
Если ЗначениеЗаполнено(ЗначениеЭлемента) Тогда
ФормаЭлемента = ЗначениеЭлемента.ПолучитьФорму(,,);
ФормаЭлемента.ТолькоПросмотр = Истина;
ФормаЭлемента.Открыть();
КонецЕсли;
КонецПроцедуры

В 8.2 не получилось, ругается

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
ах да, я не уточнил. мой код для обычных форм. не для управляемых.

Оффлайн kot_oo

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-10-11
  • Сайт: 
  • Профессия: Программист 1С
ах да, я не уточнил. мой код для обычных форм. не для управляемых.

Спасибо, что нибудь придумаем

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
на сколько я понял, для управляемого приложения вместо
ЗначениеЭлемента = Элемент.Значение;
нужно использовать
ЗначениеЭлемента = Объект.Реквизит1;

где Реквизит1 - имя реквизита, который вам надо открыть.

Второе изменение - вместо
ФормаЭлемента = ЗначениеЭлемента.ПолучитьФорму(,,);
будет
П = Новый Структура("Ключ", Поставщик);
Форма = ПолучитьФорму("Справочник.Контрагенты.ФормаОбъекта", П);
Форма.Открыть();

только параметры формы надо будет задать ваши (в зависимости от типа реквизита)

Оффлайн kot_oo

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-10-11
  • Сайт: 
  • Профессия: Программист 1С
на сколько я понял, для управляемого приложения вместо
ЗначениеЭлемента = Элемент.Значение;
нужно использовать
ЗначениеЭлемента = Объект.Реквизит1;

где Реквизит1 - имя реквизита, который вам надо открыть.

Второе изменение - вместо
ФормаЭлемента = ЗначениеЭлемента.ПолучитьФорму(,,);
будет
П = Новый Структура("Ключ", Поставщик);
Форма = ПолучитьФорму("Справочник.Контрагенты.ФормаОбъекта", П);
Форма.Открыть();

только параметры формы надо будет задать ваши (в зависимости от типа реквизита)

Открывает пустую форму для записи,
изменил стандартную обработку на истину, открывает сначало заполненую форму, потом открывает пустую форму для заполнения

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
стандартную обработку на истину точно менять не стоит. в этом случае весь остальной код смысла не имеет - будет открыта стандартная форма, а потом только код выполнится, что вы и наблюдаете

Оффлайн kot_oo

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-10-11
  • Сайт: 
  • Профессия: Программист 1С
стандартную обработку на истину точно менять не стоит. в этом случае весь остальной код смысла не имеет - будет открыта стандартная форма, а потом только код выполнится, что вы и наблюдаете

Я вот только не пойму почему она пустая открывается без заполненных реквизитов объекта


Теги:
 

Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15908
Последний ответ 16 Авг 2012, 12:07
от Will
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7735
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4773
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 1579
Последний ответ 25 Май 2016, 19:38
от marshalbratsk
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8486
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
48 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 335
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal