Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 09:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помощь с процедурами  (Прочитано 2644 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kot_oo

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-10-11
  • Сайт: 
  • Профессия: Программист 1С
Есть код модуля документа,
Суть помощи в том, нужно проверить новый ли это документ или нет,
если новый тогда сделать не доступным поля "ОбОрганизации" "Группа3" "Группа2" "ОЗаказе", до выбора вида ТС.
 
А если открыт для редактирования все нужные поля были видны если были скрыты и были доступны для редактирования

Вроде все работает но как то не так как нужно

Скину скриншоты на почту, сюда не разобрался как загружать



Процедура ПриОткрытии(Отказ)
Если Объект.Ссылка.Пустая() Тогда     
  Дата = НачалоНедели(Дата);
КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды,ПараметрыВыполненияКоманды)
//{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
ТабДок = Новый ТабличныйДокумент;
Печать (ТабДок,ПараметрКоманды);
ТабДок.Показать();
//}}
КонецПроцедуры
&НаСервере
Процедура Печать(ТабДок, ПараметрПечать)
Справочники.Номенклатура.Печать(ТабДок.ПараметрКоманды);
КонецПроцедуры


&НаКлиенте
Процедура АвтобусПриИзменении(Элемент)
Если Объект.Автобус тогда
Элементы.Легковой.Доступность = Ложь;
Элементы.Грузовой.Доступность = Ложь;
Элементы.ГрузовойСПрицепом.Доступность = Ложь;
Элементы.СпецТехника.Доступность = Ложь;
Элементы.ВыборАвтобус.Видимость = Истина;
Элементы.ОбОрганизации.Доступность = Истина;
Элементы.ОЗаказе.Доступность = Истина;
Элементы.Группа3.Доступность = Истина;
Элементы.Группа2.Доступность = Истина;

Иначе
Элементы.ОбОрганизации.Доступность = Ложь;
Элементы.Группа3.Доступность = Ложь;
Элементы.Группа2.Доступность = Ложь;
Элементы.ОЗаказе.Доступность = Ложь;
Элементы.ВыборАвтобус.Видимость = Ложь;
Элементы.Легковой.Доступность = Истина;
Элементы.Грузовой.Доступность = Истина;
Элементы.ГрузовойСПрицепом.Доступность = Истина;
Элементы.СпецТехника.Доступность = Истина;
КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура ЛегковойПриИзменении(Элемент)
Если Объект.Легковой тогда
Элементы.Автобус.Доступность = Ложь;
Элементы.Грузовой.Доступность = Ложь;
Элементы.ГрузовойСПрицепом.Доступность = Ложь;
Элементы.СпецТехника.Доступность = Ложь;
Элементы.ВыборЛегковой.Видимость = Истина;
Элементы.ОбОрганизации.Доступность = Истина;
Элементы.ОЗаказе.Доступность = Истина;
Элементы.Группа3.Доступность = Истина;
Элементы.Группа2.Доступность = Истина;

Иначе
Элементы.ОбОрганизации.Доступность = Ложь;
Элементы.Группа3.Доступность = Ложь;
Элементы.Группа2.Доступность = Ложь;
Элементы.ОЗаказе.Доступность = Ложь;

Элементы.ВыборЛегковой.Видимость = Ложь;
Элементы.Автобус.Доступность = Истина;
Элементы.Грузовой.Доступность = Истина;
Элементы.ГрузовойСПрицепом.Доступность = Истина;
Элементы.СпецТехника.Доступность = Истина;
КонецЕсли;

КонецПроцедуры

 &НаКлиенте
Процедура ГрузовойПриИзменении(Элемент)
Если Объект.Грузовой тогда
Элементы.Легковой.Доступность = Ложь;
Элементы.Автобус.Доступность = Ложь;
Элементы.ГрузовойСПрицепом.Доступность = Ложь;
Элементы.СпецТехника.Доступность = Ложь;
Элементы.ВыборГрузовойСПрицепом.Видимость = Истина;

Элементы.ОбОрганизации.Доступность = Истина;
Элементы.ОЗаказе.Доступность = Истина;
Элементы.Группа3.Доступность = Истина;
Элементы.Группа2.Доступность = Истина;

Иначе
Элементы.ОбОрганизации.Доступность = Ложь;
Элементы.Группа3.Доступность = Ложь;
Элементы.Группа2.Доступность = Ложь;
Элементы.ОЗаказе.Доступность = Ложь;

Элементы.ВыборГрузовойСПрицепом.Видимость = Ложь;
Элементы.Легковой.Доступность = Истина;
Элементы.Автобус.Доступность = Истина;
Элементы.ГрузовойСПрицепом.Доступность = Истина;
Элементы.СпецТехника.Доступность = Истина;
КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура ГрузовойСПрицепомПриИзменении(Элемент)
Если Объект.ГрузовойСПрицепом тогда
Элементы.Легковой.Доступность = Ложь;
Элементы.Грузовой.Доступность = Ложь;
Элементы.Автобус.Доступность = Ложь;
Элементы.СпецТехника.Доступность = Ложь;
Элементы.ВыборГрузовойСПрицепом.Видимость = Истина;

Элементы.ОбОрганизации.Доступность = Истина;
Элементы.ОЗаказе.Доступность = Истина;
Элементы.Группа3.Доступность = Истина;
Элементы.Группа2.Доступность = Истина;

Иначе
Элементы.ОбОрганизации.Доступность = Ложь;
Элементы.Группа3.Доступность = Ложь;
Элементы.Группа2.Доступность = Ложь;
Элементы.ОЗаказе.Доступность = Ложь;

Элементы.ВыборГрузовойСПрицепом.Видимость = Ложь;
Элементы.Легковой.Доступность = Истина;
Элементы.Грузовой.Доступность = Истина;
Элементы.Автобус.Доступность = Истина;
Элементы.СпецТехника.Доступность = Истина;
КонецЕсли;

КонецПроцедуры

 &НаКлиенте
Процедура СпецТехникаПриИзменении(Элемент)
Если Объект.СпецТехника тогда
Элементы.Легковой.Доступность = Ложь;
Элементы.Грузовой.Доступность = Ложь;
Элементы.ГрузовойСПрицепом.Доступность = Ложь;
Элементы.Автобус.Доступность = Ложь;
Элементы.ВыборСпецТехника.Видимость = Истина;

Элементы.ОбОрганизации.Доступность = Истина;
Элементы.ОЗаказе.Доступность = Истина;
Элементы.Группа3.Доступность = Истина;
Элементы.Группа2.Доступность = Истина;

Иначе
Элементы.ОбОрганизации.Доступность = Ложь;
Элементы.Группа3.Доступность = Ложь;
Элементы.Группа2.Доступность = Ложь;
Элементы.ОЗаказе.Доступность = Ложь;

Элементы.ВыборСпецТехника.Видимость = Ложь;
Элементы.Легковой.Доступность = Истина;
Элементы.Грузовой.Доступность = Истина;
Элементы.ГрузовойСПрицепом.Доступность = Истина;
Элементы.Автобус.Доступность = Истина;
КонецЕсли;

КонецПроцедуры


Последний раз редактировалось: MuI_I_Ika; 11 Окт 2013, 13:25


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Много кода непонятно куда смотреть. У документа есть метод ЭтоНовый() я думаю его и нужно использовать.

Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • Глобальный модератор
  • *****
  • Сообщений: 1376
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
Много кода непонятно куда смотреть. У документа есть метод ЭтоНовый() я думаю его и нужно использовать.
Это опять управляемые формы. Там этот метод не работает...
Ведь недавно такая тема уже была.



Автор! Вам сюда: http://forum-1c.ru/index.php?topic=32092.msg95071#msg95071

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
Там этот метод не работает...
ЭтоНовый() работает независимо от типа формы, но это к данному случаю не относится, т.к. приведен код модуля формы, начало правильное
Процедура ПриОткрытии(Отказ)
Если Объект.Ссылка.Пустая() Тогда     
  Дата = НачалоНедели(Дата);
КонецЕсли;
КонецПроцедуры
а дальше начинатеся нагромождение кода, без скрина формы не разобраться

Оффлайн kot_oo

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-10-11
  • Сайт: 
  • Профессия: Программист 1С
Много кода непонятно куда смотреть. У документа есть метод ЭтоНовый() я думаю его и нужно использовать.

В 8.2 ругается на ЭтоНовый ()
Добавлено: 11 Окт 2013, 14:41

Там этот метод не работает...
ЭтоНовый() работает независимо от типа формы, но это к данному случаю не относится, т.к. приведен код модуля формы, начало правильное
Процедура ПриОткрытии(Отказ)
Если Объект.Ссылка.Пустая() Тогда     
  Дата = НачалоНедели(Дата);
КонецЕсли;
КонецПроцедуры
а дальше начинатеся нагромождение кода, без скрина формы не разобраться

http://vk.com/album74255545_180930296 Здесь выложил скриншоты
Добавлено: 11 Окт 2013, 14:42

Там этот метод не работает...
ЭтоНовый() работает независимо от типа формы, но это к данному случаю не относится, т.к. приведен код модуля формы, начало правильное
Процедура ПриОткрытии(Отказ)
Если Объект.Ссылка.Пустая() Тогда     
  Дата = НачалоНедели(Дата);
КонецЕсли;
КонецПроцедуры
а дальше начинатеся нагромождение кода, без скрина формы не разобраться

http://vk.com/album74255545_180930296 вот тут скриншоты

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Ругается потому что метод ЭтоНовый(), это метод объекта, а не формы! И вызывать его нужно в контексте ОБЪЕКТА.
Не вижу ничего страшного в использовании такой конструкции для проверки записан ли элемент или нет.
Если Объект.Ссылка.Пустая() Тогда

Уважаемый(ая) kot_oo, на этом форуме прекрасно прикрепляются скриншоты! (Предварительный просмотр - Вложения и другие параметры - Выберите файл)

По вашему вопросу: Слишком много непонятного кода, ЧТО НЕ РАБОТАЕТ ТО?
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн kot_oo

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2013-10-11
  • Сайт: 
  • Профессия: Программист 1С
Ругается потому что метод ЭтоНовый(), это метод объекта, а не формы! И вызывать его нужно в контексте ОБЪЕКТА.
Не вижу ничего страшного в использовании такой конструкции для проверки записан ли элемент или нет.
Если Объект.Ссылка.Пустая() Тогда

Уважаемый(ая) kot_oo, на этом форуме прекрасно прикрепляются скриншоты! (Предварительный просмотр - Вложения и другие параметры - Выберите файл)

По вашему вопросу: Слишком много непонятного кода, ЧТО НЕ РАБОТАЕТ ТО?

Уже все работает)))


 

Нужна помощь про "Отчет о смене без гашение" и "Z отчет"

Автор Serg85Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3758
Последний ответ 23 Ноя 2014, 12:36
от дфтын
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2758
Последний ответ 27 Май 2016, 15:19
от Олька Бякина
Нужна помощь по "Управление торговлей 10.3"

Автор werstakРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1972
Последний ответ 26 Мар 2011, 12:50
от werstak
Нужна помощь в формировании отчета "Преобразование значения к типу Дата не может быть выполнено"

Автор STLuka1337Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2092
Последний ответ 14 Ноя 2014, 13:24
от cska-fanat-kz
Нужна помощь специалиста 1С (v8.1) (программиста) по работе с "Бухгалтерией"

Автор lx470Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2385
Последний ответ 24 Фев 2011, 15:25
от lx470

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 768
  • Точка Скрытых: 0
  • Точка Пользователей: 14
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal