Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2018, 16:05
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: перемещать строки табличной части документа  (Прочитано 9679 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mikel10

  • ***
  • Сообщений: 108
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-01
  • Сайт: 
Всем добрый день! управление торговлей. Я создал новый документ ЗаданиеКурьера. Разместил в нем табличную часть ТабличнаяЧасть1. Сверху табл части я разместил стрелки вверх, вниз. Помогите написать операторы которые перемещают строки табл части вверх или вниз. Заранее благодарен.


Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
а разве на форме нет стрелок по умолчанию вверх и вниз?

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1348
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
форма то обычная, не управляемая, как я понимаю?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Честно говоря такая тема поднимается последнее время очень часто... Решил выложить решение
Для обычных форм
Процедура КоманднаяПанель2Вверх(Кнопка)

текСтрока = ЭлементыФормы.ТабличнаяЧасть1.ТекущаяСтрока;
Если текСтрока.НомерСтроки > 1 Тогда
ТабличнаяЧасть1.Сдвинуть(текСтрока,-1);
КонецЕсли;

КонецПроцедуры

Процедура КоманднаяПанель2Вниз(Кнопка)

текСтрока = ЭлементыФормы.ТабличнаяЧасть1.ТекущаяСтрока;
Если текСтрока.НомерСтроки < ТабличнаяЧасть1.Количество() Тогда
ТабличнаяЧасть1.Сдвинуть(текСтрока,1);
КонецЕсли;

КонецПроцедуры
Для управляемых форм (в принципе тоже самое)
&НаКлиенте
Процедура Вверх(Команда)

текСтрока = Элементы.ТабличнаяЧасть1.ТекущиеДанные;
Если текСтрока.НомерСтроки > 1 Тогда
Объект.ТабличнаяЧасть1.Сдвинуть(текСтрока.НомерСтроки-1,-1);
КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура Вниз(Команда)

текСтрока = Элементы.ТабличнаяЧасть1.ТекущиеДанные;
Если текСтрока.НомерСтроки < Объект.ТабличнаяЧасть1.Количество() Тогда
Объект.ТабличнаяЧасть1.Сдвинуть(текСтрока.НомерСтроки-1,1);
КонецЕсли;

КонецПроцедуры
Во вложении обработка
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1348
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
ну на самом деле, вот похожая тема http://forum-1c.ru/index.php?topic=32113.msg95139#msg95139
кнопки перемещения есть и в обычных формах и в управляемых в командной панели. не вижу смысла кодом что-то писать (ну или такое решение должно быть чем-то обосновано, разъяснено, почему нельзя пользоваться стандартными средствами)


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Колледж, задание от препода... (буквально недавно слышал такое обоснование)
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1348
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
ну это и есть веская причина :)
обучение - штука нужная


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4855
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8273
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5520
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 10302
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7841
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
159 Сообщений
alex0402
74 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
59 Сообщений
buketov.av buketov.av
44 Сообщений
wise wise
39 Сообщений
KOI8-R
34 Сообщений
ilyay ilyay
29 Сообщений
Alter
28 Сообщений
Анюта17
28 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal