Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
26 Май 2018, 09:23
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Преобразование элемента списка значений в строку  (Прочитано 5217 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн JoeButcher

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2010-12-28
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте!
Подскажите пожалуйста, в чем я не прав:
на форме в поле списка находится список значений (содержит ФИО сотрудников). Пытаюсь получить элементы списка
Для Каждого Элемент Из ЭлементыФормы.ПолеСписка1.Значение  Цикл
                Сообщить(Элемент.Значение)
КонецЦикла;
Так все работает, но при попытке замены на Сообщить(Строка(Элементы.Значение)) получается не строка а неопределенное значение.
Заранее спасибо за помощь.
         



Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
Сообщить(Строка(Элемент.Значение)) Может Элемент,а не Элементы?)

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1348
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
ошибки такой код не дает?
вот такой примерно: "Итератор для значения не определен   Для Каждого Элемент Из ЭлементыФормы.ПолеСписка1.Значение Цикл"??
вообще,
ЭлементыФормы.ПолеСписка1.Значение
вот это - текущее выбранное значение, а не весь список выбора.
Список выбора открывается через одноименное свойство. Попробуйте так:
Для Каждого Элемент Из ЭлементыФормы.ПолеСписка1.СписокВыбора Цикл
Сообщить(Элемент.Значение)
КонецЦикла;


Оффлайн JoeButcher

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2010-12-28
  • Сайт: 
  • Профессия: Ученик 1С
Сообщить(Строка(Элемент.Значение)) Может Элемент,а не Элементы?)
Сорри, это уже моя опечатка. В коде "Элемент"
Добавлено: 08 Окт 2013, 05:52

ошибки такой код не дает?
вот такой примерно: "Итератор для значения не определен   Для Каждого Элемент Из ЭлементыФормы.ПолеСписка1.Значение Цикл"??
вообще,
ЭлементыФормы.ПолеСписка1.Значение
вот это - текущее выбранное значение, а не весь список выбора.
Список выбора открывается через одноименное свойство. Попробуйте так:
Для Каждого Элемент Из ЭлементыФормы.ПолеСписка1.СписокВыбора Цикл
Сообщить(Элемент.Значение)
КонецЦикла;
Нет, ошибок код не выдает, просто возвращает значение "Не определено", хотя без преобразования к строковому типу все работает. Как я уже сказал, ПолеСписка1.Значение имеет тип СписокЗначений, а "СписокВыбора", насколько я понимаю - это другой элемент формы, у Поля списка такого свойства нет.


Теги:
 

Обнаружено дублирование ключевых значений в колонке ссылка ["обнаружено дублирование ключевых з

Автор lianinfoРаздел Пользователям "1С - Предприятие 8"

Ответов: 10
Просмотров: 688
Последний ответ 20 Мар 2018, 16:54
от alex0402
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 524
Последний ответ 12 Окт 2017, 14:02
от wise
"Таблица значений" в результате запроса - 1С

Автор mvk843Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 1313
Последний ответ 15 Июн 2017, 07:53
от mvk843
Ошибка - Обнаружено дублирование ключевых значений в колонке "Ссылка". Отображение данных в списке не возможно.

Автор welldoneРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5487
Последний ответ 24 Ноя 2015, 15:38
от welldone
"Проверка мутабельных значений на заполненность не поддерживается"

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 22931
Последний ответ 13 Фев 2011, 17:36
от proofet

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
164 Сообщений
alex0402
72 Сообщений
oleg-x
63 Сообщений
AIFrame AIFrame
54 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
KOI8-R
31 Сообщений

* Кто онлайн

  • Точка Гостей: 184
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal