Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2018, 05:22
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Загрузка данных в табличную часть  (Прочитано 7648 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Sasha133

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2013-10-07
  • Сайт: 
  • Профессия: Программист 1С
Всем добрый день!

Подскажите пожалуйста , есть документ Затаривание продукции, у него есть табличная часть я запросом из документа РапортНаВыработку подружаю туда все необходимую номенклатуру, но к сожалению подгружается все документы, хотел сделать фильтр по дате, но ругается на то что у документа Затаривание нет этого поля....

Вопрос: как сделать отбор из одного документа, чтобы подругружались данные в другой документ тч с выбором даты

Процедура ЗаполнитьТабличнуюЧастьДокументаПоРапорту()Экспорт
   
      
   Запрос = Новый Запрос;
     Запрос.Текст ="ВЫБРАТЬ
                 |   ц_РапортФ114.Номенклатура,
                 |   ц_РапортФ114.Дата,
                 |   ц_РапортФ114.Контрагент,
                 |   ц_РапортФ114.Стоимость,
                 |   ц_РапортФ114.ВесПродукции
                 |ИЗ
                 |   Документ.ц_РапортФ114 КАК ц_РапортФ114
                 |ГДЕ
                 |   ц_РапортФ114.Дата МЕЖДУ &НачДата И &КонДата";
   
   
                                   Выборка = Запрос.Выполнить().Выбрать();

Пока Выборка.Следующий() Цикл
      НоваяСтрока = Продукция.Добавить();
      ЗаполнитьЗначенияСвойств(НоваяСтрока, Выборка);
КонецЦикла;

   КонецПроцедуры


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
укажите полностью текст ошибки

Оффлайн Sasha133

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2013-10-07
  • Сайт: 
  • Профессия: Программист 1С
Запрос = Новый Запрос;
     Запрос.Текст ="ВЫБРАТЬ
                 |   ц_РапортФ114.Номенклатура,
                 |   ц_РапортФ114.Дата,
                 |   ц_РапортФ114.Контрагент,
                 |   ц_РапортФ114.Стоимость,
                 |   ц_РапортФ114.ВесПродукции
                 |ИЗ
                 |   Документ.ц_РапортФ114 КАК ц_РапортФ114
                 |ГДЕ
                 |   ц_РапортФ114.Дата МЕЖДУ &НачДата И &КонДата";
            
                Запрос.УстановитьПараметр("НачДата", Документы.ц_РапортФ114.Дата());
   Запрос.УстановитьПараметр("КонДата",  Документы.ц_РапортФ114.Дата);

   
      Выборка = Запрос.Выполнить().Выбрать();

Пока Выборка.Следующий() Цикл
      НоваяСтрока = Продукция.Добавить();
      ЗаполнитьЗначенияСвойств(НоваяСтрока, Выборка);
КонецЦикла;

Добавлено: 07 Окт 2013, 15:40

Вообщем смысл получается такой что мне в документе Затаривание продукции при нажатии кнопки ЗАПОЛНИТЬ нужно заполнить табличную часть которая берется из документа РАПОРТ Ф114 с возможностью отбора по дате в документе затаривание...

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
повторю просьбу.
укажите полностью текст ошибки

Оффлайн Sasha133

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2013-10-07
  • Сайт: 
  • Профессия: Программист 1С
повторю просьбу.
укажите полностью текст ошибки

Оффлайн acanta

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 1
  • КПД: 8%
  • Регистрация: 2012-01-12
  • Сайт: 
  • Профессия: Программист 8.1
Попробуйте вместо .Дата() указать .НачДата

Оффлайн Sasha133

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2013-10-07
  • Сайт: 
  • Профессия: Программист 1С
я не понимаю в чем конкретно ваша проблема.
что именно не получается?

Не получается сделать фильтр даты !. ( НачДата КонДата) без фильтра подгружает все имеющиеся рапорта а это не нужно...

Оффлайн sdilshod

  • **
  • Сообщений: 76
  • РЕПУТАЦИЯ: 11
  • КПД: 14%
  • Регистрация: 2013-09-30
  • Сайт: 
  • Профессия: Программист 1С
 
  Запрос.УстановитьПараметр("НачДата", ЭлементыФормы.НачДата.Значение);
   Запрос.УстановитьПараметр("КонДата", ЭлементыФормы.КонДата.Значение);

Если НачДата и КонДата это реквизиты формы то можно передать

   Запрос.УстановитьПараметр("НачДата", НачДата);
   Запрос.УстановитьПараметр("КонДата", КонДата);


Оффлайн Sasha133

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 1
  • КПД: 2%
  • Регистрация: 2013-10-07
  • Сайт: 
  • Профессия: Программист 1С
  Запрос.УстановитьПараметр("НачДата", ЭлементыФормы.НачДата.Значение);
   Запрос.УстановитьПараметр("КонДата", ЭлементыФормы.КонДата.Значение);

Если НачДата и КонДата это реквизиты формы то можно передать

   Запрос.УстановитьПараметр("НачДата", НачДата);
   Запрос.УстановитьПараметр("КонДата", КонДата);

это прост элементы формы попробовал выдает тоже ошибку

{Документ.ц_ЗатариваниеПродукции(138)}: Поле объекта не обнаружено (ЭлементыФормы)
             Запрос.УстановитьПараметр("НачДата", ЭлементыФормы.НачДата.Значение);

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
ну вы читать же умеете?
написано - нет такого метода.
скобки в конце зачем? все что со скобками - это методы (процедуры и функции).
это первая часть ответа.

вторая часть:
Документы.ц_РапортФ114.Дата() - что конкретно вы хотели таким образом получить?
дату документа ц_РапортФ114? какого именно?
ЛИКБЕЗ: Документы.ц_РапортФ114 - вот это менеджер объекта документ ц_РапортФ114 (читайте синтаксис-помощник, документацию). у менеджера даты быть не может априори. дата может быть только у объекта (или у ссылки на объект, т.е. по сути все равно у объекта)


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7630
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3964
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2229
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 7670
Последний ответ 15 Окт 2015, 11:21
от Mari_beginner
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 7146
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
99 Сообщений
AIFrame
65 Сообщений
alex0402
32 Сообщений
kiksi
26 Сообщений
pavl_vs
24 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
KOI8-R
14 Сообщений
MuI_I_Ika MuI_I_Ika
13 Сообщений

* Кто онлайн

  • Точка Гостей: 119
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal