Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 04:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Перебор и изменение значений полей табличной части (макет)  (Прочитано 3816 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Compodoctor

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-09-28
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте
Есть вот такой код

ВыборкаТаблица = Выборка.Таблица.Выбрать();
       

Пока ВыборкаТаблица.Следующий() Цикл
        Таблица.Параметры.Заполнить(ВыборкаТаблица);
    Если Таблица.Параметры.Скрытое = Истина тогда
        //нумерация строк

        Номер = Номер + 1;
        Таблица.Параметры.Строка = Номер;
        //Скрытое = ""

        Таблица.Параметры.Скрытое = "";
               
        Для Каждого Параметр Из Таблица.Параметры Цикл
           //Вот собстнно больное место

                   Если Параметр = Ложь Тогда Таблица.Параметры.Параметр = "";
           КонецЕсли;
           Сообщить(Параметр);   
            КонецЦикла;
               
    ТабДок.Вывести(Таблица, ВыборкаТаблица.Уровень());
    КонецЕсли;
КонецЦикла;

Он заполняет таблицу макета с условием, что поле "Скрытое" = Истина.
Существует еще три поля Булевого типа. Они выводятся в виде "Да" или "Нет"
Хочу для удобочитаемости скрыть значение полей = Ложь.
Есть вариант вручную прописать условие для каждого поля, но это как то не по программерски. Может быть есть варики обратиться к каждому полю через цикл? Там где //больное место, выдает ошибку, что поля Параметр - нету.
Вдумчиво так


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Так может его действительно нету. Что есть Таблица.Параметры?

Оффлайн acanta

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 1
  • КПД: 8%
  • Регистрация: 2012-01-12
  • Сайт: 
  • Профессия: Программист 8.1
Предположение. Макет таблицы?
Добавлено: 04 Окт 2013, 20:34

Параметры.Количество()
Параметры.Получить()
Параметры.Установить()
Цикл наверное можно через счетчик,но не пробовала.

Последний раз редактировалось: acanta; 04 Окт 2013, 20:34. Причина: Объединение сообщений

Оффлайн Compodoctor

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-09-28
  • Сайт: 
  • Профессия: Ученик 1С
Всем спасибо. Решилось вообще просто - форматированием ячеек макета )
Вдумчиво так


Теги:
 

"Уникальность" строки таблиной части документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1958
Последний ответ 20 Авг 2014, 12:22
от has
Работа с табличной частью в документе. Или Работа с ШАПКОЙ документа

Автор gorbach178500Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3064
Последний ответ 30 Сен 2011, 20:01
от gorbach178500
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 275
Последний ответ 12 Окт 2017, 14:02
от wise
УТ 11ред. Есть ли возможность указать серии в заказе покупателя?( в табл. части)

Автор tsaboevРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3099
Последний ответ 02 Июл 2012, 13:11
от totutotam
Применять ПСН относительно доходов, полученных от субаренды части нежилого помещения, нельзя

Автор newsРаздел Новости

Ответов: 0
Просмотров: 671
Последний ответ 23 Июн 2015, 14:25
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
62 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 182
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal