Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 20:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сформировать последнюю цену  (Прочитано 2123 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dezmont89

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 2
  • КПД: 9%
  • Регистрация: 2013-10-04
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте уважаемые программисты.
Есть такое задание вытащить цену последнего поступления каждого товара, ну и сформировать все это в таблице.
Так вот в 7.7 я никогда не работал, помогите как это можно сделать? Пользуясь поиском то что мне могло бы помочь я не нашел, или я не знаю что искать.
Бух общ.


Оффлайн Herby

  • *****
  • Сообщений: 936
  • РЕПУТАЦИЯ: 164
  • КПД: 18%
  • Регистрация: 2010-08-31
  • Сайт: 
  • Профессия: Программист 7.7
Если вы никогда не работали в 7.7, то советами и консультацией вам сложно помочь.
Ищите людей, кто готов решить для вас эту задачу платно или бесплатно...

Я бы мог помочь, но ухожу в отпуск через 20 минут.

Последний раз редактировалось: Herby; 04 Окт 2013, 17:38

Оффлайн Dezmont89

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 2
  • КПД: 9%
  • Регистрация: 2013-10-04
  • Сайт: 
  • Профессия: Ученик 1С
Я бы мог помочь, но ухожу в отпуск через 20 минут.
Повезло))

Ну вот набросал, но он меддленный. И так делать скорей всего нельзя :wacko:
Если ГруппироватьПоСкладам = 1 Тогда
БИ.ИспользоватьСубконто(ВидыСубконто.МестаХранения,,1);
КонецЕсли;
БИ.ИспользоватьСубконто(ВидыСубконто.Материалы,,1);
БИ.ВыполнитьЗапрос(ДатаФормирования, ДатаФормирования, СчетПоКоду("10.1"));
Если ГруппироватьПоСкладам = 1 Тогда
БИ.ВыбратьСубконто(ВидыСубконто.МестаХранения);
ДалееЦикл = БИ.ПолучитьСубконто(ВидыСубконто.МестаХранения);
Склад = БИ.Субконто(ВидыСубконто.МестаХранения);
Таб.ВывестиСекцию("Склад");
Иначе
ДалееЦикл = 1;
КонецЕсли;
Пока ДалееЦикл = 1 Цикл
БИ.ВыбратьСубконто(ВидыСубконто.Материалы);
Пока БИ.ПолучитьСубконто(ВидыСубконто.Материалы) = 1 Цикл
Материал = БИ.Субконто(ВидыСубконто.Материалы);
Таб.ВывестиСекцию("Строка|Наименование");
Количество = БИ.СКД("К");
Стоимость = БИ.СКД("С");
///////////////////////////////////////////////
Если (ОтображатьПосЦену=1) Тогда     
Кол=0; СТ=0;
  // БИ1 = СоздатьОбъект("БухгалтерскиеИтоги"); 
    БИ1.ИспользоватьСубконто(ВидыСубконто.Материалы,Материал,2);
             БИ1.ВыполнитьЗапрос(ДобавитьМесяц(ДатаФормирования,-6) ,ДатаФормирования,"10.1","60.1",,,3, "Операция");
        БИ1.ВыбратьСубконто(ВидыСубконто.Материалы,Материал,2); 

            Если (БИ1.СКД("К")>0)  Тогда 

                БИ1.ВыбратьПериоды();
                Пока БИ1.ПолучитьПериод() = 1 Цикл
                                       Если (Найти(Би1.Операция, "справка" )=0)  Тогда   
   Кол=БИ1.ДО("К");
  Ст=БИ1.ДО("С");
КонецЕсли;
            КонецЦикла;               
            КонецЕсли;
             КонецЕсли;

Оффлайн slavyan

  • *
  • Сообщений: 18
  • РЕПУТАЦИЯ: 2
  • КПД: 11%
  • Регистрация: 2012-01-09
  • Сайт: 
  • Профессия: Программист 1С
либо по бух итогам либо по докам поступления, результаты занести в Табл значений отсортировать по дате и взять из последней колонки результат


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 262
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal