Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 02:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Расчет себестоимости  (Прочитано 2716 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
Здраствуйте друзья!!!

Пишу самописную простенькую торговлю.
Нужно реализовать учет себестоимости по Методу ФИФИ и Средней.

Пните в нужно напровлении или кусок кода дайте где это реализованно или конфа самописная где это есть.


Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Здраствуйте друзья!!!

Пишу самописную простенькую торговлю.
Нужно реализовать учет себестоимости по Методу ФИФИ и Средней.

Пните в нужно напровлении или кусок кода дайте где это реализованно или конфа самописная где это есть.


Может быть ФИФО? :xfbnsdfb:
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
ага, опечатался :D

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Pavel779

  • ***
  • Сообщений: 145
  • РЕПУТАЦИЯ: 3
  • КПД: 2%
  • Регистрация: 2011-11-01
  • Сайт: 
  • Профессия: Консультант 1С
СПАСИБО
Добавлено: 03 Окт 2013, 00:29

обясните откуда здесь берется переменная (СРЕДНЯЯ)

//получение учетной политики
МетодСписания = РегистрыСведений.МетодСписанияТоваров.ПолучитьПоследнее(Дата).МетодСписания;
//Вот эта вот перменная в самом начале (СРЕДНЯЯ)
Средняя = МетодСписания = Перечисления.УчетнаяПолитика.Средняя;

//запись движений
Движения.ОстаткиНоменклатуры.Записывать = Истина;
Для Каждого ТекСтрокаСписокНоменклатуры Из СписокНоменклатуры Цикл
Если ТекСтрокаСписокНоменклатуры.Номенклатура.Услуга Тогда
Продолжить;
КонецЕсли;
Движение = Движения.ОстаткиНоменклатуры.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
Движение.Период = Дата;
Движение.Номенклатура = ТекСтрокаСписокНоменклатуры.Номенклатура;
Если Не Средняя Тогда // если метод списания средняя – не следует записывать документ партия
Движение.Партия = Ссылка;
КонецЕсли;
Движение.Количество = ТекСтрокаСписокНоменклатуры.Количество;
Движение.Сумма = ТекСтрокаСписокНоменклатуры.Сумма;
КонецЦикла;

Я правельно понимаю, что здесь сначало идет   
Средняя = МетодСписания = Перечисления.УчетнаяПолитика.Средняя;
Присваивание а потом Сравнение.

Вот (МетодСписания) понятно это перменная в самом начале а (Средняя) откудова взялась.
Объесяните кто может!
Кусок кода взят ссылки выше!

Последний раз редактировалось: Pavel779; 03 Окт 2013, 00:29. Причина: Объединение сообщений

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Присваивание а потом Сравнение.
Присваивается переменной Средняя результат сравнения - т.е. БУЛЕВО
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4304
Последний ответ 24 Дек 2015, 15:34
от дфтын
Как создать нескольких документов "расчет при увольнении" на основании кадрового документа "увольнение" как Отпуска

Автор cozuРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3202
Последний ответ 21 Мар 2015, 20:24
от дфтын
1с82 ЗУП: Расчет по среднему:надбавка учитывается и не учитывается

Автор PushastРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 3841
Последний ответ 05 Окт 2011, 11:13
от Pushast
Отчет о НЕ уволенных сотрудниках и расчет начислений, как для уволенных

Автор medoedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3679
Последний ответ 02 Фев 2012, 14:49
от medoed
Расчет процента автоматической скидки и скидки наценки

Автор Max99990Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 4504
Последний ответ 31 Янв 2016, 02:33
от дфтын

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
61 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 152
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal