Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 20:17
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Открыть программно внешнюю печатную форму  (Прочитано 8473 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн BorisSPb

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 1
  • КПД: 9%
  • Регистрация: 2013-09-17
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте.

Стоит задача. Написать команду, которая бы открывала бы внешнюю печатную форму. В форме СерииНоменклатуры я создал следующую команду, которая бы открывала внешнюю печатную форму.

&НаКлиенте
Процедура ПечатьМ17()

ОткрытьФормуМодально("ВнешняяОбработка.ВнешняяПечатнаяФормаМ17", , ЭтаФорма);

КонецПроцедуры

Но такая процедура выдает ошибку:
{Справочник.СерииНоменклатуры.Форма.ФормаВыбораПоОстаткам.Форма(415)}: Ошибка при вызове метода контекста (ОткрытьФормуМодально)
ОткрытьФормуМодально("ВнешняяОбработка.ВнешняяПечатнаяФормаМ17", , ЭтаФорма);
по причине:
Неизвестное имя формы. Имя: "ВнешняяОбработка.ВнешняяПечатнаяФормаМ17"

Подскажите, пожалуйста, как обращаться к внешней печатной форме?


Оффлайн BorisSPb

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 1
  • КПД: 9%
  • Регистрация: 2013-09-17
  • Сайт: 
  • Профессия: Ученик 1С
Спасибо за код. Прокомментируйте, пожалуйста, куда нужно вставить имя внешней обработки?

И работает ли этот код, если внешняя обработка уже загружена в Дополнительеные отчеты и обработки? Я работаю в типовой конфигурации УП.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
С описанием и исправил ошибку из первого листинга...

//В данном примере не обрабатываются исключения
&НаКлиенте
Процедура ОткрытьВПФ(Команда) //Кнопка открытия формы
   
   СсылкаНаФайл = ПолучитьСсылкуНаФайлИзСправочника("Моя внешняя обработка"); //Имя обработки
   ОткрытьФорму("ВнешняяОбработка."+ВызовСервера(СсылкаНаФайл)+".Форма"); //Непосредственно открытие формы
   
КонецПроцедуры

&НаСервереБезКонтекста
Функция ВызовСервера(АдресХранилища) //Функция подключает обработку что бы к ней можно было обратиться
   
   Возврат ВнешниеОбработки.Подключить(АдресХранилища);
   
КонецФункции

&НаСервереБезКонтекста
Функция ПолучитьСсылкуНаФайлИзСправочника(ИмяФайла) //функция ищет по наименования ссылку на обработку и возвращает ссылку на реквизит "ХранилищеОбработки" найденной обработки
   
   Возврат ПолучитьНавигационнуюСсылку(Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию(ИмяФайла),"ХранилищеОбработки");
   
КонецФункции
   
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Печать штрих кодов на форму печати выводятся 3 штрих кода на принтер выходит только 2.

Автор ZSSРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 501
Последний ответ 15 Май 2017, 08:59
от ZSS
Передача параметров из ячейки поля табличного документа в форму создания нового документа 1с 8.3

Автор Анна БахановичРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 2994
Последний ответ 18 Фев 2016, 12:50
от Анна Баханович
Версия 8.3, при добавлении поля в форму списка не устанавливается вид поля - выпадающий список пустой

Автор Developer.KZРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 332
Последний ответ 22 Июн 2017, 10:50
от Developer.KZ
Как добавить внутреннюю обработку "Печать ТТН" на управляемую форму???

Автор ViktorkaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 8059
Последний ответ 11 Апр 2012, 17:14
от Vit1501
Как вывести табличный документ в форму "Печать документов"

Автор boldinovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2310
Последний ответ 03 Апр 2015, 17:50
от boldinov

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 347
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal