Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 19:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как пронумеровать столбец в макете ?  (Прочитано 2402 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
Здравствуйте!


Как пронумеровать столбец в макете (файл вложен) ?
Знаю, что нужно счетчик "включить", но как в 1С сделать не знаю :( .
Есть код :



&НаКлиенте
Процедура ОбработкаКоманды(ПараметрКоманды, ПараметрыВыполненияКоманды)
//{{_КОНСТРУКТОР_ПЕЧАТИ(Печать)
ТабДок = Новый ТабличныйДокумент;
Печать(ТабДок, ПараметрКоманды);


ТабДок.ОтображатьСетку = Ложь;
ТабДок.Защита = Ложь;
ТабДок.ТолькоПросмотр = Ложь;
ТабДок.ОтображатьЗаголовки = Ложь;
ТабДок.Показать();
//}}
КонецПроцедуры


&НаСервере
Процедура Печать(ТабДок, ПараметрКоманды)
Документы.АктОтправкиВРемонт.Печать(ТабДок, ПараметрКоманды);

КонецПроцедуры






Последний раз редактировалось: MuI_I_Ika; 25 Сен 2013, 11:08


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Все решается вот в этой процедуре

Документы.АктОтправкиВРемонт.Печать(ТабДок, ПараметрКоманды);

Там должен быть цикл в который и нужно добавить счетчик.

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
Начал писать:
&НаСервере
Процедура Печать(ТабДок, ПараметрКоманды)
ТабДок = Новый ТабличныйДокумент;
Макет = ПолучитьМакет ("Печать");

и сразу повалили ошибки:
{Документ.АктОтправкиВРемонт.Команда.Печать.МодульКоманды(19,10)}: Процедура или функция с указанным именем не определена (ПолучитьМакет)
   Макет = <<?>>ПолучитьМакет ("Печать"); (Проверка: Сервер)

КонецПроцедуры

Последний раз редактировалось: MuI_I_Ika; 25 Сен 2013, 18:55

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Подозреваю, что вы на форме пытаетесь получить макет. Правильнее будет писать данную процедуру в модуле объекта или модуле менеджера объекта. Поскольку на форме не доступен контекст объекта.

Многие извращаются получают объект на форме и уже таким образом вызывают его контекст, но я вам так поступать не советую.

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
Помогите пронумеровать. Никак не пойму что то не дописано :( Код:

Процедура Акт(ТабДок, Ссылка) Экспорт
//{{_КОНСТРУКТОР_ПЕЧАТИ(Акт)
Макет = Документы.АктОтправкиВРемонт.ПолучитьМакет("Акт");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| АктОтправкиВРемонт.Дата,
| АктОтправкиВРемонт.ТабличнаяЧасть.(
| СотрудникОтдела,
| Кабинет,
| Принтер,
| ИнвентарныйНомер,
| ЗаводскойНомер
| )
|ИЗ
| Документ.АктОтправкиВРемонт КАК АктОтправкиВРемонт
|ГДЕ
| АктОтправкиВРемонт.Ссылка В (&Ссылка)";
Запрос.Параметры.Вставить("Ссылка", Ссылка);
Выборка = Запрос.Выполнить().Выбрать();

ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьТабличнаяЧастьШапка = Макет.ПолучитьОбласть("ТабличнаяЧастьШапка");
ОбластьТабличнаяЧасть = Макет.ПолучитьОбласть("ТабличнаяЧасть");
Подвал = Макет.ПолучитьОбласть("Подвал");

ТабДок.Очистить();

Номер = 0;
ВставлятьРазделительСтраниц = Ложь;
Пока Выборка.Следующий() Цикл
Если ВставлятьРазделительСтраниц Тогда
ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
КонецЕсли;

ТабДок.Вывести(ОбластьЗаголовок);

ТабДок.Вывести(ОбластьТабличнаяЧастьШапка);
ВыборкаТабличнаяЧасть = Выборка.ТабличнаяЧасть.Выбрать();
Пока ВыборкаТабличнаяЧасть.Следующий() Цикл
ОбластьТабличнаяЧасть.Параметры.Заполнить(ВыборкаТабличнаяЧасть);
ТабДок.Вывести(ОбластьТабличнаяЧасть, ВыборкаТабличнаяЧасть.Уровень());
КонецЦикла;

Для Каждого Строка из ВыборкаТабличнаяЧасть.Выбрать() Цикл;
   ОбластьТабличнаяЧасть.Номер = Строка.Номер;
   ОбластьТабличнаяЧасть.СотрудникОтдела = Строка.СотрудникОтдела;
           Номер = Номер + 1;
КонецЦикла;
Подвал.Параметры.Заполнить(Выборка);
ТабДок.Вывести(Подвал);
 

ВставлятьРазделительСтраниц = Истина;
КонецЦикла;
//}}
КонецПроцедуры

Добавлено: 26 Сен 2013, 09:12

вопрос решился всем спасибо.

Последний раз редактировалось: MuI_I_Ika; 26 Сен 2013, 13:51


Теги:
 

Как "поймать" нажатие на кнопку "Печать" в открываемом макете(табличный документ)?

Автор taramz5Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1172
Последний ответ 14 Фев 2017, 14:27
от ilyay
Форматирование ячейки типа "Шаблон" в макете табличного документа

Автор KatishРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 19419
Последний ответ 11 Апр 2012, 11:13
от cska-fanat-kz
подскажите как сделать так,чтобы в макете в нужных графах автоматически подставлялась текущая дата.

Автор MikhailDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1493
Последний ответ 12 Авг 2015, 19:26
от SkyNetYar
как в макете отчета сделать, чтоб можно было переходить по выводимым ссылкам

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1027
Последний ответ 20 Апр 2016, 13:31
от ktu78
Система компоновки данных – как в макете реализовать сложение(вычитание) ячеек?

Автор sapravkaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3771
Последний ответ 14 Фев 2013, 22:34
от sapravka

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 275
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal