Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 14:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выгрузка печатной формы из 1 С в Ексель  (Прочитано 6846 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Tgr11

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-27
  • Сайт: 
Доброе утро, подскажите пожалуйста как быть в такой ситуации и как из нее лучше выйти.
Есть печатная форма документа, которую я выгружаю в Ексель, все отлично все выгружается как нужно мне, но есть одно большое НО, проблема в одной колонке ЕдиницаИзмерения, если у материала единица измерения 1 КОНСУЛЬТАЦИЯ , тогда программа при выгрузке делает мне ####, не определяет формат как общий и не переносит текст, если хотя бы в единице измерения 100 м2 окрашиваемой поверхности будет так и одна буква будет попадать на первую строку, то все ОКЕЙ, а если при переносе на первой строке цифра а на второй слово, то все при выгрузке одни ###, подскажите что делать мне в такой ситации?


Оффлайн Tgr11

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-27
  • Сайт: 
расширять колонку я не могу, так как единица измерения может быть очень большой, чтобы влезало выражение

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Делаем внешнюю печатную форму. А эту ячейку (единицы измерения) формируем со свойствами - "Переносить" и все будет норм.
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн Tgr11

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-27
  • Сайт: 
Делаем внешнюю печатную форму. А эту ячейку (единицы измерения) формируем со свойствами - "Переносить" и все будет норм.
Не подскажите функцию? если ли функция без задания конкретной ячейки? тогда имеет смысл сделать перенос для всего документа, чтобы не возникало таких ситуаций... вот мой код для большего понимания
	Структура = Новый Структура("ИмяПапки,ИмяФайла,ПолноеИмя");

Если ВыводитьДиалог Тогда
Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Сохранение);
Диалог.Фильтр = "Excel(*.xls)|*.xls";
    Диалог.Расширение = "xls";
Диалог.Заголовок = "Сохраните файл...";
Диалог.ПолноеИмяФайла = ЭтаФорма.Заголовок+".xls";
Если Диалог.Выбрать() Тогда
ИмяПапки = Диалог.Каталог;
ИмяФайла = СтрЗаменить(Диалог.ПолноеИмяФайла,ИмяПапки,"");
Иначе
Возврат Структура;
КонецЕсли;
пФайл = Новый Файл(Диалог.ПолноеИмяФайла);
Иначе
пФайл = Новый Файл(ПолучитьИмяВременногоФайла("xls"));
ИмяПапки = пФайл.Путь;
ИмяФайла = пФайл.ИмяБезРасширения;
КонецЕсли;

ТабДок = ЭлементыФормы.ПолеТабличногоДокумента;
ТабДок.Записать(пФайл.ПолноеИмя, "xls");

Excel = Новый COMОбъект("Excel.Application");
Excel.Visible = 0;
Книга = Excel.WorkBooks.Open(пФайл.ПолноеИмя);
//Установка ориентации
Если ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт Тогда
Excel.ActiveSheet.PageSetup.Orientation = 2;
Иначе
Excel.ActiveSheet.PageSetup.Orientation = 1;
КонецЕсли;

//Установка масштаба печати
Excel.ActiveSheet.PageSetup.Zoom = false;
Excel.ActiveSheet.PageSetup.FitToPagesWide = 1;
    Excel.ActiveSheet.PageSetup.FitToPagesTall = false;
Excel.ActiveSheet.PageSetup.LeftMargin   = Excel.CentimetersToPoints(1);
  Excel.ActiveSheet.PageSetup.RightMargin  = Excel.CentimetersToPoints(1);
  Excel.ActiveSheet.PageSetup.TopMargin    = Excel.CentimetersToPoints(0.9);
  Excel.ActiveSheet.PageSetup.BottomMargin = Excel.CentimetersToPoints(0.9);
//нижний колонтитул размер
    Excel.ActiveSheet.PageSetup.FooterMargin  = Excel.CentimetersToPoints(0.4);//0.1
Excel.ActiveSheet.PageSetup.HeaderMargin  = Excel.CentimetersToPoints(0.4);
//номер страницы  по середине центральный нижний колонтитул
Excel.ActiveSheet.PageSetup.CenterFooter = "стр. &P ";
  Книга.Save();
Книга.Close();
Excel.Quit();

Структура.ИмяПапки = "";
Структура.ИмяФайла = "";
Размер = 0;
ТекДата60 = ТекущаяДата() + 60;
Пока ТекущаяДата() < ТекДата60  Цикл
Если пФайл.Существует() Тогда
Размер = пФайл.Размер();
КонецЕсли;
Если Не Размер = 0 Тогда
Структура.ИмяПапки = ИмяПапки;
Структура.ИмяФайла = ИмяФайла;
Прервать;
КонецЕсли;
КонецЦикла;

Возврат Структура;

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
В ячейке "единицы измерения" твоего "ЭлементыФормы.ПолеТабличногоДокумента" ПКМ - свойства ячейки - Переносить
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Tgr11

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-27
  • Сайт: 
В ячейке "единицы измерения" твоего "ЭлементыФормы.ПолеТабличногоДокумента" ПКМ - свойства ячейки - Переносить
Сделано, я обьяснила как раз ситуацию связанную с переносом слов.
Если на первой строке будет, Цифра и Буква , то все выгружается так как надо, но если перенос был первая строка цифра а вторая буква, то в выгрузке одни ####

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Точнее в МАКЕТЕ
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Tgr11

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-27
  • Сайт: 

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Вопрос? А файл - сохранить как. Имеет точно такое же поведение?
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Tgr11

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-27
  • Сайт: 
Вопрос? А файл - сохранить как. Имеет точно такое же поведение?
да
Добавлено: 25 Сен 2013, 10:48

В самом макете все переносится и в форме все переносится и все выглядит красиво, как открываешь ексель зачастую ###, как с этим бороться не пойму((причем только такая ситуация при сохранении в ексель, в doc,htm и так далее все нормально


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 295
Последний ответ 21 Сен 2017, 10:33
от Insider
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4821
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3416
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4996
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz
Настройка формы "Заполнение товаров"

Автор ЖаннаРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 587
Последний ответ 10 Мар 2017, 21:00
от Жанна

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
oleg-x
44 Сообщений
andron81_81
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 253
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal