Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 23:54
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: проведение документа  (Прочитано 2412 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dimon777

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте! подскажите пожалуйста, вот мне нужно сделать так: если стоит пометка на удаление у документа увольнения, то начисление проводим, а если пометка не стоит и документ не проведен,то должен не проводить. пишу следующий код :
  Если Сотрудник = Сотрудник1 и ВыборкаСтрокДокумента.Проведен = Ложь и ПометкаУдаления = Ложь Тогда

    Отказ = Истина;
                    Сообщить("Провести неудалось т.к. есть приказ на увольнение");

ИначеЕсли ПометкаУдаления = Истина Тогда
     Проведение = Истина;
  КонецЕсли;
подскажите пожалуйста в чем ошибка может быть? потому что все равно не дает провести документ даже если есть пометка.


Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Помеченные на удаление документы не проводятся ни в одной конфигурации. Сначала надо снять ПометкаУдаления.
Док.ПометкаУдаления = Ложь;
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн Dimon777

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
нет, вы не поняли. если есть помеченные на удаление док.увольнения , то тогда док.начисление нужно провести,а если они просто есть и не проведены, тогда нужно отказать в проведении.
вот он мне в обоих случаях и не проводит, а нужно чтоб в первом случае документ провелся...

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Что за конфигурация и приведи полностью текст процедуры пожалуйста.
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн Dimon777

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Зарплата, делаю в процедуре ОбработкаПроведения
Запрос = Новый Запрос;
Запрос.Текст =
   "ВЫБРАТЬ
   | УвольнениеИзОрганизаций.Ссылка,
   | УвольнениеИзОрганизаций.Проведен,
   | УвольнениеИзОрганизаций.Дата,
   | УвольнениеИзОрганизаций.РаботникиОрганизации.(
   | Сотрудник,
   | ДатаУвольнения
   | )
   |ИЗ
   | Документ.УвольнениеИзОрганизаций КАК УвольнениеИзОрганизаций";

   ВыборкаСтрокДокумента = Запрос.Выполнить().Выбрать();
   Пока ВыборкаСтрокДокумента.Следующий() Цикл
   Для Каждого ТекущаяСтрока из ВыборкаСтрокДокумента.Ссылка.РаботникиОрганизации Цикл
    Для каждого СтрокаДокумент Из Начисления Цикл
                  Сотрудник = ТекущаяСтрока.Сотрудник;
          Сотрудник1 = СтрокаДокумент.Сотрудник;
  Если Сотрудник = Сотрудник1 и ВыборкаСтрокДокумента.Проведен = Ложь и ПометкаУдаления = Ложь Тогда
    Отказ = Истина;
                    Сообщить("Провести неудалось т.к. есть приказ на увольнение");
ИначеЕсли ПометкаУдаления = Истина Тогда
Проведение = Истина;
  КонецЕсли;
        КонецЦикла;   
           КонецЦикла;
       КонецЦикла;

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Вопрос один: Зачем??? ведь все механизмы нормально в ЗУПе работают?
Последовательность:
1. Приказ об увольнении.
2. Расчет сотрудника при увольнении.
3. Начисление ЗП уволенного сотрудника.
 P.S.: Дважды уже сотрудник за месяц не попадет в документ Начисление ЗП!
Добавлено: 24 Сен 2013, 14:02

Да и еще. Хотя бы выборку делайте за какой-то рабочий период месяца, а не все

ГДЕ
  УвольнениеИзОрганизаций.ДатаДок МЕЖДУ &ДатаНачала И &ДатаКонца
Запрос.УстановитьПараметр("ДатаНачала",ДатаНачала);
Запрос.Установитьпараметр("ДатаКонца",ДатаКонца);
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн Dimon777

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
мне просто нужно чтоб документ провелся.... как написать это условие? что я не так написал?

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
1. Оба дока имеют Таблы. И соответственно тебе нужно будет сравнивать содержание таблиц.
 Если нашли хоть одного одинакового Сотрика проверяем на следуующее

 Если  ДокУвольнения.ПометкаУдаления ИЛИ ДокУвольнения.проведен() Тогда
       ДокНачисления.Записать(РежимЗаписиДокумента.ОтменаПроведения);
Иначе
        ДокНачисления.Записать(РежимЗаписиДокумента.Проведение);
КонецЕсли;

что-то типа этого
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4472
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15920
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4198
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 623
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7741
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 247
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal