Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 06:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Регистр сведений  (Прочитано 1871 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Дринкинс

  • **
  • Сообщений: 55
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-27
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте.

   
Для стр = 0 По ТЗ.Количество()-1 Цикл 

НоменклатураБезПроизводства = Справочники.Номенклатура.НайтиПоНаименованию(ТЗ.Получить(стр).Номенклатура);
Набор = РегистрыСведений.НоменклатураСнятаяСПроизводства.СоздатьНаборЗаписей();
НоваяЗапись = Набор.Добавить();
НоваяЗапись.Номенклатура = НоменклатураБезПроизводства;
//Набор.Загрузить(ТЗ);
Набор.Записать();

КонецЦикла;
   


Данным кодом из таблицы значений хочу записать данные в регистр сведений но почему то записывается только одна последняя номенклатура. Помогите где ошибка

Последний раз редактировалось: MuI_I_Ika; 22 Сен 2013, 21:41


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6557
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Re: Регистр сведений
« Ответ #1: 22 Сен 2013, 21:55 »
Что-то не то у вас в ТЗ записано.

Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
Re: Регистр сведений
« Ответ #2: 23 Сен 2013, 09:48 »
Набор = РегистрыСведений.НоменклатураСнятаяСПроизводства.СоздатьНаборЗаписей();
Для стр = 0 По ТЗ.Количество()-1 Цикл
      НоменклатураБезПроизводства = Справочники.Номенклатура.НайтиПоНаименованию(ТЗ.Получить(стр).Номенклатура);
    Если НоменклатураБезПроизводства <> Справочники.Номенклатура.ПустаяСсылка() Тогда
      НоваяЗапись = Набор.Добавить();
      НоваяЗапись.Номенклатура = НоменклатураБезПроизводства;
    КонецЕсли;
КонецЦикла;
Набор.Записать();
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Последний раз редактировалось: MuI_I_Ika; 23 Сен 2013, 13:26


Теги:
 

Отличие проводки по регистру сведений от проводки по регистру накопления?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4843
Последний ответ 18 Апр 2012, 02:19
от Dethmontt
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7738
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9335
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
В чем отличие регистра сведений от регистра накопления?

Автор Dmitry QweРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 484
Последний ответ 11 Сен 2017, 10:50
от ilyay
Проверка на "новую" запись в рег. сведений

Автор nomer13Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 14329
Последний ответ 11 Янв 2011, 10:04
от nomer13

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
171 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 268
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal