Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Ноя 2019, 11:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Нужна помощь начинающему программисту  (Прочитано 3810 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ay79

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-09-20
  • Сайт: 
Добрый день! Помогите начинающему программисту. У меня версия 1С:Предприятие 8.2 (8.2.17.143). Делаю простое задание по лабораторной. Нужно создать обработчик для кнопки. Код следующий:

Процедура Нажатие(Команда)
// Вставить содержимое обработчика
//На чтение
Выборка = Справочники.Номенклатура.Выбрать();
Пока Выборка.Следующий() Цикл
Наим = Выборка.Наименование;
КонецЦикла;

//На запись
Выборка = Справочники.Номенклатура.Выбрать();
Пока Выборка.Следующий() Цикл
обСпр = Выборка.ПолучитьОбъект();
обСпр.Наименование=обСпр.Наименование+" обработанно";
обСпр.Записать();
КонецЦикла;

КонецПроцедуры
Выдает ошибку:
{Справочник.Номенклатура.Форма.ФормаСписка.Форма(6,11)}: Переменная не определена (Справочники)
Выборка = <<?>>Справочники.Номенклатура.Выбрать(); (Проверка: Тонкий клиент)
{Справочник.Номенклатура.Форма.ФормаСписка.Форма(12,11)}: Переменная не определена (Справочники)
Выборка = <<?>>Справочники.Номенклатура.Выбрать(); (Проверка: Тонкий клиент)

Help! Как устранить ошибку? Лаба горит!



Оффлайн Yura063

  • *****
  • Сообщений: 1050
  • РЕПУТАЦИЯ: 137
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: 
  • Профессия: Программист 1С
Вызов метаданных (документов, справочников и т.д.) производится на сервере. на клиенте к ним обращатся нельзя!
Помогли, отблагодари!

Оффлайн ay79

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-09-20
  • Сайт: 
Спасибо Yura063! Ошибку теперь не выдает, но код не работает.

Оффлайн Yura063

  • *****
  • Сообщений: 1050
  • РЕПУТАЦИЯ: 137
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: 
  • Профессия: Программист 1С
не переименовывает? ошибку выдает? зачем два раза читать справочник номенклатуры? сделайте в одном цикле
Помогли, отблагодари!

Оффлайн Dethmontt

  • Денис
  • *****
  • Сообщений: 2864
  • РЕПУТАЦИЯ: 550
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
КНОПКА ДОЛЖНЫ ВЫЗЫВАТЬСЯ НА КЛИЕНТЕ! (Т.к кнопка может существовать только на клиенте)
А вот из клиентской процедуры должна вызываться серверная выполняющая ваш(выше написанный) КОД
Добавлено: 20 Сен 2013, 19:40

Тут пример
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн vladialim

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-11-04
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет, у меня тоже какая-то ошибка никак не могу понять где
 
&НаКлиенте
Процедура МатриалыТоварПриИзменении(Элемент)
   СТЧ = Элементы.Материалы.ТекущиеДанные;
   Товар = СокрЛП(СТЧ.Товар);
   СпрН = Справочники.Номенклатура;
   Объект = СпрН.ВыбратьИерархически();
   Пока
      СпрН.Следующий()Цикл
      Номенкл = СокрЛП(Объект.Наименование);
      Код = СпрН.Код;
      ЭлСпр = СпрН.НайтиПоКоду(Код);
      СТЧ.ЕдИзм = ЭлСпр.ЕдИзм;
      Если Номенкл = Товар Тогда
         Прервать;
         КонецЕсли;           
КонецЦикла;
ЕдИзмВ = СокрЛП(СТЧ.ЕдИзм);
Выб = Элементы.Справочники.Единицы.ВыбратьИерархически();
Пока
   Выб.Следующий() Цикл
   ЕдИзмС = СокрЛП(Выб.Ссылка);
   СТЧ.Коэф = Выб.Коэфф;
   Если ЕдИзмВ = ЕдИзмС Тогда
      Прервать;
   КонецЕсли;
КонецЦикла;
КонецПроцедуры

{Документ.ПриходнаяНакладная.Форма.ФормаДокумента.Форма(6,9)}: Переменная не определена (Справочники)
   СпрН = <<?>>Справочники.Номенклатура; (Проверка: Тонкий клиент)

Помогите пожалуйста

Оффлайн Геннадий ОбьГЭС

  • Консультант-программист 1С. ЗВОНИТЕ!
  • *****
  • Сообщений: 3313
  • РЕПУТАЦИЯ: 140
  • КПД: 4%
  • Проблемы решу удаленно в 1С
  • Регистрация: 2015-03-12
  • Сайт: nsk1c.wordpress.com
  • Профессия: Программист 1С
Всем привет, у меня тоже какая-то ошибка никак не могу понять где

Дубль http://forum-1c.ru/index.php?topic=31778.msg212690#msg212690
Геннадий
Консультант-программист 1С
 Оплата после результата

Оффлайн vladialim

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-11-04
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет, у меня тоже какая-то ошибка никак не могу понять где

Дубль http://forum-1c.ru/index.php?topic=31778.msg212690#msg212690

Спасибо за оказанное внимание, но если можно по подробнее по занной ошибке, или где почитать об этом можно.

Оффлайн Alexbis

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2014-03-06
  • Сайт: 
  • Профессия: Программист 1С

{Документ.ПриходнаяНакладная.Форма.ФормаДокумента.Форма(6,9)}: Переменная не определена (Справочники)
   СпрН = <<?>>Справочники.Номенклатура; (Проверка: Тонкий клиент)

Помогите пожалуйста
[/quote]
обращения к объекту "Справочники" должны вызываться из "серверных" процедур, те &НаСервере

Добавлено: 05 Ноя 2019, 11:27

&НаКлиенте
Процедура МатриалыТоварПриИзменении(Элемент)

МатриалыТоварПриИзмененииНаСервере(Элемент)

КонецПроцедуры

&НаСервере
Процедура МатриалыТоварПриИзмененииНаСервере(Элемент)

тут ваш код

КонецПроцедуры


Последний раз редактировалось: Alexbis; 05 Ноя 2019, 11:27. Причина: Объединение сообщений


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
78 Сообщений
MuI_I_Ika MuI_I_Ika
35 Сообщений
BuhRust
35 Сообщений
Бактыжан Килибаев Бактыжан Килибаев
32 Сообщений
LexaK
30 Сообщений
Chgdz
25 Сообщений
alexandr_ll
25 Сообщений
wise wise
22 Сообщений
Пересвет Пересвет
19 Сообщений
aleon1
10 Сообщений

* Кто онлайн

  • Точка Гостей: 782
  • Точка Скрытых: 0
  • Точка Пользователей: 11
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal