Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 05:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Нужна помощь начинающему программисту  (Прочитано 2611 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ay79

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-09-20
  • Сайт: 
Добрый день! Помогите начинающему программисту. У меня версия 1С:Предприятие 8.2 (8.2.17.143). Делаю простое задание по лабораторной. Нужно создать обработчик для кнопки. Код следующий:

Процедура Нажатие(Команда)
// Вставить содержимое обработчика
//На чтение
Выборка = Справочники.Номенклатура.Выбрать();
Пока Выборка.Следующий() Цикл
Наим = Выборка.Наименование;
КонецЦикла;

//На запись
Выборка = Справочники.Номенклатура.Выбрать();
Пока Выборка.Следующий() Цикл
обСпр = Выборка.ПолучитьОбъект();
обСпр.Наименование=обСпр.Наименование+" обработанно";
обСпр.Записать();
КонецЦикла;

КонецПроцедуры
Выдает ошибку:
{Справочник.Номенклатура.Форма.ФормаСписка.Форма(6,11)}: Переменная не определена (Справочники)
Выборка = <<?>>Справочники.Номенклатура.Выбрать(); (Проверка: Тонкий клиент)
{Справочник.Номенклатура.Форма.ФормаСписка.Форма(12,11)}: Переменная не определена (Справочники)
Выборка = <<?>>Справочники.Номенклатура.Выбрать(); (Проверка: Тонкий клиент)

Help! Как устранить ошибку? Лаба горит!



Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Вызов метаданных (документов, справочников и т.д.) производится на сервере. на клиенте к ним обращатся нельзя!
Помогли, отблагодари!

Оффлайн ay79

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-09-20
  • Сайт: 
Спасибо Yura063! Ошибку теперь не выдает, но код не работает.

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
не переименовывает? ошибку выдает? зачем два раза читать справочник номенклатуры? сделайте в одном цикле
Помогли, отблагодари!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
КНОПКА ДОЛЖНЫ ВЫЗЫВАТЬСЯ НА КЛИЕНТЕ! (Т.к кнопка может существовать только на клиенте)
А вот из клиентской процедуры должна вызываться серверная выполняющая ваш(выше написанный) КОД
Добавлено: 20 Сен 2013, 19:40

Тут пример
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
AIFrame
39 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 228
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal