Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
28 Май 2018, 13:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Дополнительный отбор при открытии формы  (Прочитано 1997 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Tgr11

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-27
  • Сайт: 
Доброе утро, пользователи, обращаюсь к Вам с вопросом и надеюсь на помощь в данном вопросе:
Есть Документ, у него форма документа, в ней мне нужно при открытии в процедуре сделать заполнение одной из табличных частей по определенному отбору, вернее по двум отборам:
1-По документу-основанию
2-По реквизиту поля-Ид
Вот сама процедура:
Для каждого ИмяТаблицы Из ТаблицыОтбора Цикл

  Если ЭлементыФормы.Найти(ИмяТаблицы) = неопределено Тогда
      продолжить;
  КонецЕсли;
 
  Если ИмяТаблицы = "ДеревоНачислений" Тогда
    ОбновитьДеревоНачислений(ЭлементыФормы.Начисления.Значение,ЭлементыФормы[ИмяТаблицы],ТекущийПользователь, ПолучитьСтрокуРасценки(текущаяСтрока)) ;
  Иначе
ЭлементыФормы[ИмяТаблицы].ОтборСтрок.СметныйДокумент.Установить(
?(текущаяСтрока<> неопределено и (ЭтоРесурс(текущаяСтрока)или ЭтоДопЗатрата(текущаяСтрока)),текущаяСтрока.СметныйДокумент,
?(текущаяСтрока<> неопределено и (ЭтоРасценка(текущаяСтрока)или ЭтоРаздел(текущаяСтрока)),текущаяСтрока.СметныйДокумент,0)));
  КонецЕсли;
КонецЦикла;
сейчас у меня сделано только по одному отбору, подскажите пожалуйста как мне сделать, чтобы отбор работал по двум полям... что то не получается((


Оффлайн Tgr11

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-27
  • Сайт: 
Или просто подскажите накладывается ли двойной фильтр по полю через ОтборСтрок... или мне как то по другому делать?

Оффлайн Yura063

  • *****
  • Сообщений: 1050
  • РЕПУТАЦИЯ: 137
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: 
  • Профессия: Программист 1С
А использовать запрос не пробовали?
Помогли, отблагодари!


Теги:
 

Не работает метод Сдвинуть() по отношению к программно добавляемой колонке1С:Предприятие 8.3 (8.3.10.2561) Управление производственным предприятием, редакция 1.4 Приветствую, я добавляю программно свою колонку в методе ПриОткрытии() модуля формы, вот так

Автор InsiderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 639
Последний ответ 21 Сен 2017, 10:33
от Insider
Нужно в параметр запроса к РегистрБухгалтерии.Проводки.Остатки вставить вместо периода данные из другого запроса отчет СКД 8.3, обычные формы

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 158
Последний ответ 10 Апр 2018, 14:00
от Св Ч
Редактирование формы "Настройки пользователя".

Автор t955938Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5262
Последний ответ 03 Авг 2011, 11:45
от t955938
получаю значение реквизита формы, дает значение 0

Автор mikel10Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3805
Последний ответ 12 Июл 2013, 15:35
от mikel10
Как обратиться к функции модуля формы из модуля Менеджера?

Автор TreeDogNightРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5803
Последний ответ 10 Июл 2014, 14:05
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
139 Сообщений
alex0402
64 Сообщений
oleg-x
54 Сообщений
AIFrame AIFrame
53 Сообщений
buketov.av buketov.av
47 Сообщений
ilyay ilyay
39 Сообщений
wise wise
37 Сообщений
alexandr_ll
34 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal