Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 02:30
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: сравнить в цикле предыдущее найденное значение с найденным  (Прочитано 5874 раз)

0 Пользователей и 2 Гостей просматривают эту тему.

Оффлайн aleks-lit

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-02
  • Сайт: 
  • Профессия: Программист 1С
сравнить в цикле предыдущее найденное значение с найденным
 
 
ВыборкаПериод = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"регистратор");
   Пока ВыборкаПериод.Следующий() Цикл
      фл=0;ИтогПодработкиДень=0;
      ВыборкаКонтрагент = ВыборкаПериод.Выбрать();
      Пока ВыборкаКонтрагент.Следующий() Цикл
 
         НомерСтроки = НомерСтроки + 1;
         ОбластьДетальныхЗаписей.Параметры.КоличествоСтр = НомерСтроки;
         ОбластьДетальныхЗаписей.Параметры.ДатаДок = Формат(ВыборкаПериод.Регистратор,"ДФ=dd.MM.yy");
         Если ОбластьДетальныхЗаписей.Параметры.ДатаДок -1 <> ОбластьДетальныхЗаписей.Параметры.ДатаДок тогда
            фл=1
         иначе
            фл=0
         конецесли;

 
         ОбластьДетальныхЗаписей.Параметры.Контрагент = ВыборкаКонтрагент.Владелец;         


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
ВыборкаКонтрагент = ВыборкаПериод.Выбрать(); 
ПредыдущееНайденноеЗначение = Неопределено;
Пока ВыборкаКонтрагент.Следующий() Цикл
   Если НЕ ПредыдущееНайденноеЗначение = Неопределено тогда
       Сообщить("Предыдущее и текущее значения равны? Ответ: "+выборка.ТекущееЗначение = ПредыдущееНайденноеЗначение);
   КонецЕсли;
   //....
   //....

   ПредыдущееНайденноеЗначение = Выборка.ТекущееЗначение;
КонецЦикла;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн aleks-lit

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-02
  • Сайт: 
  • Профессия: Программист 1С
ВыборкаКонтрагент = ВыборкаПериод.Выбрать(); 
ПредыдущееНайденноеЗначение = Неопределено;
Пока ВыборкаКонтрагент.Следующий() Цикл
   Если НЕ ПредыдущееНайденноеЗначение = Неопределено тогда
       Сообщить("Предыдущее и текущее значения равны? Ответ: "+выборка.ТекущееЗначение = ПредыдущееНайденноеЗначение);
   КонецЕсли;
   //....
   //....

   ПредыдущееНайденноеЗначение = Выборка.ТекущееЗначение;
КонецЦикла;

я тут покумекал и сделал так:

старЗнач = "";

Пока ВыборкаПериод.Следующий() Цикл
фл=0;ИтогПодработкиДень=0;
ВыборкаКонтрагент = ВыборкаПериод.Выбрать();

//для с = 1 по 10 цикл
  новЗнач =Формат(ВыборкаПериод.Регистратор,"ДФ=dd.MM.yy");
//если старЗнач <> "" тогда
если старЗнач <> новЗнач тогда
если старЗнач = "" тогда
фл=0
Иначе
фл=1
конецесли;
  иначе
    фл=0

КонецЕсли;
         

Если фл=1 Тогда
ОбластьДетальныхЗаписейДень.Параметры.ИтогоЗаДень = "ИТОГО за "+Формат(старЗнач,"ДФ=dd.MM.yy");
                        .............. и тд
         

но есть один косяк за последний день не выводится итог

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Поставьте после цикла Вывод последнего значения!
Помогли, отблагодари!

Оффлайн aleks-lit

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-02
  • Сайт: 
  • Профессия: Программист 1С
Поставьте после цикла Вывод последнего значения!

что именно? если поставить после цикла тот же код с оператором "если", то повторяется тоже самое(со сдвигом на 1 позицию.

   
	ВыборкаПериод = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"регистратор");
старЗнач = "";
КоличествоПриходЗаДень =  Число(0) ;
Пока ВыборкаПериод.Следующий() Цикл
фл=0;ИтогПодработкиДень=0;
ВыборкаКонтрагент = ВыборкаПериод.Выбрать();

//для с = 1 по 10 цикл
  новЗнач =Формат(ВыборкаПериод.Регистратор,"ДФ=dd.MM.yy");
//если старЗнач <> "" тогда
если старЗнач <> новЗнач тогда
если старЗнач = "" тогда
фл=0
Иначе
фл=1
конецесли;
  иначе
    фл=0

КонецЕсли;
         

Если фл=1 Тогда
ОбластьДетальныхЗаписейДень.Параметры.ИтогоЗаДень = "ИТОГО за "+Формат(старЗнач,"ДФ=dd.MM.yy");

//итог количество день

ОбластьДетальныхЗаписейДень.Параметры.КоличествоРасход = ВыборкаПериод.КоличествоРасход-ИтогПодработкиДень;//минус подработка по влажности
ОбластьДетальныхЗаписейДень.Параметры.КоличествоПриход = КоличествоПриходЗаДень;
//итог влажность-сорность день
ОбластьДетальныхЗаписейДень.Параметры.ПриходВлажностьЦП  = ВыборкаПериод.ВлажностьПриход;
ОбластьДетальныхЗаписейДень.Параметры.ПриходСорностьЦП   = ВыборкаПериод.СорностьПриход;
ОбластьДетальныхЗаписейДень.Параметры.РасходВлажностьЦП  = ВыборкаПериод.ВлажностьРасход;
ОбластьДетальныхЗаписейДень.Параметры.РасходСорностьЦП   = ВыборкаПериод.СорностьРасход;


ОбластьДетальныхЗаписейДень.Параметры.Остаток = НачОстаток;
ОбластьДетальныхЗаписейДень.Параметры.Подработка = ?(ИтогПодработкиДень>0,"подр: влажность "+ИтогПодработкиДень,"");

ТабДок.Вывести(ОбластьДетальныхЗаписейДень);

//Сумма итогов
ИтогВлажностьПриход=ИтогВлажностьПриход+ВыборкаПериод.ВлажностьПриход;
ИтогСорностьПриход=ИтогСорностьПриход+ВыборкаПериод.СорностьПриход;
ИтогВлажностьРасход=ИтогВлажностьРасход+ВыборкаПериод.ВлажностьРасход;
ИтогСорностьРасход=ИтогСорностьРасход+ВыборкаПериод.СорностьРасход;

ИтогКоличествоПриход=ИтогКоличествоПриход+ВыборкаПериод.КоличествоПриход;
ИтогКоличествоРасход=ИтогКоличествоРасход+ВыборкаПериод.КоличествоРасход;

ИтогПодработки = ИтогПодработки+ИтогПодработкиДень;
КоличествоПриходЗаДень =  Число(0) ;

            КонецЕсли;
              старЗнач = новЗнач;

Пока ВыборкаКонтрагент.Следующий() Цикл



//КоличествоПриходЗаДень = КоличествоПриходЗаДень + формат(ОбластьДетальныхЗаписей.Параметры.КоличествоПриход,"ЧДЦ=0");
// ВыборкаПериод.КоличествоПриход
НомерСтроки = НомерСтроки + 1;
ОбластьДетальныхЗаписей.Параметры.КоличествоСтр = НомерСтроки;
ОбластьДетальныхЗаписей.Параметры.ДатаДок = Формат(ВыборкаПериод.Регистратор,"ДФ=dd.MM.yy");
//Иначе
//фл=0
//конецесли;

//конеццикла
//Если ОбластьДетальныхЗаписей.Параметры.ДатаДок -1 <> ОбластьДетальныхЗаписей.Параметры.ДатаДок тогда
// фл=1
//иначе
// фл=0
//конецесли;

ОбластьДетальныхЗаписей.Параметры.Контрагент = ВыборкаКонтрагент.Владелец;

//при попадании подработки, дублируем только остаток
Если (ВыборкаКонтрагент.КодОперации = Перечисления.КодыОпераций.СнижениеВлажности) Тогда

ОбластьДетальныхЗаписей.Параметры.Влажность = "";
ОбластьДетальныхЗаписей.Параметры.Сорность  = "";
ОбластьДетальныхЗаписей.Параметры.КоличествоРасход  = "";
ОбластьДетальныхЗаписей.Параметры.КоличествоПриход  = "";
ОбластьДетальныхЗаписей.Параметры.ПриходВлажностьЦП = "";
ОбластьДетальныхЗаписей.Параметры.РасходВлажностьЦП = "";
ОбластьДетальныхЗаписей.Параметры.ПриходСорностьЦП  = "";
ОбластьДетальныхЗаписей.Параметры.РасходСорностьЦП  = "";
ОбластьДетальныхЗаписей.Параметры.Остаток = НачОстаток;
ОбластьДетальныхЗаписей.Параметры.Подработка = "подр: влажность "+ВыборкаКонтрагент.КоличествоРасход;
КоличествоПриходЗаДень = КоличествоПриходЗаДень+Число(0);
ИтогПодработкиДень = ИтогПодработкиДень+ВыборкаКонтрагент.КоличествоРасход;

Иначе

//Анализы рассчитаем % влажности и сорности, исходя из данных центнеро-процентов
Если ВыборкаКонтрагент.КоличествоПриход>0 Тогда//Приход
ОбластьДетальныхЗаписей.Параметры.Влажность = Окр(ВыборкаКонтрагент.ВлажностьПриход/ВыборкаКонтрагент.КоличествоПриход*100,2);
ОбластьДетальныхЗаписей.Параметры.Сорность  = Окр(ВыборкаКонтрагент.СорностьПриход/ВыборкаКонтрагент.КоличествоПриход*100,2);
Иначе//Расход
ОбластьДетальныхЗаписей.Параметры.Влажность = Окр(ВыборкаКонтрагент.ВлажностьРасход/ВыборкаКонтрагент.КоличествоРасход*100,2);
ОбластьДетальныхЗаписей.Параметры.Сорность = Окр(ВыборкаКонтрагент.СорностьРасход/ВыборкаКонтрагент.КоличествоРасход*100,2);
КонецЕсли;

//Масса
ОбластьДетальныхЗаписей.Параметры.КоличествоРасход = ВыборкаКонтрагент.КоличествоРасход;
ОбластьДетальныхЗаписей.Параметры.КоличествоПриход = ВыборкаКонтрагент.КоличествоПриход;

//ЦП
ОбластьДетальныхЗаписей.Параметры.ПриходВлажностьЦП = ВыборкаКонтрагент.ВлажностьПриход;
ОбластьДетальныхЗаписей.Параметры.РасходВлажностьЦП = ВыборкаКонтрагент.ВлажностьРасход;
ОбластьДетальныхЗаписей.Параметры.ПриходСорностьЦП = ВыборкаКонтрагент.СорностьПриход;
ОбластьДетальныхЗаписей.Параметры.РасходСорностьЦП = ВыборкаКонтрагент.СорностьРасход;

//Нач. остаток
    НачОстаток = НачОстаток + ВыборкаКонтрагент.КоличествоПриход - ВыборкаКонтрагент.КоличествоРасход;
КоличествоПриходЗаДень = КоличествоПриходЗаДень + Число(ВыборкаКонтрагент.КоличествоПриход);      // ВыборкаПериод.КоличествоПриход
                                    //заполним комменты по операциям или очищаем прошлое значение подработки
Если (ВыборкаКонтрагент.КодОперации = Перечисления.КодыОпераций.СнижениеСорности)Тогда
ОбластьДетальныхЗаписей.Параметры.Подработка = "подр: сорность";
ИначеЕсли (ВыборкаКонтрагент.КодОперации = Перечисления.КодыОпераций.Аспирация) Тогда
ОбластьДетальныхЗаписей.Параметры.Подработка = "подр: аспирация";
Иначе
ОбластьДетальныхЗаписей.Параметры.Подработка = "";
КонецЕсли;
//КоличествоПриходЗаДень = КоличествоПриходЗаДень + ВыборкаКонтрагент.КоличествоПриход;
КонецЕсли;

//Нач. остаток
            ОбластьДетальныхЗаписей.Параметры.Остаток = НачОстаток;
//КоличествоПриходЗаДень = КоличествоПриходЗаДень + ВыборкаКонтрагент.КоличествоПриход; 
 
ТабДок.Вывести(ОбластьДетальныхЗаписей);
            //Флаг вывода итогов за день
//датастрока =  Формат(ВыборкаПериод.регистратор,"ДФ=dd.MM.yy");
//Выборка1=ВыборкаПериод.Следующий();
//Если датастрока= Выборка1.найти(датастрока) Тогда
// фл=0
//Иначе
//Если (Формат(ВыборкаКонтрагент.регистратор,"ДФ=dd.MM.yy") = Формат(ВыборкаПериод.Регистратор,"ДФ=dd.MM.yy")) тогда
// фл=0
//иначе
//фл=1
//конецесли;

//КонецЕсли;


КонецЦикла;
КонецЦикла;

будте добры подскажите куда именно и что подставить.

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
За последний день у вас в любом случае должен выводится?
Помогли, отблагодари!

Оффлайн aleks-lit

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-02
  • Сайт: 
  • Профессия: Программист 1С
За последний день у вас в любом случае должен выводится?

да должен

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Есть варианты:
- дублировать полностью код для последней дата, это после цикла по выборке по дате, только без условий.
- менять цикл, то есть, вместо пока Выборка.Следующий() Цикл сделать Пока выборка.дата <> "" цикл (гемора тоже много)
Помогли, отблагодари!

Оффлайн aleks-lit

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-02
  • Сайт: 
  • Профессия: Программист 1С
Есть варианты:
- дублировать полностью код для последней дата, это после цикла по выборке по дате, только без условий.
- менять цикл, то есть, вместо пока Выборка.Следующий() Цикл сделать Пока выборка.дата <> "" цикл (гемора тоже много)


я пробовал и после конца первого цикла и после 2 цикла но не так работает

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
ВыборкаПериод = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам,"регистратор");
   старЗнач = "";
   КоличествоПриходЗаДень =  Число(0) ;
   Пока ВыборкаПериод.Следующий() Цикл
      фл=0;ИтогПодработкиДень=0;
      ВыборкаКонтрагент = ВыборкаПериод.Выбрать();
     
            //для с = 1 по 10 цикл
              новЗнач =Формат(ВыборкаПериод.Регистратор,"ДФ=dd.MM.yy");
            //если старЗнач <> "" тогда
               если старЗнач <> новЗнач тогда
                  если старЗнач = "" тогда
                     фл=0
                  Иначе
                     фл=1
                  конецесли;
                 иначе
                                        фл=0
                 
               КонецЕсли;
         
         
         Если фл=1 Тогда
         ОбластьДетальныхЗаписейДень.Параметры.ИтогоЗаДень = "ИТОГО за "+Формат(старЗнач,"ДФ=dd.MM.yy");
         
         //итог количество день
           
         ОбластьДетальныхЗаписейДень.Параметры.КоличествоРасход = ВыборкаПериод.КоличествоРасход-ИтогПодработкиДень;//минус подработка по влажности
         ОбластьДетальныхЗаписейДень.Параметры.КоличествоПриход = КоличествоПриходЗаДень;
         //итог влажность-сорность день
         ОбластьДетальныхЗаписейДень.Параметры.ПриходВлажностьЦП  = ВыборкаПериод.ВлажностьПриход;
         ОбластьДетальныхЗаписейДень.Параметры.ПриходСорностьЦП   = ВыборкаПериод.СорностьПриход;
         ОбластьДетальныхЗаписейДень.Параметры.РасходВлажностьЦП  = ВыборкаПериод.ВлажностьРасход;
         ОбластьДетальныхЗаписейДень.Параметры.РасходСорностьЦП   = ВыборкаПериод.СорностьРасход;
     
         
         ОбластьДетальныхЗаписейДень.Параметры.Остаток = НачОстаток;
         ОбластьДетальныхЗаписейДень.Параметры.Подработка = ?(ИтогПодработкиДень>0,"подр: влажность "+ИтогПодработкиДень,"");

         ТабДок.Вывести(ОбластьДетальныхЗаписейДень);
         
         //Сумма итогов
         ИтогВлажностьПриход=ИтогВлажностьПриход+ВыборкаПериод.ВлажностьПриход;
         ИтогСорностьПриход=ИтогСорностьПриход+ВыборкаПериод.СорностьПриход;
         ИтогВлажностьРасход=ИтогВлажностьРасход+ВыборкаПериод.ВлажностьРасход;
         ИтогСорностьРасход=ИтогСорностьРасход+ВыборкаПериод.СорностьРасход;
         
         ИтогКоличествоПриход=ИтогКоличествоПриход+ВыборкаПериод.КоличествоПриход;
         ИтогКоличествоРасход=ИтогКоличествоРасход+ВыборкаПериод.КоличествоРасход;
         
         ИтогПодработки = ИтогПодработки+ИтогПодработкиДень;
         КоличествоПриходЗаДень =  Число(0) ;

            КонецЕсли;
                 старЗнач = новЗнач;

       Пока ВыборкаКонтрагент.Следующий() Цикл
         
         
               
         //КоличествоПриходЗаДень = КоличествоПриходЗаДень + формат(ОбластьДетальныхЗаписей.Параметры.КоличествоПриход,"ЧДЦ=0");
         // ВыборкаПериод.КоличествоПриход
         НомерСтроки = НомерСтроки + 1;
         ОбластьДетальныхЗаписей.Параметры.КоличествоСтр = НомерСтроки;
         ОбластьДетальныхЗаписей.Параметры.ДатаДок = Формат(ВыборкаПериод.Регистратор,"ДФ=dd.MM.yy");
                      //Иначе
               //фл=0
            //конецесли;
         
         //конеццикла
         //Если ОбластьДетальныхЗаписей.Параметры.ДатаДок -1 <> ОбластьДетальныхЗаписей.Параметры.ДатаДок тогда
         //   фл=1
         //иначе
         //   фл=0
         //конецесли;
         
         ОбластьДетальныхЗаписей.Параметры.Контрагент = ВыборкаКонтрагент.Владелец;
         
         //при попадании подработки, дублируем только остаток
         Если (ВыборкаКонтрагент.КодОперации = Перечисления.КодыОпераций.СнижениеВлажности) Тогда
           
            ОбластьДетальныхЗаписей.Параметры.Влажность = "";
            ОбластьДетальныхЗаписей.Параметры.Сорность  = "";
            ОбластьДетальныхЗаписей.Параметры.КоличествоРасход  = "";
            ОбластьДетальныхЗаписей.Параметры.КоличествоПриход  = "";
            ОбластьДетальныхЗаписей.Параметры.ПриходВлажностьЦП = "";
            ОбластьДетальныхЗаписей.Параметры.РасходВлажностьЦП = "";
            ОбластьДетальныхЗаписей.Параметры.ПриходСорностьЦП  = "";
            ОбластьДетальныхЗаписей.Параметры.РасходСорностьЦП  = "";
            ОбластьДетальныхЗаписей.Параметры.Остаток = НачОстаток;
            ОбластьДетальныхЗаписей.Параметры.Подработка = "подр: влажность "+ВыборкаКонтрагент.КоличествоРасход;
            КоличествоПриходЗаДень = КоличествоПриходЗаДень+Число(0);
            ИтогПодработкиДень = ИтогПодработкиДень+ВыборкаКонтрагент.КоличествоРасход;
           
         Иначе
           
            //Анализы рассчитаем % влажности и сорности, исходя из данных центнеро-процентов
            Если ВыборкаКонтрагент.КоличествоПриход>0 Тогда//Приход
               ОбластьДетальныхЗаписей.Параметры.Влажность = Окр(ВыборкаКонтрагент.ВлажностьПриход/ВыборкаКонтрагент.КоличествоПриход*100,2);
               ОбластьДетальныхЗаписей.Параметры.Сорность  = Окр(ВыборкаКонтрагент.СорностьПриход/ВыборкаКонтрагент.КоличествоПриход*100,2);
            Иначе//Расход
               ОбластьДетальныхЗаписей.Параметры.Влажность = Окр(ВыборкаКонтрагент.ВлажностьРасход/ВыборкаКонтрагент.КоличествоРасход*100,2);
               ОбластьДетальныхЗаписей.Параметры.Сорность = Окр(ВыборкаКонтрагент.СорностьРасход/ВыборкаКонтрагент.КоличествоРасход*100,2);
            КонецЕсли;
           
            //Масса
            ОбластьДетальныхЗаписей.Параметры.КоличествоРасход = ВыборкаКонтрагент.КоличествоРасход;
            ОбластьДетальныхЗаписей.Параметры.КоличествоПриход = ВыборкаКонтрагент.КоличествоПриход;
           
            //ЦП
            ОбластьДетальныхЗаписей.Параметры.ПриходВлажностьЦП = ВыборкаКонтрагент.ВлажностьПриход;
            ОбластьДетальныхЗаписей.Параметры.РасходВлажностьЦП = ВыборкаКонтрагент.ВлажностьРасход;
            ОбластьДетальныхЗаписей.Параметры.ПриходСорностьЦП = ВыборкаКонтрагент.СорностьПриход;
            ОбластьДетальныхЗаписей.Параметры.РасходСорностьЦП = ВыборкаКонтрагент.СорностьРасход;
           
            //Нач. остаток         
             НачОстаток = НачОстаток + ВыборкаКонтрагент.КоличествоПриход - ВыборкаКонтрагент.КоличествоРасход;
            КоличествоПриходЗаДень = КоличествоПриходЗаДень + Число(ВыборкаКонтрагент.КоличествоПриход);      // ВыборкаПериод.КоличествоПриход
                                             //заполним комменты по операциям или очищаем прошлое значение подработки
            Если (ВыборкаКонтрагент.КодОперации = Перечисления.КодыОпераций.СнижениеСорности)Тогда
               ОбластьДетальныхЗаписей.Параметры.Подработка = "подр: сорность";
            ИначеЕсли (ВыборкаКонтрагент.КодОперации = Перечисления.КодыОпераций.Аспирация) Тогда
               ОбластьДетальныхЗаписей.Параметры.Подработка = "подр: аспирация";
            Иначе
               ОбластьДетальныхЗаписей.Параметры.Подработка = "";
            КонецЕсли;
            //КоличествоПриходЗаДень = КоличествоПриходЗаДень + ВыборкаКонтрагент.КоличествоПриход;
         КонецЕсли;
         
         //Нач. остаток         
            ОбластьДетальныхЗаписей.Параметры.Остаток = НачОстаток;
         //КоличествоПриходЗаДень = КоличествоПриходЗаДень + ВыборкаКонтрагент.КоличествоПриход; 
 
         ТабДок.Вывести(ОбластьДетальныхЗаписей);
                    //Флаг вывода итогов за день
         //датастрока =  Формат(ВыборкаПериод.регистратор,"ДФ=dd.MM.yy");
         //Выборка1=ВыборкаПериод.Следующий();
         //Если датастрока= Выборка1.найти(датастрока) Тогда
         //   фл=0
         //Иначе
         //Если (Формат(ВыборкаКонтрагент.регистратор,"ДФ=dd.MM.yy") = Формат(ВыборкаПериод.Регистратор,"ДФ=dd.MM.yy")) тогда
         //   фл=0
         //иначе
            //фл=1
         //конецесли;
         
         //КонецЕсли;
         
           
      КонецЦикла;
КонецЦикла;

Добавлено: 20 Сен 2013, 16:09

Наверное так. я сильно не смотрел!
Помогли, отблагодари!


Теги:
 

Значение "00000000001" поля "Код" не уникально

Автор gigsonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 6884
Последний ответ 24 Ноя 2014, 12:21
от gigson
Значение поля "Владелец" не заполнено или заполнено неверно

Автор ReclaimРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3247
Последний ответ 16 Ноя 2015, 09:36
от cska-fanat-kz
Как в СКД вычислить значение ресурса для группировки по значениям ресурса нижестоящей группировки

Автор ОтцовскийРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 975
Последний ответ 23 Ноя 2016, 12:53
от sertak
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1092
Последний ответ 02 Дек 2016, 12:58
от Jalib
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8559
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
61 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 155
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal