Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 05:22
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выкинуть из базы определенного пользователя - программно.  (Прочитано 14936 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн boobzx

  • ***
  • Сообщений: 124
  • РЕПУТАЦИЯ: 8
  • КПД: 6%
  • Регистрация: 2013-03-07
  • Сайт: 
  • Профессия: Ученик 1С
В общем задача.. Нужно выкинуть из базы определенного пользователя.

Т.е. Пишу обработку где выполняю код..

&НаСервере
Процедура ПолучитьАктПолНаСервере()

АктивныеПользователи.Очистить();

СоединенияИнформационнойБазы = ПолучитьСоединенияИнформационнойБазы();

Для Каждого Соединение Из СоединенияИнформационнойБазы Цикл 
ТЗ=АктивныеПользователи.Добавить(); 
Если ИмяПользователя() = Соединение.Пользователь.Имя Тогда
УсловноеОформление.Элементы[0].Отбор.Элементы[0].ПравоеЗначение = ИмяПользователя();
КонецЕсли;
ТЗ.Пользователь=Соединение.Пользователь.Имя;
ТЗ.Компьютер=Соединение.ИмяКомпьютера;
ТЗ.НачалоСеанса=Соединение.НачалоСеанса;                         
ТЗ.НачалоСоединения=Соединение.НачалоСоединения; 
ТЗ.ТипКлиента=ПредставлениеПриложения(Соединение.ИмяПриложения);
КонецЦикла;

нНомерТекущегоСоединения=НомерСоединенияИнформационнойБазы();
//В итоге получаем ТЗ со списком пользователей и Номер Текущего Соединения

КонецПроцедуры

Соответственно этой командой я ищу все активные сеансы. И вот если там я нашел определенного пользователя, то мне нужно его выкинуть. Как сделать? ЗавершитьРаботуСистемы(Ложь) - выкидывает только меня. Перечитал кучу форумов, ответа так и не нашел. Есть хрень под названием Сервис->управление пользователями->и там заблокировать ИБ.. но это мне не подходит.. 1 выкидываются все.. а мне не надо.. и есть самописные конфигурации.. где такой фичи вообще нет. Неужели никак не выгнать определенного пользователя?


Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
А нужно именно выгнать? может просто не пускать определенного пользователя в систему?

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Бейсбольная бита, удар!... и Пользователь уходит не только с программы, но и на больничный!
Если СКУЛ, то
Коннектор = Новый COMОбъект("V8.COMConnector"); 
Сервер = Коннектор.ConnectServer("server");
Сервер.AddAuthentication("Login","password");
ИнформационнаяБаза = Сервер.CreateInfoBaseInfo();
ИнформационнаяБаза.Name = "1c";
СоединенияБазы = Сервер.GetIBConnections(ИнформационнаяБаза);

Для Каждого Соединение Из СоединенияБазы Цикл
    Сервер.Disconnect(Соединение); //только здесь можно ненароком отключить самого себя
КонецЦикла;
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн boobzx

  • ***
  • Сообщений: 124
  • РЕПУТАЦИЯ: 8
  • КПД: 6%
  • Регистрация: 2013-03-07
  • Сайт: 
  • Профессия: Ученик 1С
Новенькая, не пускать другое дело.. есть пользователи.. которые тупа уходят и забывают закрыть 1с.. этот филиал в другом городе.. и занимаюсь я ими ночью.. а там никого нет.. выход.. только кикнуть их с 1с..
LordWizard, я это решение тоже видел.. но он мне не подходит.. потому что есть и файловый вариант базы..  и к тому же я так понял.. этот код требует аутентификацию на серерве 1с.. а этого у меня нет:) ыыы программисту 1с.. дали пользователя с правами гость:) я ничего не могу делать.. как только заходить в 1с.. и что-то творить там... пароли мне не дают:)
Сервер.AddAuthentication("Login","password");
Я так понимаю.. логин и пароль от 1с сервера? в любом случае.. от скуля и от сервера 1с.. паролей у меня нет.. кроме заведенного для меня пользователя в базы..по этому выход я вижу только 1... как-то кикнуть их из самой базы программно..
Добавлено: 18 Сен 2013, 12:19

Говорят такое решение есть в 1с-рарус.. там даже можно сообщения посылать другим пользователям.. и по отдельности выкидывать.. но как там это сделали.. х.з:)

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
глянь на инфостарте - может там что есть по этому поводу? Реально не понимаю - как ты без прав собираешься что-то делать!
Добавлено: 18 Сен 2013, 12:46

Соединение с рабочим процессом (IWorkingProcessConnection)
Disconnect (Disconnect)
Синтаксис:

Disconnect(<Соединение>)
Параметры:

<Соединение> (обязательный)

Тип: Соединение.
Описание соединения с информационной базой. Объект может быть получен ка элемент массива, возвращаемого методом GetInfoBaseConnections.
Описание:

Разрывает соединение клиента с рабочим процессом.

Доступность:

Интеграция.
Примечание:

После разрыва соединения соответствующее клиентское приложение завершится аварийно.

(выдержка из синтаксис- помощника)
Тут не указано, что и как. Значит можно рубить и так, без сервера и СКУЛа.
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Последний раз редактировалось: LordWizard; 18 Сен 2013, 12:46. Причина: Объединение сообщений


Теги:
 

Можете помочь написать обработку которая сможет делать реализацию списывая поступления из другой базы или ссылаясь на них? просто одна компания покупает другая продает этот товар и чтобы вторая компания не смогла продать больше чем есть у первой? 1с 8.2 2

Автор Юлия АндреевнаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 739
Последний ответ 13 Ноя 2016, 19:25
от BuhRust
Возможно ли получение эталонного файла конфигурации *.cf из измененной стандартной, например (УТ 11.1, БП 3.0) или вопрос о том как убрать лишние доработки и привести конфигурацию базы максимально к стандартной после варварских "доработок"?

Автор kostyaomskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 9150
Последний ответ 30 Дек 2015, 22:14
от 1Cnastroika
Как перенести конфу базы данных на новую конфу?

Автор dim3740Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 11238
Последний ответ 23 Авг 2010, 15:41
от mohock
восстановить учет после после уреза базы

Автор NarimanРаздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 3852
Последний ответ 16 Июн 2011, 15:02
от Nariman
Восстановление испорченной базы данных 1С [chdbfl.exe] [chdbfl]

Автор MuI_I_IkaРаздел Администрирование 1с

Ответов: 3
Просмотров: 28021
Последний ответ 04 Дек 2012, 13:13
от greenLiss

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 219
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal