Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 19:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ПОМОГИТЕ!!! Установить два одинаковых параметра  (Прочитано 1832 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн aleks-lit

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-02
  • Сайт: 
  • Профессия: Программист 1С
ЕСЛИ устанавливет параметр запроса
Если ТипДв="Приход" Тогда 
        Запрос.УстановитьПараметр("КодОперации", Перечисления.КодыОпераций.ПоступлениеЗерновых);
    ИначеЕсли ТипДв="Расход" Тогда
        Запрос.УстановитьПараметр("КодОперации", Перечисления.КодыОпераций.ОтгрузкаЗерновых);
    КонецЕсли;

Нужно чтобы было два параметра.
пробовал так:

Если ТипДв="Приход" Тогда 
        Запрос.УстановитьПараметр("КодОперации", Перечисления.КодыОпераций.ПоступлениеЗерновых);
    ИначеЕсли ТипДв="Расход" Тогда
        Запрос.УстановитьПараметр("КодОперации", Перечисления.КодыОпераций.ОтгрузкаЗерновых);
Запрос.УстановитьПараметр("КодОперации", Перечисления.КодыОпераций.ВывозОтходов);
    КонецЕсли;


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Запрос.УстановитьПараметр("КодОперации", Перечисления.КодыОпераций.ОтгрузкаЗерновых);
Запрос.УстановитьПараметр("КодОперации", Перечисления.КодыОпераций.ВывозОтходов);

так работать точно не будет. установится последнее значение.

правильно я понимаю, что нужно чтобы отодрались и те и другие?
если да, то в запросе нужно сравнение не на равенство, а на вхождение: "В (&КодОперации)" вместо "= &КодОперации".
тип значения КодОперации будет массив либо список значений. когда 1 значение - значит будет массив из 1 элемента, если 2 - соответственно, 2.

Оффлайн JoeButcher

  • *
  • Сообщений: 41
  • РЕПУТАЦИЯ: 2
  • КПД: 5%
  • Регистрация: 2010-12-28
  • Сайт: 
  • Профессия: Ученик 1С
Так может в данном случае как раз и использовать два параметра КодОперации1 и КодОперации2, а в запросе просто поменять условие?

Оффлайн aleks-lit

  • *
  • Сообщений: 21
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-03-02
  • Сайт: 
  • Профессия: Программист 1С
вот так заработало
в запросе:

И ЛабПараметрыОбороты.КодОперации В (&КодОперации)

Если ТипДв="Приход" Тогда
      Запрос.УстановитьПараметр("КодОперации", Перечисления.КодыОпераций.ПоступлениеЗерновых);
   ИначеЕсли ТипДв="Расход" Тогда
      СписокКодОперации = Новый СписокЗначений;
      СписокКодОперации.Добавить(Перечисления.КодыОпераций.ОтгрузкаЗерновых);
      СписокКодОперации.Добавить(Перечисления.КодыОпераций.ВывозОтходов);
      Запрос.УстановитьПараметр("КодОперации",СписокКодОперации );
   КонецЕсли;


ВСЕМ СПАСИБО ЗА ОПЕРАТИВНОСТЬ!!!


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4304
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5565
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5903
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4398
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1987
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
71 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 338
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal