Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 16:04
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Выгрузка в XML  (Прочитано 20243 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер

Здравствуйте!


Прошу сильно не пинать я начинающий.
Код собственно представлен. Почему собственно не создается файл itog.xml ?


&НаСервере


Процедура Команда1(Кнопка)
   
ЗаписьXML = Новый ЗаписьXML;


ЗаписьXML.ОткрытьФайл("C:\itog.xml");
ЗаписьXML.ЗаписатьОбъявлениеXML();
ЗаписьXML.ЗаписатьНачалоЭлемента("Выгрузка");




Выборка = Документы.Прием.Выбрать();


Пока Выборка.Следующий()Цикл
   
   ЗаписьXML.ЗаписатьНачалоЭлемента("Выгрузка");
   
   ЗаписьXML.ЗаписатьАтрибут("Номер", Строка(Выборка.Номер));
   
ЗаписьXML.ЗаписатьКонецЭлемента();


ЗаписьXML.ЗаписатьКонецЭлемента();


ЗаписьXML.Закрыть();


КонецЦикла;


   
КонецПроцедуры





Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Re: Выгрузка в XML
« Ответ #1: 15 Сен 2013, 20:45 »
Эксель = Новый COMObject("Excel.Application");
        Книга = Эксель.WorkBooks.Open(ИмяФайла);
        Лист = Книга.WorkSheets(НомерЛиста);
        area  = Лист.UsedRange;
        НайденнаЯчейка = area.Find(ИскомоеЗначение);       
        Лист.Cells(НайденнаЯчейка.Row,НайденнаЯчейка.Column).Value = Значение;
        Книга.SaveAs(ИмяФайла);
        Эксель.Application.Quit();
вот пример кода тебе
где у тебя использовать приложение Exel вообще?
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
Re: Выгрузка в XML
« Ответ #2: 15 Сен 2013, 20:47 »
а при чем тут excel ?

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Re: Выгрузка в XML
« Ответ #3: 15 Сен 2013, 20:51 »
пардон. попутал.
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Выгрузка в XML
« Ответ #4: 15 Сен 2013, 21:19 »
&НаКлиенте
Добавлено: 15 Сен 2013, 21:21

Кнопка должны исполняться на КЛИЕНТЕ
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Re: Выгрузка в XML
« Ответ #5: 15 Сен 2013, 21:24 »
//процедура выгружает элементы справочника "Физические лица" в файл формата XML

Процедура Лица_Выгрузить()

     //справочник

     С=СоздатьОбъект("Справочник.Лица");

     //анализатор

     Анализатор=СоздатьОбъект("AddIn.XMLParser");

     Корень=Анализатор.СоздатьДокумент();

     //данные

     Данные=Корень.СоздатьПодчиненныйЭлемент("Данные");

     Данные.УстановитьАтрибут("Дата",ТекущаяДата());

     Данные.УстановитьАтрибут("Время",ТекущееВремя());

     Данные.УстановитьАтрибут("Автор",гПользователь.Наименование);

     //наполнение

     Группа=Данные;

     С.ВыбратьЭлементы();

     Пока С.ПолучитьЭлемент()=1 Цикл

          Если С.ЭтоГруппа()=1 Тогда

               Группа=Данные.СоздатьПодчиненныйЭлемент(С.Наименование);

          Иначе

               Э=Группа.СоздатьПодчиненныйЭлемент("Лицо");

               Э.Значение=С.Код;

               Э.УстановитьАтрибут("Наименование",С.Наименование);

          КонецЕсли;

     КонецЦикла;

     //запись

     Корень.Записать("C:\People.xml");

     Предупреждение("ОК");

КонецПроцедуры

 
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
Re: Выгрузка в XML
« Ответ #6: 16 Сен 2013, 11:30 »
Хотел еще такие моменты уточнить:
1) что с моим кодом не так?
2) почему когда я пишу директиву &На клиенте у меня выходит ошибка:переменная не определена Документ?
3) и еще хотел попросить, если не сложно привести пример Загрузки XML.


Спасибо заранее.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Выгрузка в XML
« Ответ #7: 17 Сен 2013, 01:26 »
1. Потому что кнопка есть только на клиенте и выполняться ее обработчик должен на клиенте!
2. Потому что менеджеры не доступны на клиенте для обращения к менеджерам нужно вызывать сервер!
3. Пример вашего же кода:

&НаКлиенте
Процедура Команда1(Кнопка)

   КомандаНаСервере();
   
КонецПроцедуры

&НаСервере
Процедура КомандаНаСервере()

ЗаписьXML = Новый ЗаписьXML;

ЗаписьXML.ОткрытьФайл("C:\itog.xml");
ЗаписьXML.ЗаписатьОбъявлениеXML();
ЗаписьXML.ЗаписатьНачалоЭлемента("Выгрузка");

Выборка = Документы.Прием.Выбрать();

Пока Выборка.Следующий()Цикл
   
   ЗаписьXML.ЗаписатьНачалоЭлемента("Выгрузка");
   
   ЗаписьXML.ЗаписатьАтрибут("Номер", Строка(Выборка.Номер));
   
   ЗаписьXML.ЗаписатьКонецЭлемента(); 

КонецЦикла;

ЗаписьXML.ЗаписатьКонецЭлемента(); //вынес из цикла что бы закрыть корень

ЗаписьXML.Закрыть(); //Закрываем когда выборка прошла весь цикл

КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн cobra77777

  • ***
  • Сообщений: 164
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2011-08-26
  • Сайт: 
  • Профессия: Бухгалтер
Re: Выгрузка в XML
« Ответ #8: 17 Сен 2013, 07:40 »

Dethmontt БОЛЬШОЕ СПАСИБО !



Добавлено: 17 Сен 2013, 13:13

Выгрузка файла прошла успешна в итоге я получил такой формат:
Как теперь произвести загрузку из файла itog.xml? Спасибо

<?xml version="1.0" encoding="UTF-8"?>
<Выгрузка>
   <Выгрузка Номер="000000001" Дата="05.02.2013 12:51:14" СотрудникГруппы="Иванов И.Т." СотрудникОтдела="Никулин Н.В." Деталь="Подшпиник" Склад="Основной" Описание="аввыафыа"/>
   <Выгрузка Номер="000000002" Дата="10.02.2013 10:52:14" СотрудникГруппы="Сидоров А.А." СотрудникОтдела="Ахметов А.П." Деталь="Подшпиник" Склад="Основной" Описание="ппара"/>
......................................
</Выгрузка>

Последний раз редактировалось: cobra77777; 17 Сен 2013, 13:13. Причина: Объединение сообщений

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Выгрузка в XML
« Ответ #9: 17 Сен 2013, 19:28 »
При помощи объекта ЧтениеXML
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

выгрузка из "Платежные документы" выборочно в "Бухгалтерию предприятия"

Автор hkvРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4112
Последний ответ 09 Окт 2014, 15:58
от дфтын
Выгрузка Бух учет из "Зарплаты и управления персоналом 8" в "1С:Бухгалтерию 8"

Автор KazakOFFРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2426
Последний ответ 10 Ноя 2015, 16:20
от vitasw
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8572
Последний ответ 26 Апр 2012, 23:08
от Dethmontt
Модуль "выгрузка в банк"

Автор Dima IgnatovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 947
Последний ответ 11 Май 2016, 13:23
от Rasty
Выгрузка из "Зарплата и кажпы" платеж за три месяца

Автор vlasssov71Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1231
Последний ответ 07 Июл 2015, 15:19
от vlasssov71

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 255
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal