Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 00:25
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: ПриИзменении()  (Прочитано 3431 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн elwis91

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-23
  • Сайт: 
  • Профессия: Ученик 1С
здравствуйте.есть такая задача, мне нужно чтобы при выборе реквизита Водитель(СправочникСсылка.Физические Лица) реквизит Автомобиль(СправочникСсылка.ЗначенияСвойствОбъектов) заполнялся автоматически.
я так понял на форме списка я выбираю водителя, в событии ПриИзменении, должен написать этот обработчик событий.Подскажите пожалуйста как сделать



Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
Re: ПриИзменении()
« Ответ #1: 12 Сен 2013, 12:57 »
в событии ПриИзменении
в событии ОбработкаВыбора, вызываете серверную процедуру в к\ю передаете выбранное значение (водитель), в к\й запросом из соотвествующих регистров вытаскиваете нужные сведения, затем заполняете этими данными соответсвующие реквизиты формы

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Re: ПриИзменении()
« Ответ #2: 12 Сен 2013, 13:01 »
не только обработчик, но и связь с реквизитом, на основании которого перезаполняется.
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн elwis91

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-23
  • Сайт: 
  • Профессия: Ученик 1С
Re: ПриИзменении()
« Ответ #3: 13 Сен 2013, 11:52 »
кому интересно вот сделал. Теперь следущий вопрос.мне сказали еше нужно, чтобы была возможность ручного ввода автомобиля.Подскажите как это сделать?
Процедура ВодительПриИзменении(Элемент)
   Запрос = Новый Запрос;
   Запрос.Текст="ВЫБРАТЬ
                |   ЗначенияСвойствОбъектов.Значение
                |ИЗ
                |   РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
                |ГДЕ
                |   ЗначенияСвойствОбъектов.Объект = &Объект
                |   И ЗначенияСвойствОбъектов.Свойство.Наименование = &НаименованиеСвойства";
   Запрос.УстановитьПараметр("НаименованиеСвойства","Транспортное средство");
   Запрос.УстановитьПараметр("Объект",Водитель);
//  Если не Запрос.Выполнить().Пустой() тогда
//  Автомобиль=Запрос.Выполнить().Выгрузить()[0].Значение;
//   КонецЕсли;
   
   Для каждого стр из Запрос.Выполнить().Выгрузить()
      цикл
           Автомобиль=стр.Значение;
      
      КонецЦикла;
КонецПроцедуры

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Re: ПриИзменении()
« Ответ #4: 13 Сен 2013, 11:59 »
кому интересно вот сделал. Теперь следущий вопрос.мне сказали еше нужно, чтобы была возможность ручного ввода автомобиля.Подскажите как это сделать?
Процедура ВодительПриИзменении(Элемент)
   Запрос = Новый Запрос;
   Запрос.Текст="ВЫБРАТЬ
                |   ЗначенияСвойствОбъектов.Значение
                |ИЗ
                |   РегистрСведений.ЗначенияСвойствОбъектов КАК ЗначенияСвойствОбъектов
                |ГДЕ
                |   ЗначенияСвойствОбъектов.Объект = &Объект
                |   И ЗначенияСвойствОбъектов.Свойство.Наименование = &НаименованиеСвойства";
   Запрос.УстановитьПараметр("НаименованиеСвойства","Транспортное средство");
   Запрос.УстановитьПараметр("Объект",Водитель);
//  Если не Запрос.Выполнить().Пустой() тогда
//  Автомобиль=Запрос.Выполнить().Выгрузить()[0].Значение;
//   КонецЕсли;
   
   Для каждого стр из Запрос.Выполнить().Выгрузить()
      цикл
           Автомобиль=стр.Значение;
      
      КонецЦикла;
КонецПроцедуры


Главное работает! Молодца!
Анек:
"Приходит малец программера с садика домой, а тот в это время сидит и пишет прогу.
-Пап, там такое нам воспиталка расказала!?!
-Что случилось сынок? - не оборачиваясь от ратного труда, программер.
-Представляешь, солнышко встает утром на небо и там ходит целый день!
-Сынок! Работает? Работает! Так вот - ничего не трогай!"
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн elwis91

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-23
  • Сайт: 
  • Профессия: Ученик 1С
Re: ПриИзменении()
« Ответ #5: 13 Сен 2013, 12:13 »
всех с праздником кстати!)ну а все-таки, как сделать чтобы еще вручную можно было заполнять?

Оффлайн LordWizard

  • "Иди учи бухгалтерский учет и не беспокой просьбами господа Бога!"
  • *****
  • Сообщений: 1463
  • РЕПУТАЦИЯ: 221
  • КПД: 15%
  • Пишу, консультирую, да и так - по клавишам...
  • Регистрация: 2011-07-25
    • Skype: warlock02121968
  • Сайт: 
  • Профессия: Консультант 1С
Re: ПриИзменении()
« Ответ #6: 13 Сен 2013, 12:21 »
всех с праздником кстати!)ну а все-таки, как сделать чтобы еще вручную можно было заполнять?

посмотри в настройках и по тексту по данному полю реквизита на доступность.
Добавлено: 13 Сен 2013, 12:21

всех с праздником кстати!)ну а все-таки, как сделать чтобы еще вручную можно было заполнять?

посмотри в настройках и по тексту по данному полю реквизита на доступность.
Пятница 13-е? :xfbnsdfb:
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Оффлайн elwis91

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-23
  • Сайт: 
  • Профессия: Ученик 1С
Re: ПриИзменении()
« Ответ #7: 13 Сен 2013, 12:23 »
день программиста!)ну и пятница 13ое заодно:D


Теги:
 

событии "ПриИзменении()"

Автор umnicaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1550
Последний ответ 09 Май 2012, 16:09
от umnica
Как программно вызывать обработчик ПриИзменении поля табличной части после того, как форма была заполнена программно?

Автор ИстребительРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4340
Последний ответ 27 Июл 2015, 06:21
от cska-fanat-kz
Как получить значения элементов формы "ПриИзменении"?

Автор OptyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 7919
Последний ответ 07 Май 2015, 14:38
от Opty
Дополнительные реквизиты и ф-ция ПриИзменении(Элемент)

Автор virus555Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3379
Последний ответ 16 Мар 2011, 17:57
от virus555
ПриИзменении Даты и Срока(В Годах)

Автор Митя_Просто_МитяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1318
Последний ответ 15 Дек 2011, 00:52
от evialen

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 213
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal