Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 19:12
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение формы списка документа по отбору запросом  (Прочитано 12470 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Tgr11

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-27
  • Сайт: 
Добрый день, уважаемые пользователи. Столкнулась с такой задачей: Нужно в форме списка документа по отбору вывести новый список документов. Я собрала данные документы, сделала реквизит с отбором, но табличная часть формы не заполняется по отбору, не подскажите почему? Подскажите что написать после получения нового списка значений?
Процедура ОтборСметаПриИзменении(Элемент)
   СметныйДокумент = Элемент.Значение;
   ВывестиПодчиненныеДокументы();
КонецПроцедуры
Процедура ВывестиПодчиненныеДокументы()
   //для отображения актов по смете
   Список = Новый СписокЗначений;
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |   ВыполненныеРаботыПериод.Регистратор КАК Ссылка
   |ИЗ
   |   РегистрНакопления.ВыполненныеРаботы КАК ВыполненныеРаботыПериод
   |ГДЕ
   |   ВыполненныеРаботыПериод.СметныйДокумент = &Ссылка
   |   И ВыполненныеРаботыПериод.ВидДвижения = &Вид
   |СГРУППИРОВАТЬ ПО
   |   ВыполненныеРаботыПериод.Регистратор";
   Запрос.УстановитьПараметр("Ссылка", ЭлементыФормы.СметныйДокумент.Значение);
   Запрос.УстановитьПараметр("Вид", ВидДвиженияНакопления.Расход);
   ТабАктов = Запрос.Выполнить().Выгрузить();
   СписокДокументов.Колонки.Добавить("Ссылка");


Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
ТабАктов = Запрос.Выполнить().Выгрузить();
   СписокДокументов.Колонки.Добавить("Ссылка");

ТабАктов - какой тип?
Помогли, отблагодари!

Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
Не очень понятно что именно вы хотите сделать...На каком этапе вы хотите наложить отбор на список документов??? вы открываете форму списка по какой-то кнопке и хотите видеть список с отбором??? или как??? К примеру, отбор обычно на списки накладывается так:
ФормаВыбора=Документы.ПлатежноеПоручениеИсходящее.ПолучитьФормуВыбора();
   ФормаВыбора.ДокументСписок.Отбор.Организация.Значение                            = Организация;
   ФормаВыбора.ДокументСписок.Отбор.Организация.Использование                       = Истина;
в этом случае откроется форма с нужным отбором. Форма обычная или управляемая?

Оффлайн Tgr11

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-27
  • Сайт: 
Это процедура будет выполняться при установке выбора документа, когда мы ставим документ в форме списка документа должны отобразиться акты подчиненные данному документу...реквизита Документ-основания нет, поэтому я собрала нужные документы в списке значений...то что написано на данный момент не работает(((не могу понять свой алгоритм действий, чтобы работал.. помогите пожалуйста
Добавлено: 05 Сен 2013, 16:56

форма обычная
Добавлено: 05 Сен 2013, 16:58

ТабАктов = Запрос.Выполнить().Выгрузить();
   СписокДокументов.Колонки.Добавить("Ссылка");

ТабАктов - какой тип?

таблица значений

Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
ТабАктов - это таблицаЗначений на форме? как называется список на форме куда вы пытаетесь вывести?
Добавлено: 05 Сен 2013, 17:09

Если на форме у вас табл часть "Список документов" и вы туда пытаетесь вывести, может это вам поможет:
ТабАктов = Запрос.Выполнить().Выгрузить();
      
Для Каждого ТекСтрока Из ТабАктов Цикл
                  
   НоваяСтрока = СписокДокументов.Добавить();
   НоваяСтрока.Документ= ТекСтрока.Ссылка;
               
КонецЦикла;

Оффлайн Tgr11

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-06-27
  • Сайт: 
ТабАктов - это таблицаЗначений на форме? как называется список на форме куда вы пытаетесь вывести?
Добавлено: 05 Сен 2013, 17:09

Если на форме у вас табл часть "Список документов" и вы туда пытаетесь вывести, может это вам поможет:
ТабАктов = Запрос.Выполнить().Выгрузить();
      
Для Каждого ТекСтрока Из ТабАктов Цикл
                  
   НоваяСтрока = СписокДокументов.Добавить();
   НоваяСтрока.Документ= ТекСтрока.Ссылка;
               
КонецЦикла;
ДокументСписок.АктВыполненныхРабот тип значения на форме

Оффлайн Yura063

  • *****
  • Сообщений: 1045
  • РЕПУТАЦИЯ: 136
  • КПД: 13%
  • Регистрация: 2010-11-15
  • Сайт: yuis.ru
  • Профессия: Программист 1С
Совсем мало что понятно! у вас реквизит (тот который отображает вашу табличную часть на форме), куда вы хотите загрузить ссылки как называется?
Добавлено: 05 Сен 2013, 17:55

Цитировать
Процедура ВывестиПодчиненныеДокументы()
   //для отображения актов по смете
   Список = Новый СписокЗначений;
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |   ВыполненныеРаботыПериод.Регистратор КАК Ссылка
   |ИЗ
   |   РегистрНакопления.ВыполненныеРаботы КАК ВыполненныеРаботыПериод
   |ГДЕ
   |   ВыполненныеРаботыПериод.СметныйДокумент = &Ссылка
   |   И ВыполненныеРаботыПериод.ВидДвижения = &Вид
   |СГРУППИРОВАТЬ ПО
   |   ВыполненныеРаботыПериод.Регистратор";
   Запрос.УстановитьПараметр("Ссылка", ЭлементыФормы.СметныйДокумент.Значение);
   Запрос.УстановитьПараметр("Вид", ВидДвиженияНакопления.Расход);
   ТабАктов = Запрос.Выполнить().Выгрузить();
   СписокДокументов.Колонки.Добавить("Ссылка");
дальше
   
СписокДокументов.Загрузить(ТабАктов);
если конечно у вас СписокДокументов - таблица значений, если список значений выгружайте колонку из ТабАктов
Помогли, отблагодари!

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Если форма на которую вы хотите наложить отбор имеет тип "ДокументСписок" тогда примерно вот так (вам уже показывали выше!)

Список = Новый СписокЗначений;
//.............
//.............
   Запрос.УстановитьПараметр("Вид", ВидДвиженияНакопления.Расход);
   Список.ЗагрузитьЗначения(Запрос.Выполнить().Выгрузить().ВыгрузитьКолонку("Ссылка"));

СписокДокументов.Отбор.Ссылка.ВидСравнения = ВидСравнения.ВСписке;
СписокДокументов.Отбор.Ссылка.Значение = Список;
СписокДокументов.Отбор.Ссылка.Использование = Истина;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4470
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7735
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4773
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8485
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7332
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
48 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 360
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal