Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 23:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: в журнале ЗаказыПокупателей нужно строчки окрашивать в разный цвет  (Прочитано 2683 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mikel10

  • ***
  • Сообщений: 108
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-01
  • Сайт: 
Конфигурация Управление торговлей
Есть журнал ЗаказаПокупателей. В зависимости от реквизита СостояниеЗаказа строчку журнала нужно окрасить в определенный цвет. Например СостояниеЗаказа ПеревозчикОплачен- эту строчку окрашиваем в голубой цвет, далее
СостояниеЗаказа СнятКлиентом - строчку окрашиваем в красный, СостояниеЗаказа ЗакрытиеЗаказа - строчку окрашиваем в синий.
Подскажите пожалкйста как это сделать, если нужны дополнительные комментарии задавайте вопросы


Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
событие есть такое ПриВыводеСтроки - в нем получаете оформление строки и задаете цвет
Добавлено: 29 Авг 2013, 12:31

УТ 10 или 11?
да, про этот нюанс забыл...

моя рекомендация относится к версии 10, т.е. обычные формы, не управляемые

Оффлайн Gunner

  • ****
  • Сообщений: 291
  • РЕПУТАЦИЯ: 23
  • КПД: 8%
  • Регистрация: 2011-08-07
  • Сайт: 
  • Профессия: Программист 1С
Использовать обработчик события табличного поля формы журнала "При получении данных"
Процедура СписокПриПолученииДанных(Элемент, ОформленияСтрок)
Для каждого СтрокаОформленияСписка Из ОформленияСтрок Цикл
    Если СтрокаОформленияСписка.ДанныеСтроки.СостояниеЗаказа = "Нужное состояние" Тогда
            СтрокаОформленияСписка.ЦветТекста = WebЦвета.Красный;
    Иначе
        СтрокаОформленияСписка.ЦветТекста = WebЦвета.Синий;
        КонецЕсли;
КонецЦикла;
КонецПроцедуры


Теги:
 

Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2752
Последний ответ 27 Май 2016, 15:19
от Олька Бякина
Нужно добавить к документу "Оригинал получен"

Автор ZnNuРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 729
Последний ответ 27 Окт 2016, 08:37
от alexandr_ll
Что нужно делать чтобы в отчете "Продажи по оплате" отображалась стоимость услуг?

Автор TonyMontanaSlotРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 1301
Последний ответ 02 Апр 2015, 12:28
от Artemtriplex
Для всех документов нужно сделать проверку при проведении. Где это можно сделать?

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 633
Последний ответ 04 Сен 2016, 04:20
от cska-fanat-kz
Работнику, который в течение года вновь устроился на работу в ту же компанию, заново рассчитывать базу для начисления взносов с выплат не нужно

Автор newsРаздел Новости

Ответов: 0
Просмотров: 1320
Последний ответ 22 Июн 2015, 09:43
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
49 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 294
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal