Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 00:07
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Сброс отбора у форми списка  (Прочитано 3117 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн bkmz_1_

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-07-18
    • Skype: bkmz_1_
  • Сайт: 
  • Профессия: Бухгалтер
Есть код

&НаКлиенте
Процедура ФильтрАвтоПриИзменении(Элемент)
Список.Отбор.Элементы.Очистить();
ЭлементОтбора = Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
    ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Авто");
    ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
    ЭлементОтбора.ПравоеЗначение = ФильтрАвто;
    ЭлементОтбора.Использование = Истина;
КонецПроцедуры


Он у меня фильтрует список при изменении авто. А как мне сделать так что если я удаляю авто то мне не будет фильтровать по пустоте а покажет полный список?
Чем ленивее человек, тем больше его труд похож на подвиг


Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С

Оффлайн bkmz_1_

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-07-18
    • Skype: bkmz_1_
  • Сайт: 
  • Профессия: Бухгалтер
Разобрался. Надо было запретить делать отбор по пустоте. И создать в обработчике события "очистить" сброс элемент отбора.

&НаКлиенте
Процедура ФильтрАвтоПриИзменении(Элемент)
Если НЕ ФильтрАвто.Пустая() Тогда
   Список.Отбор.Элементы.Очистить();
   ЭлементОтбора = Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
       ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("Авто");
       ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
       ЭлементОтбора.ПравоеЗначение = ФильтрАвто;
       ЭлементОтбора.Использование = Истина;
КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ФильтрАвтоОчистка(Элемент, СтандартнаяОбработка)
Список.Отбор.Элементы.Очистить();
КонецПроцедуры
Чем ленивее человек, тем больше его труд похож на подвиг


Теги:
 

Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 263
Последний ответ 12 Окт 2017, 14:02
от wise
Как из справочника вытащить список одной группы справочника и вставить его в поле документа для выбора одного элемента из полученного списка?

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1675
Последний ответ 21 Сен 2016, 08:16
от GadLex
Изменение вида "выпадающего списка"

Автор JohnDoe144Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1216
Последний ответ 20 Май 2016, 13:26
от LexaK
Отключение кнопки "Отключить отбор" на панели формы списка документа

Автор AlterMannРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 10310
Последний ответ 13 Мар 2013, 09:41
от AlterMann
Где найти вкладку "Параметры", в конструкторе запроса при создании динамического списка?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 792
Последний ответ 09 Мар 2017, 14:48
от LexaK

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 270
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal