Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 00:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Написание отчета  (Прочитано 2848 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lena.evdokimova

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-14
  • Сайт: 
  • Профессия: Программист 8.1
Здравствуйте ребята нужен простой отчет чтоба на слово "вет" сформировался отчет:
Дата нач
Дата конц
словов: вет
далее таблица где:
Дата Номер Сумма Ктнрагент АдресДоставки Организация Экспедитор



Процедура КнопкаВыполнитьНажатие(Кнопка)
   Если ПустаяСтрока(ПолеВвода1) Тогда
      Предупреждение("Нет слова для поиска");
      Возврат;
   КонецЕсли;
   Запрос = Новый Запрос;
   Запрос.Текст =  "
      |Выбрать
      |   *
      |ИЗ
      |   ЖурналДокументов.ЗаказыПокупателей
      |ГДЕ
      |   Видоперации = ЗНАЧЕНИЕ(Перечисление.ВидыОперацийРеализацияТоваровиУслуг.ЗаказыПокупателей)
      |И
      |   НЕ ПометкаУдаления
      |И
      |   Проведен
      |И
      |   ВЫРАЗИТЬ(НазначениеПлатежа КАК СТРОКА(250)) ПОДОБНО &Усл
      | И Дата МЕЖДУ &НачПериода И &КонПериода
      | УПОРЯДОЧИТЬ ПО Дата";
   
   
   Запрос.УстановитьПараметр("НачПериода",НачПериода);
   Запрос.УстановитьПараметр("КонПериода",КонПериода);
   Выборка = Запрос.Выполнить().Выбрать();
    Состав.Очистить();
   Пока Выборка.Следующий() Цикл
      НоваяСтрока = Состав.Добавить();
      НоваяСтрока.Документ = Выборка.Ссылка;
      НоваяСтрока.КонтрАгент = Выборка.Ссылка.Контрагент;
      НоваяСтрока.Дата = Выборка.Ссылка.Дата;
      НоваяСтрока.Номер = Выборка.Ссылка.НомерДокумента;
      НоваяСтрока.Сумма = Выборка.Ссылка.СуммаДокумента;
      НоваяСтрока.АдресДоставки = Выборка.Ссылка.РегистрСведений.КонтактнаяИнформация;
      НоваяСтрока.Организация = Выборка.Ссылка.РегистрСведений.КонтактнаяИнформация;
      НоваяСтрока.Организация = Выборка.Ссылка.Справочник.Организаци;
      НоваяСтрока.Экспедитор = Выборка.Ссылка.Справочник.ФизичискиеЛица;

   КонецЦикла;
КонецПроцедуры

Процедура ВыбПериодНажатие(Элемент)
   НастройкаПериода = Новый НастройкаПериода;
   НастройкаПериода.УстановитьПериод(НачПериода, ?(КонПериода='0001-01-01', КонПериода, КонецДня(КонПериода)));
   НастройкаПериода.РедактироватьКакИнтервал = Истина;
   НастройкаПериода.РедактироватьКакПериод = Истина;
   НастройкаПериода.ВариантНастройки = ВариантНастройкиПериода.Период;
   Если НастройкаПериода.Редактировать() Тогда
      НачПериода = НастройкаПериода.ПолучитьДатуНачала();
      КонПериода = НастройкаПериода.ПолучитьДатуОкончания();
   КонецЕсли;
КонецПроцедуры

Процедура СоставВыбор(Элемент, ВыбраннаяСтрока, Колонка, СтандартнаяОбработка)
   СтандартнаяОбработка = Ложь;
   ТекСтрока = ЭлементыФормы.Состав.ТекущаяСтрока;
   Если ТекСтрока <> Неопределено Тогда
      ФормаЭлемента = ТекСтрока.Документ.Ссылка.ПолучитьФорму();
      ФормаЭлемента.ОткрытьМодально();
   КонецЕсли;   
КонецПроцедуры

 
 
НачПериода = ТекущаяДата();
КонПериода = ТекущаяДата();



   //Если ПустаяСтрока(ПолеВвода) Тогда
   //   Предупреждение("Нет слова для поиска");
   //   Возврат;
   //КонецЕсли;
   //Запрос = Новый Запрос;
   //Запрос.Текст =  "
   //|ВЫБРАТЬ
   //|   Ссылка,
   //|   Дата
   //|ИЗ
   //|   Документ.РеализацияТоваровИУслуг
   //|ОБЪЕДИНИТЬ
   //|ВЫБРАТЬ
   //|   Ссылка,
   //|   Дата
   //|ИЗ
   //|Документ.ЗаказыПокупателей
   //|ГДЕ
   //| ВЫРАЗИТЬ(НазначениеПлатежа КАК СТРОКА(250)) ПОДОБНО &Усл
   //| И Дата МЕЖДУ &НачПериода И &КонПериода
   //| УПОРЯДОЧИТЬ ПО Дата" ;
   //Запрос.УстановитьПараметр("НачПериода",НачПериода);
   //Запрос.УстановитьПараметр("КонПериода",КонПериода);
   //Выборка = Запрос.Выполнить().Выбрать();
   //Состав.Очистить();
   //Пока Выборка.Следующий() Цикл
   //   НоваяСтрока = Состав.Добавить();
   //   НоваяСтрока.Документ = Выборка.Ссылка;
   //КонецЦикла;

Кому не сложно проверьте пожалуйста отчет! Еще не могу исправить ошибку
({Форма.Форма(28,5)}: Переменная не определена (Состав)
    <<?>>Состав.Очистить();
{Форма.Форма(30,17)}: Переменная не определена (Состав)
      НоваяСтрока = <<?>>Состав.Добавить();
)


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Re: Написание отчета
« Ответ #1: 27 Авг 2013, 14:37 »
1. не вижу нигде установки значения параметра &Усл
2. при сравнении через ПОДОБНО вероятно (хотя я не знаю в точности сути вашей задачи) следует использовать символы %:
либо в тексте запроса
    |   ВЫРАЗИТЬ(НазначениеПлатежа КАК СТРОКА(250)) ПОДОБНО "%"+&Усл+"%"
либо при  установке значения параметра
Запрос.УстановитьПараметр("Усл", "%"+Усл+"%");

3.
Переменная не определена (Состав)
означает, что вы пытаетесь добавлять строки и очищать то, чего нет на форме. Состав в вашем случае - это что? таблица значений? она должна быть определена - либо как реквизит формы, либо как реквизит объекта, либо как переменная модуля.


Оффлайн lena.evdokimova

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-14
  • Сайт: 
  • Профессия: Программист 8.1
Re: Написание отчета
« Ответ #2: 27 Авг 2013, 14:50 »
до установление параметров еще не дошла, пока только выдает ошибку на перечислениях:dfbsdfbsdf: пока
{Форма.Форма(27)}: Ошибка при вызове метода контекста (Выполнить): {(7, 41)}: Синтаксическая ошибка "(Перечисление.ВидыОперацийЗаказПокупателей.ПродажаКомиссия)"
ЗаказПокупателей.ВидОперации = ЗНАЧЕНИЕ<<?>>(Перечисление.ВидыОперацийЗаказПокупателей.ПродажаКомиссия)
   Выборка = Запрос.Выполнить().Выбрать();



Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Re: Написание отчета
« Ответ #3: 27 Авг 2013, 14:59 »
ну видимо нет такого значения перечисления. проверьте.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Написание отчета
« Ответ #4: 27 Авг 2013, 19:23 »
Вы думаете такое перечисление есть?

Перечисление.ВидыОперацийРеализацияТоваровиУслуг.ЗаказыПокупателей
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Печатная форма "ЧекККМ" для "Отчета о розничных продажах"

Автор Игорь ПолищукРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 7072
Последний ответ 01 Июн 2011, 20:39
от Шурыгин Иван Сергеевич
Формирование отчёта "Задолженость по контрагентам" 1С:Предприятие 8.2 "Торговля для частных предпринимателей базовая", редакция 1.0

Автор casper009Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3008
Последний ответ 27 Май 2015, 10:02
от casper009
Ошибка при выгрузке отчета "Прибыль"

Автор VasilРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4103
Последний ответ 28 Апр 2011, 14:34
от MaryaAlbertovna
Создание отчета "Отсутствие заказов"

Автор dronspartak9@gmail.comРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3887
Последний ответ 16 Апр 2014, 15:09
от dronspartak9@gmail.com
Программирование отчета "Движения на складах"

Автор ЛунатикРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1970
Последний ответ 05 Апр 2016, 10:15
от vitasw

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
61 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 197
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal