Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 05:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: счетчик строк в журнале документов  (Прочитано 6313 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mikel10

  • ***
  • Сообщений: 108
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-01
  • Сайт: 
подскажите пожалуйста как сделать счетчик строк в журнале документов Заказыокупателей.
 


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
а подробнее? что за счетчик и зачем он нужен (как будет использоваться)?

Оффлайн mikel10

  • ***
  • Сообщений: 108
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-01
  • Сайт: 
счетчик активируется и становиться видимым только при включенном отборе. Зачем он нужен мне не сказали.
Используется таким образом, например в верхней части журнала отображается цифра . Это все.
Добавлено: 27 Авг 2013, 10:55

Есть такое решение
Процедура ДокументСписокПриПолученииДанных(Элемент, ОформленияСтрок)
колво = 0;
Для Каждого стр Из ОформленияСтрок Цикл
  колво = колво + 1;
КонецЦикла;

Сообщить(колво);

КонецПроцедуры

Встает вопрос: Я добавил эту процедуру в форму списка журнала. Процедура не вызывается???
Подкажите в чем проблема

Последний раз редактировалось: mikel10; 27 Авг 2013, 10:55. Причина: Объединение сообщений

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Зачем он нужен мне не сказали.
напрасно вы не спросили.
 
стает вопрос: Я добавил эту процедуру в форму списка журнала. Процедура не вызывается???
Подкажите в чем пробле
процедура указана в свойствах табличного поля в качестве обработчика события ПриПолученииДанных?

судя по вашему коду, счетчик - имеется ввиду просто вывод количества строк, так?
если да, то ПриПолученииДанных не подойдет, во всяком случае в том виде, как вы написали точно не подойдет. суть в том, что это событие отрабатывает 2 раза - сначала для первой строки и потом для всех остальных.
т.е. как вариант можно оставить ваш код, только перед выводом увеличить количество еще на 1 (учесть первую строку)

Оффлайн mikel10

  • ***
  • Сообщений: 108
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-01
  • Сайт: 
последний вопрос : Эта процедура (см выше ) расчитывает кол-во строк, которое уместилось на мониторе, но не кол-во строк журнала. У меня на мониторе уместилось 34 строки, а в журнале строк намного больше. А нужна именно цифра - кол-во строк всего журнала.

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
ну так с этого же и надо было начинать.
общее количество строк можно получить запросом:

ВЫБРАТЬ
   КОЛИЧЕСТВО(*) КАК КоличествоЗаписей
ИЗ
   Документ.ЗаказПокупателя КАК ЗаказПокупателя

Оффлайн mikel10

  • ***
  • Сообщений: 108
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-01
  • Сайт: 
нет, не общее количество, а кол-во строк которое отображается в открытом журнале, оно отличается от общего количества, например мы задали в журнале интервал, или условия отбора

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
вот все ж из вас клещами вытаскивать приходится.
сформулировали бы задачу сразу четко, ответ был бы быстрее.

в вашем случае надо обработать отбор и добавить указанные в нем условия в запрос. подробнее см. синтаксис-помощник ЖурналДокументовСписок.<Имя журнала документов>.Отбор

с периодом должно быть примерно то же самое, хотя не уверен - надо во-первых проверить, не содержатся ли настройки периода в свойстве Отбор, а во-вторых, если не содержатся, то покопаться в синтаксис-помощнике и поискать.
Добавлено: 27 Авг 2013, 15:09

проверил на простой обработке - так и есть - отбор по периоду попадает в свойство Отбор, соответственно оттуда его можно получить и использовать.

таким образом ваша задача заключается в том, чтобы программно пройтись по всем полям отбора и на их основе добавить условия в текст запроса.
Добавлено: 27 Авг 2013, 15:36

потратил время, написал код под вашу задачу.

ТекстЗапроса = 
"ВЫБРАТЬ
| КОЛИЧЕСТВО(*) КАК КоличествоЗаписей
|ИЗ
| ЖурналДокументов.ЗаказыПокупателей КАК ЗаказыПокупателей
|{ГДЕ
| ЗаказыПокупателей.Ссылка.*,
| ЗаказыПокупателей.Дата,
| ЗаказыПокупателей.ПометкаУдаления,
| ЗаказыПокупателей.Номер,
| ЗаказыПокупателей.Проведен,
| ЗаказыПокупателей.ВидОперации.*,
| ЗаказыПокупателей.Сумма,
| ЗаказыПокупателей.Валюта.*,
| ЗаказыПокупателей.Информация.*,
| ЗаказыПокупателей.Организация.*,
| ЗаказыПокупателей.Подразделение.*,
| ЗаказыПокупателей.Ответственный.*,
| ЗаказыПокупателей.Комментарий,
| ЗаказыПокупателей.ДатаОплаты,
| ЗаказыПокупателей.ДатаОтгрузки,
| ЗаказыПокупателей.Тип}";

ПостроительОтчета = Новый ПостроительОтчета(ТекстЗапроса);

Для каждого ЭлементОтбора Из ЗаказыПокупателей.Отбор Цикл
Если ЭлементОтбора.Использование Тогда
ЭлементОтбораПостроителя = ПостроительОтчета.Отбор.Найти(ЭлементОтбора.Имя);
Если ЭлементОтбораПостроителя = Неопределено Тогда
Попытка
ЭлементОтбораПостроителя = ПостроительОтчета.Отбор.Добавить(ЭлементОтбора.Имя);
Исключение
Продолжить;
КонецПопытки;
КонецЕсли;
ЗаполнитьЗначенияСвойств(ЭлементОтбораПостроителя, ЭлементОтбора);
КонецЕсли;
КонецЦикла;

ПостроительОтчета.Выполнить();

Запрос = ПостроительОтчета.ПолучитьЗапрос();

Выборка = Запрос.Выполнить().Выбрать();
Выборка.Следующий();
Сообщить(Выборка.КоличествоЗаписей);

Последний раз редактировалось: mixqn; 27 Авг 2013, 15:36. Причина: Объединение сообщений

Оффлайн mikel10

  • ***
  • Сообщений: 108
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-01
  • Сайт: 
подскажите как программным способом например в форме списка журнала документов ЗаказыПокупателей получить значения Произвольного интервала С ...  По

Оффлайн mikel10

  • ***
  • Сообщений: 108
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-09-01
  • Сайт: 
Спасибо огромное , написал запрос. Все работает! :)


Теги:
 

Как создать нескольких документов "расчет при увольнении" на основании кадрового документа "увольнение" как Отпуска

Автор cozuРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3196
Последний ответ 21 Мар 2015, 20:24
от дфтын
Не работает структура подчиненности документов "Требование-накладная" и "Передач

Автор sv_stas_svРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4103
Последний ответ 10 Мар 2011, 07:36
от sv_stas_sv
готовая компонента сканирования/загрузки / распознавания бумажных документов (счетов, налоговых накладных, приходных накладных) из бумажного документа в 1с

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 182
Последний ответ 14 Ноя 2017, 10:43
от oleg-x
Реквизит "Ссылка" у справочников и документов

Автор leklerkРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3029
Последний ответ 29 Май 2013, 16:24
от leklerk
"Дубляж" документов реализации в ВзаиморасчетыКомпанииОстаткиИОбороты

Автор mspuzРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1790
Последний ответ 24 Янв 2014, 13:55
от mspuz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
50 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 117
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal