Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 23:23
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Присвоение значения табличной части документа  (Прочитано 3208 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн _max_

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-07
  • Сайт: 
  • Профессия: Ученик 1С
Добрый вечер помогите пож заполнить данными табличную часть документа. Есть документ ОтчетКомиссионераОПродажах, с табличной частью Товары, реквизитом табличной части Цена (Число) и  ЦенаПередачи (Число). Можно ли колонку ЦенаПередачи (Число) автоматически заполнить значением из колонки Цена (Число). А то вручную заполнять долго, много строк слишком.


Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
&НаКлиенте
Процедура ТоварыЦенаПриИзменении(Элемент)
Элементы.Товары.ТекущиеДанные.ЦенаПередачи = Элементы.Товары.ТекущиеДанные.Цена;
КонецПроцедуры

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
//Если УФ
Для каждого Стр Из Объект.Товары Цикл
   Стр.ЦенаПродажи = Стр.Цена;
КонецЦикла;

//Если Обычные формы
Для каждого Стр Из Товары Цикл
   Стр.ЦенаПродажи = Стр.Цена;
КонецЦикла;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн _max_

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-07
  • Сайт: 
  • Профессия: Ученик 1С
//Если УФ
Для каждого Стр Из Объект.Товары Цикл
   Стр.ЦенаПродажи = Стр.Цена;
КонецЦикла;

//Если Обычные формы
Для каждого Стр Из Товары Цикл
   Стр.ЦенаПродажи = Стр.Цена;
КонецЦикла;

Процедура Кнопка1Нажатие(Элемент,Стр)
Для каждого Стр Из Товары Цикл
   Стр.ЦенаПродажи = Стр.Цена;
КонецЦикла;   
КонецПроцедуры;
 
Выдает ошибку "Поле объекта не обнаружено(ЦенаПродажи)"
Добавлено: 27 Авг 2013, 08:51

Все с этим разобрался. Код ниже может кому пригодиться:
Процедура Кнопка1Нажатие(Элемент)
ДокВыборка = Документы.ОтчетКомиссионераОПродажах.Выбрать();
   Пока ДокВыборка.Следующий() Цикл
      ДокОбъект = ДокВыборка.ПолучитьОбъект();
   Для каждого СтрокиТабличнойЧасти из Товары  Цикл
      СтрокиТабличнойЧасти.ЦенаПередачи=СтрокиТабличнойЧасти.Цена;
КонецЦикла;
КонецЦикла;   
//ДокОбъект.Записать(?(ДокОбъект.Проведен, РежимЗаписиДокумента.Проведение, РежимЗаписиДокумента.Запись));
КонецПроцедуры

Последний раз редактировалось: _max_; 27 Авг 2013, 08:51. Причина: Объединение сообщений


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4481
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7751
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4787
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8534
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7345
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
51 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 209
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal