Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 10:05
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение графика работы сотрудников - 2 через 2  (Прочитано 4832 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dimon777

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте!
делаю обработку график сотрудников.  они сторожат два через два.
вот я на форме создал два поля заполнения сотрудников, т.е. где выбираются два сотрудника и период С и ПО какое число мне нужно заполнить. Ниже вывел регистр сведений как таблица, там у меня Дата и Сотрудник , т.е вывод когда кто работает.
проблема возникла в обработке заполнения, создал кнопку заполнить на форме и теперь мне надо прописать как заполнять, вот тут я и застрял... незнаю что дальше делать... как сделать так чтобы два через два было...  раньше никогда не делал просто график работы , подскажите пожалуйста.

Последний раз редактировалось: mixqn; 24 Авг 2013, 14:33


Оффлайн Dimon777

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С

Здравствуйте!
делаю обработку график сотрудников.  они сторожат два через два.
вот я на форме создал два поля заполнения сотрудников, т.е. где выбираются два сотрудника и период С и ПО какое число мне нужно заполнить. Ниже вывел регистр сведений как таблица, там у меня Дата и Сотрудник , т.е вывод когда кто работает.
проблема возникла в обработке заполнения, создал кнопку заполнить на форме и теперь мне надо прописать как заполнять, вот тут я и застрял... незнаю что дальше делать... как сделать так чтобы два через два было...  раньше никогда не делал просто график работы , подскажите пожалуйста.
вот что я написал
Процедура ЗаполнитьНажатие(Элемент)
Набор = РегистрыСведений.ГрафикиРаботы.СоздатьНаборЗаписей();
ЧислоСекундВСутках = 86400;
    Дат = ДатаНачала;
Сч = 1;
Пока Дат <= ДатаОкончания Цикл
 Запись = Набор.Добавить();
Запись.Дата = Дат;
 
 Если Сч <= 2 Тогда
 Запись.Дни = 24;
Иначе
Запись.Дни = 0;
 КонецЕсли;
 Сч = Сч + 1;
 Сч = ?(Сч = 5, 1, Сч);
Дат = Дат + ЧислоСекундВСутках;
КонецЦикла;
Набор.Записать();

но что то ничего не заполняет...

Оффлайн Besart

  • *****
  • Сообщений: 678
  • РЕПУТАЦИЯ: 142
  • КПД: 21%
  • Регистрация: 2012-12-10
    • Skype: artfa.a
  • Компания: Фрилансер
  • Профессия: Программист 8.1
посмотрите как сделана обработка заполнение графика в Каркасная конфигурация для сдачи экзамена "1С:Специалист" по платформе "1С:Предприятие 8" и доработайте ее

Оффлайн Dimon777

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-12
  • Сайт: 
  • Профессия: Ученик 1С
смотрел(( вот и не получается что-то....
Добавлено: 25 Авг 2013, 15:29

помогите пожалуйста( а то что-то совсем у меня ничего не выводит (
Добавлено: 25 Авг 2013, 17:04

вот код который я написал, но почему то обработка не заполняет, только создает пустое поле одно, видимо перебор не идет и не записывает данные... подскажите пожалуйста что не так ????

Процедура ЗаполнитьНажатие(ДатаНачала,ДатаОкончания)
Запрос = Новый Запрос();
Запрос.Текст =
"ВЫБРАТЬ
| ГрафикиРаботы.Дата,
| ГрафикиРаботы.Сотрудник
|ИЗ
| РегистрСведений.ГрафикиРаботы КАК ГрафикиРаботы";


Набор = РегистрыСведений.ГрафикиРаботы.СоздатьНаборЗаписей();

        Результат = Запрос.Выполнить();
ВыборкаДетальныеЗаписи = Результат.Выбрать();

ЧислоСекундВСутках = 86400;
Дат = ДатаНачала;
Сч = 1;

 СтруктураПоиска = Новый Структура("Дата");
 
 СтруктураПоиска.Вставить("Дата",Дат);
 
Если ВыборкаДетальныеЗаписи.НайтиСледующий(СтруктураПоиска) Тогда
НЗ = РегистрыСведений.ГрафикиРаботы.СоздатьНаборЗаписей();
НЗ.Отбор.Дата.Установить(Дат);
//НЗ.Отбор.ВидГрафикаРаботы.Установить(ВидГрафикаРаботы);
НЗ.Прочитать();
Для каждого ТекЗапись Из НЗ Цикл
   
  ТекЗапись.Значение = Сред(Сч,1);
   
КонецЦикла;
НЗ.Записать();
Иначе
МЗ = РегистрыСведений.ГрафикиРаботы.СоздатьМенеджерЗаписи();
//МЗ.ВидГрафикаРаботы = ВидГрафикаРаботы;
МЗ.Дата = Дат;
  МЗ.Записать();
КонецЕсли;
 

Сч = Сч + 1;
 
  КонецПроцедуры

Последний раз редактировалось: Dimon777; 25 Авг 2013, 17:04. Причина: Объединение сообщений


Теги:
 

Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 7611
Последний ответ 16 Авг 2012, 21:50
от Will
Как объединить объект в реквизите формы с типом "ДокументОбъект" и объект формы, созданной через "ПолучитьФорму()"?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 255
Последний ответ 06 Авг 2017, 21:22
от alex0402
Заполнение табличной части документа табличной частью из другого документа

Автор PeaceownerРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2546
Последний ответ 30 Ноя 2011, 07:10
от has
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15970
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4212
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
136 Сообщений
AIFrame
66 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 783
  • Точка Скрытых: 0
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal