Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 19:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнить Номенклатурные Группы  (Прочитано 3434 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн elwis91

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-23
  • Сайт: 
  • Профессия: Ученик 1С
Помогите написать процедуру инициализировать для этой процедуры. нужно чтобы получилась внешняя обработка:
 Процедура ЗаполнитьНоменклатурныеГруппы()
    ТаблицаСчетов = ОтражениеВУчете.Выгрузить();
   СтруктураОтбораНов = Новый Структура("СчетДт", планысчетов.Хозрасчетный.РезервыПредстоящихРасходов);
         СтруктураОтбораНов.Вставить("СчетКт", планысчетов.Хозрасчетный.РасчетыСПерсоналомПоОплатеТруда);
         СтруктураОтбораНов.Вставить("СчетКтНУ", планысчетов.Налоговый.РасчетыСПерсоналомПоОплатеТруда);
         ПодходящиеСтрокиНов = ТаблицаСчетов.НайтиСтроки(СтруктураОтбораНов);
         Если НЕ ПодходящиеСтрокиНов.Количество()=0 Тогда
            Для Каждого ОчереднаяСтрока Из ПодходящиеСтрокиНов Цикл
               ОчереднаяСтрока.СубконтоКт1 = NULL;
               ОчереднаяСтрока.СубконтоКтНУ1 = NULL;
            КонецЦикла;
         КонецЕсли;
   ТаблицаСчетов.Свернуть("СчетДт,СубконтоДт1,СубконтоДт2,СубконтоДт3,СчетКт,СубконтоКт1,СубконтоКт2,СубконтоКт3,СчетДтНУ,СубконтоДтНУ1,СубконтоДтНУ2,СубконтоДтНУ3,СчетКтНУ,СубконтоКтНУ1,СубконтоКтНУ2,СубконтоКтНУ3","СуммаНУ,Сумма");
   ОтражениеВУчете.Очистить();
   ОтражениеВУчете.Загрузить(ТаблицаСчетов);

   ТаблицаСчетов = ОтражениеВУчете.Выгрузить();
   таблицаСчетов.Свернуть("СчетДт,СубконтоДт1,СчетДтНУ,СубконтоДтНУ1");
   Для каждого ТекущаяСтрокаСчета Из ТаблицаСчетов Цикл
      
      Если ТекущаяСтрокаСчета.СчетДт <> ПланыСчетов.Хозрасчетный.ОсновноеПроизводствоНеОблагаемоеЕНВД И ТекущаяСтрокаСчета.СчетДтНУ <> ПланыСчетов.Налоговый.ПрямыеРасходыОсновногоПроизводства  Тогда
         Продолжить;
      Иначе
         
         ЗапросРаспределения = Новый Запрос();
         
         ЗапросРаспределения.Текст = "ВЫБРАТЬ
         |   СУММА(ВЫБОР КОГДА яяУправлениеЗаказамиТрудозатраты.СуммаИзм = 0 ТОГДА яяУправлениеЗаказамиТрудозатраты.Сумма ИНАЧЕ яяУправлениеЗаказамиТрудозатраты.СуммаИзм КОНЕЦ) КАК Сумма,
         |   яяУправлениеЗаказамиТрудозатраты.НоменклатурнаяГруппа
         |ИЗ
         |   РегистрСведений.яяУправлениеЗаказамиТрудозатраты КАК яяУправлениеЗаказамиТрудозатраты
         |ГДЕ
         |   яяУправлениеЗаказамиТрудозатраты.Период МЕЖДУ &ДатаНачала И &ДатаОкончания
         |   И яяУправлениеЗаказамиТрудозатраты.ГруппаПодразделенияИсполнителя В ИЕРАРХИИ (&Подразделение)
         |   И НЕ (яяУправлениеЗаказамиТрудозатраты.НеДляБухгалтерии)         
         |
         |СГРУППИРОВАТЬ ПО
         |   яяУправлениеЗаказамиТрудозатраты.НоменклатурнаяГруппа";
         ВыборкаПодр = РегистрыСведений.СоответствиеПодразделенийИПодразделенийОрганизаций.Выбрать(Новый Структура("ПодразделениеОрганизации",?(ТекущаяСтрокаСчета.СчетДт <> ПланыСчетов.Хозрасчетный.ОсновноеПроизводствоНеОблагаемоеЕНВД,ТекущаяСтрокаСчета.СубконтоДтНУ1,ТекущаяСтрокаСчета.СубконтоДт1)));
         //ыборкаПодр = РегистрыСведений.СоответствиеПодразделенийИПодразделенийОрганизаций.Выбрать(Новый Структура("ПодразделениеОрганизации",?(ТекущаяСтрокаСчета.СчетДт <> ПланыСчетов.Хозрасчетный.ОсновноеПроизводствоНеОблагаемоеЕНВД,ТекущаяСтрокаСчета.СубконтоДтН,ТекущаяСтрокаСчета.СубконтоДт1)));
         Если ВыборкаПодр.Следующий() Тогда
            ЗапросРаспределения.УстановитьПараметр("Подразделение",ВыборкаПодр.Подразделение);
         Иначе
            ОбщегоНазначения.Сообщение("Не найдено соответствующее подразделение упр учета для " + ТекущаяСтрокаСчета.СубконтоДт1);
            Продолжить;
         КонецЕсли;
         ЗапросРаспределения.УстановитьПараметр("ДатаНачала",НачалоМесяца(ПериодРегистрации));
         ЗапросРаспределения.УстановитьПараметр("ДатаОкончания",КонецМесяца(ПериодРегистрации));
         Распределение = ЗапросРаспределения.Выполнить().Выгрузить();
         КоличествоЗатрат = Распределение.Итог("Сумма");
         Если КоличествоЗатрат = 0 Тогда
            ОбщегоНазначения.Сообщение("Нет базы для распределения по " + ТекущаяСтрокаСчета.СубконтоДт1);
            Продолжить;
         КонецЕсли;
         
         
         СтруктураОтбора = Новый Структура();
         
         Если ТекущаяСтрокаСчета.СчетДт = ПланыСчетов.Хозрасчетный.ПустаяСсылка() Тогда
            СтруктураОтбора.Вставить("СчетДт", ПланыСчетов.Хозрасчетный.ПустаяСсылка());
            СтруктураОтбора.Вставить("СубконтоДт1", Неопределено);
            СтруктураОтбора.Вставить("СчетДтНУ",ТекущаяСтрокаСчета.СчетДтНУ);
            СтруктураОтбора.Вставить("СубконтоДтНУ1",ТекущаяСтрокаСчета.СубконтоДтНУ1);
            //СтруктураОтбора.Вставить("СубконтоДт2",Справочники.НоменклатурныеГруппы.ПустаяСсылка());
         Иначе
            СтруктураОтбора.Вставить("СчетДт",ТекущаяСтрокаСчета.СчетДт);
            СтруктураОтбора.Вставить("СубконтоДт1",ТекущаяСтрокаСчета.СубконтоДт1);
            СтруктураОтбора.Вставить("СчетДтНУ",ТекущаяСтрокаСчета.СчетДтНУ);
            СтруктураОтбора.Вставить("СубконтоДтНУ1",ТекущаяСтрокаСчета.СубконтоДтНУ1);
            //СтруктураОтбора.Вставить("СубконтоДт2",Справочники.НоменклатурныеГруппы.ПустаяСсылка());
         КонецЕсли;
         
         
         ТаблицаКДобавлению = ОтражениеВУчете.Выгрузить(Новый Массив);
         МассивСтрок = ОтражениеВУчете.НайтиСтроки(СтруктураОтбора);
         
         КоличествоНайденных = МассивСтрок.Количество();
         К=0;
         
         КоличествоДобавляемых = Распределение.Количество();
         
         
         Пока К<КоличествоНайденных Цикл
            
            Строка = МассивСтрок.Получить(К);
            
            СуммаПоСтроке = Строка.Сумма;
            СуммаКДобавлению =0;
            Н = 0;
            Пока Н < КоличествоДобавляемых Цикл
               ТекущееРаспределение  =  Распределение.Получить(Н) ;
               
               СтрокаКДобавлению =  ТаблицаКДобавлению.Добавить();
               ЗаполнитьЗначенияСвойств(СтрокаКДобавлению,Строка);
               Если ТекущаяСтрокаСчета.СчетДт = ПланыСчетов.Хозрасчетный.ОсновноеПроизводствоНеОблагаемоеЕНВД Тогда
                  
                  СтрокаКДобавлению.СубконтоДт2 = ТекущееРаспределение.НоменклатурнаяГруппа;
               КонецЕсли;
               Если ТекущаяСтрокаСчета.СчетДтНУ = ПланыСчетов.Налоговый.ПрямыеРасходыОсновногоПроизводства Тогда
                  СтрокаКДобавлению.СубконтоДтНУ2 = ТекущееРаспределение.НоменклатурнаяГруппа;
               КонецЕсли;
               
               
               
               Если  Н < КоличествоДобавляемых-1 Тогда
                  
                  
                  СтрокаКДобавлению.Сумма = Строка.Сумма*ТекущееРаспределение.Сумма/КоличествоЗатрат;
                  
                  СуммаКДобавлению = СуммаКДобавлению +СтрокаКДобавлению.Сумма;
               Иначе
                  СтрокаКДобавлению.Сумма = СуммаПоСтроке - СуммаКДобавлению;
                  
               КонецЕсли;
               
               
               Н = Н+1;
               
            КонецЦикла;   
            К = К+1;
         КонецЦикла;
         
         К1 = КоличествоНайденных-1;
         Пока К1 >= 0 Цикл
            
            
            ОтражениеВУчете.Удалить(МассивСтрок.Получить(К1));
            
            К1 = К1-1;
         КонецЦикла;
         СчетчикСтрок = 0;
         ///////////////////
         СтруктураОтбораНов = Новый Структура("СчетДт", планысчетов.Хозрасчетный.ОсновноеПроизводствоНеОблагаемоеЕНВД);
         СтруктураОтбораНов.Вставить("СчетКт", планысчетов.Хозрасчетный.РасчетыСПерсоналомПоОплатеТруда);
         ПодходящиеСтрокиНов = ТаблицаКДобавлению.НайтиСтроки(СтруктураОтбораНов);
         Если НЕ ПодходящиеСтрокиНов.Количество()=0 Тогда
            Для Каждого ОчереднаяСтрока Из ПодходящиеСтрокиНов Цикл
               ОчереднаяСтрока.СубконтоКт1 = NULL;
               ОчереднаяСтрока.СубконтоКтНУ1 = NULL;
            КонецЦикла;
         КонецЕсли;
         ТаблицаКДобавлению.Свернуть("СчетДт,СубконтоДт1,СубконтоДт2,СубконтоДт3,СчетКт,СубконтоКт1,СубконтоКт2,СубконтоКт3,СчетДтНУ,СубконтоДтНУ1,СубконтоДтНУ2,СубконтоДтНУ3,СчетКтНУ,СубконтоКтНУ1,СубконтоКтНУ2,СубконтоКтНУ3","СуммаНУ,Сумма");
         //   /////////////
         Если ТаблицаКДобавлению.Количество()>0 Тогда   
            НовыйДокОтражения = Документы.ОтражениеЗарплатыВРеглУчете.СоздатьДокумент();
            НовыйДокОтражения.Дата = Дата;
            НовыйДокОтражения.Организация = Организация;
            НовыйДокОтражения.ПериодРегистрации  =ПериодРегистрации;
            //НовыйДокОтражения.Комментарий = "20 счет " + ТекущаяСтрокаСчета.СубконтоДт1;
            Если ЗначениеЗаполнено(ТекущаяСтрокаСчета.СубконтоДт1) Тогда
               НовыйДокОтражения.Комментарий = "20 счет " + ТекущаяСтрокаСчета.СубконтоДт1;
            Иначе
               НовыйДокОтражения.Комментарий = "20 счет " + ТекущаяСтрокаСчета.СубконтоДтНУ1 + " НУ";
            КонецЕсли;   
            НовыйДокОтражения.Записать();
         КонецЕсли;
         //////////////////////////////////////
         Для Каждого СтрокаДобавление Из  ТаблицаКДобавлению Цикл
            СтрокаДобавлена = НовыйДокОтражения.ОтражениеВУчете.Добавить();
            ЗаполнитьЗначенияСвойств(СтрокаДобавлена,СтрокаДобавление);
            
            СчетчикСтрок = СчетчикСтрок + 1;
            Если СчетчикСтрок > 20000 Тогда
               СчетчикСтрок = 0;
               НовыйДокОтражения.Записать();
               НовыйДокОтражения = Документы.ОтражениеЗарплатыВРеглУчете.СоздатьДокумент();
               НовыйДокОтражения.Дата = Дата;
               НовыйДокОтражения.Организация = Организация;
               НовыйДокОтражения.ПериодРегистрации  =ПериодРегистрации;
               НовыйДокОтражения.Комментарий = "20 счет " + ТекущаяСтрокаСчета.СубконтоДт1;
               Если ЗначениеЗаполнено(ТекущаяСтрокаСчета.СубконтоДт1) Тогда
                  НовыйДокОтражения.Комментарий = "20 счет " + ТекущаяСтрокаСчета.СубконтоДт1;
               Иначе
                  НовыйДокОтражения.Комментарий = "20 счет " + ТекущаяСтрокаСчета.СубконтоДтНУ1 + " НУ";
               КонецЕсли;
               НовыйДокОтражения.Записать();
            КонецЕсли;
            
            
         КонецЦикла;   
         
         НовыйДокОтражения.Записать();
         
      КонецЕсли;
   КонецЦикла;   
   
КонецПроцедуры


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
вы бы лучше вместо выкладывания этого полотна кода нормально задачу описали.
я так и не понял, в чем конкретно проблема то?

Оффлайн elwis91

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-23
  • Сайт: 
  • Профессия: Ученик 1С
в документе отражения зарплаты в регл учете, на форме документа есть кнопка заполнить номенклатурные группы.мне нужно, чтобы я сделал эту кнопку как внешнюю обработку.

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
ну то есть вы хотите, чтобы кто-то вам готовый результат выдал или как?
не понимаю, конкретно что не получается?
Добавлено: 23 Авг 2013, 10:07

В целом последовательность действий может быть примерно такой:
1.   Создать новую внешнюю обработку, в ней поле ввода для указания документа, в процедуру - обработчик события «Нажатие» кнопки «Выполнить» (основное действие формы) вставить вызов нужной вам процедуры, добавив в нее параметр СсылкаНаДокумент, который будет передавать ссылку на документ.
2.   Текст процедуры полностью скопировать, внутри получить объект по ссылке и при обращении к реквизитам и табличным частям добавлять объект через точку.
3.   Если внутри процедуры вызываются другие процедуры модуля, их можно скопировать в обработку.
Возможно, я что-то забыл или упустил из виду.

А вообще, надо просто начать реализовывать вашу задумку и если будут конкретные вопросы – обращаться на форум.

Последний раз редактировалось: mixqn; 23 Авг 2013, 10:07. Причина: Объединение сообщений

Оффлайн elwis91

  • *
  • Сообщений: 7
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-23
  • Сайт: 
  • Профессия: Ученик 1С
спасибо большое.буду пробывать


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
48 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 348
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal