Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 01:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проводки в реализации  (Прочитано 4467 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lena.evdokimova

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-14
  • Сайт: 
  • Профессия: Программист 8.1
при обмене анных из торговли в бухгалтерию, реализация у нас по маслу (01829) выгружается по 41.04 счету проводки в дт/кт:
62.02 90.01.1
90.02.1 товар 41.04
теперь мы добавляем новую позицию сыр (02026) выгружаем реализацию по счету 41.04 но проводки в дт/кт встают:
 сначала на 004.01
62.02 90.01.1
76.05.1 76.05.2
76.05.2 91.01


Для каждого ТС из Товары Цикл
      Если (ТС.Номенклатура.ПринадлежитЭлементу(Справочники.Номенклатура.НайтиПоКоду("01829"))
         Или  ТС.Номенклатура.ПринадлежитЭлементу(Справочники.Номенклатура.НайтиПоКоду("02026"))) <> Истина Тогда
         //сообщить("1");
         ТС.СчетУчета = ПланыСчетов.Хозрасчетный.НайтиПоКоду("004.01");
      Иначе
         //сообщить("2");
         ТС.СчетУчета = ПланыСчетов.Хозрасчетный.НайтиПоКоду("41.04");
         ЭтотОбъект.СчетУчетаРасчетовСКонтрагентом = ПланыСчетов.Хозрасчетный.НайтиПоКоду("62.02");
      КонецЕсли;
      ТС.СчетДоходов = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.01.1");
      ТС.СчетУчетаНДСПоРеализации = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.03");
      ТС.СчетРасходов = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.02.1");
      ТС.Субконто = ТС.Номенклатура.НоменклатурнаяГруппа;
   КонецЦикла;


   
   Если ОбменДанными.Загрузка Тогда
      Возврат;
   КонецЕсли;

если я убираю счет 004.01
Для каждого ТС из Товары Цикл
      Если (ТС.Номенклатура.ПринадлежитЭлементу(Справочники.Номенклатура.НайтиПоКоду("01829"))
         Или  ТС.Номенклатура.ПринадлежитЭлементу(Справочники.Номенклатура.НайтиПоКоду("02026"))) <> Истина Тогда
      Иначе
         ТС.СчетУчета = ПланыСчетов.Хозрасчетный.НайтиПоКоду("41.04");
         ЭтотОбъект.СчетУчетаРасчетовСКонтрагентом = ПланыСчетов.Хозрасчетный.НайтиПоКоду("62.02");
      КонецЕсли;
      ТС.СчетДоходов = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.01.1");
      ТС.СчетУчетаНДСПоРеализации = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.03");
      ТС.СчетРасходов = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.02.1");
      ТС.Субконто = ТС.Номенклатура.НоменклатурнаяГруппа;
   КонецЦикла;


   
   Если ОбменДанными.Загрузка Тогда
      Возврат;
   КонецЕсли;
 То все равно ничего не меняется.
подскажите подалуйста как мне сделать чтобы сыр (02026) вставал по реализации а дт/кт:
62.02 90.01.1
90.02.1 41.01


Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
я же ВЧЕРА тебе ГОВОРИЛ: попробуй использовать конструкцию {
Если ... Тогда

ИначеЕсли ... Тогда

Иначе

КонецЕсли;
}
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн lena.evdokimova

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-14
  • Сайт: 
  • Профессия: Программист 8.1
я же ВЧЕРА тебе ГОВОРИЛ: попробуй использовать конструкцию {
Если ... Тогда

ИначеЕсли ... Тогда

Иначе

КонецЕсли;
}

Для каждого ТС из Товары Цикл
      Если (ТС.Номенклатура.ПринадлежитЭлементу(Справочники.Номенклатура.НайтиПоКоду("01829"))  <> Истина) Тогда
         
      Иначе
         //сообщить("2");
         ТС.СчетУчета = ПланыСчетов.Хозрасчетный.НайтиПоКоду("41.04");
         ЭтотОбъект.СчетУчетаРасчетовСКонтрагентом = ПланыСчетов.Хозрасчетный.НайтиПоКоду("62.02");
      КонецЕсли;
      ТС.СчетДоходов = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.01.1");
      ТС.СчетУчетаНДСПоРеализации = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.03");
      ТС.СчетРасходов = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.02.1");
      ТС.Субконто = ТС.Номенклатура.НоменклатурнаяГруппа;
   КонецЦикла;

       Если (ТС.Номенклатура <> Справочники.Номенклатура.НайтиПоКоду("02026"))<>истина Тогда

           ТС.СчетУчета = ПланыСчетов.Хозрасчетный.НайтиПоКоду("41.04");
         ЭтотОбъект.СчетУчетаРасчетовСКонтрагентом = ПланыСчетов.Хозрасчетный.НайтиПоКоду("62.02");

      иначе
       ТС.СчетУчета = ПланыСчетов.Хозрасчетный.НайтиПоКоду("41.04");
     ТС.СчетДоходов = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.01.1");
     ТС.СчетРасходов = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.02.1");
     КонецЕсли;
   
   Если ОбменДанными.Загрузка Тогда
      Возврат;
   КонецЕсли;
Вот, но все равно он ставит счета 76.05.1
Добавлено: 15 Авг 2013, 10:39

Как мне написать чтобы он счет
76.05.1 - 76.05.2
76.05.2 - 92.01

заменял только на
90.02.1 -41.04

Оффлайн Дринкинс

  • **
  • Сообщений: 55
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-27
  • Сайт: 
  • Профессия: Ученик 1С
 а что это у тебя за 76052 и 76051
Добавлено: 18 Авг 2013, 22:24

а вообще в реализации при типовой конфе 76 не применяется смотри сам объект. наверно чтото дописано


Теги:
 

УТ 10.3 Цена единицы товара в партии и цена списания этой единицы при реализации не совпадают????????????????????????

Автор i_antonРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 4871
Последний ответ 31 Янв 2014, 12:22
от i_anton
Пропали вкладки "Дополнительно" и "подписи" в Реализации товаров и услуг БП30

Автор andryscha92Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 2815
Последний ответ 22 Дек 2015, 14:31
от andryscha92
ошибка проведения реализации "При списании комиссионных товаров не определены параметры партии ""

Автор WelllaryРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 3731
Последний ответ 15 Апр 2015, 17:58
от Дмитрий@
Подбор товаров в реализации товаров и услуг

Автор apogey.tomskРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 431
Последний ответ 25 Май 2017, 06:06
от apogey.tomsk
"Дубляж" документов реализации в ВзаиморасчетыКомпанииОстаткиИОбороты

Автор mspuzРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1787
Последний ответ 24 Янв 2014, 13:55
от mspuz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 163
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal