Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2018, 10:31
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как внести проводку, новой позиции  (Прочитано 2031 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lena.evdokimova

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-14
  • Сайт: 
  • Профессия: Программист 8.1
Есть новая позиция (Сыр) как ее внести в проводку чтобы он падал на счет 41.01 а он автоматически падает на счет 004.01. Подскажите как мне внести проводку? Спасибо
Код у сыров (02026) Помогите пожалуйта нужно срочно!(


//*************08.06

    ЭтотОбъект.СпособЗачетаАвансов = Перечисления.СпособыЗачетаАвансов.НеЗачитывать;
    ЭтотОбъект.СчетУчетаРасчетовСКонтрагентом = ПланыСчетов.Хозрасчетный.НайтиПоКоду("62.01");
    ЭтотОбъект.Склад = Справочники.Склады.НайтиПоКоду("00001");
    ЭтотОбъект.Организация = Справочники.Организации.НайтиПоКоду("00003");
    Выборка = Справочники.ДоговорыКонтрагентов.Выбрать(, ЭтотОбъект.Контрагент.Ссылка);
    ЭтотОбъект.ВалютаДокумента = Справочники.Валюты.НайтиПоКоду("643");
    Пока Выборка.Следующий()=Истина Цикл
        Если Выборка.Организация<>Справочники.Организации.НайтиПоКоду("00003") Тогда
            Продолжить;
        КонецЕсли;
       
        Если выборка.ПометкаУдаления<>Истина Тогда
        ЭтотОбъект.ДоговорКонтрагента = Выборка.Ссылка;
        КонецЕсли;
    КонецЦикла;
   
    Для каждого ТС из Товары Цикл
        Если (ТС.Номенклатура.ПринадлежитЭлементу(Справочники.Номенклатура.НайтиПоКоду("01829")) <> Истина) Тогда
            ТС.СчетУчета = ПланыСчетов.Хозрасчетный.НайтиПоКоду("004.01");
        иначе
            ТС.СчетУчета = ПланыСчетов.Хозрасчетный.НайтиПоКоду("41.04");
        КонецЕсли;
        ТС.СчетДоходов = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.01.1");
        ТС.СчетУчетаНДСПоРеализации = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.03");
        ТС.СчетРасходов = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.02.1");
        ТС.Субконто = ТС.Номенклатура.НоменклатурнаяГруппа;
               
        если (тс.ЦенаПоступления>тс.цена) или (тс.ЦенаПоступления=0)  тогда
        //    тс.ЦенаПоступления=тс.Цена;   

    конецесли;
КонецЦикла;
    //*************08.06
 :dfbsdfbsdf: :dfbsdfbsdf: :dfbsdfbsdf: :dfbsdfbsdf: :dfbsdfbsdf:


Оффлайн wise

  • *****
  • Сообщений: 510
  • РЕПУТАЦИЯ: 65
  • КПД: 13%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
        Если (ТС.Номенклатура.ПринадлежитЭлементу(Справочники.Номенклатура.НайтиПоКоду("01829")) <> Истина) Тогда            ТС.СчетУчета = ПланыСчетов.Хозрасчетный.НайтиПоКоду("004.01");        иначе            ТС.СчетУчета = ПланыСчетов.Хозрасчетный.НайтиПоКоду("41.04");         КонецЕсли;

Код у сыров (02026)
вот и ПОЛУЧАЕТСЯ 004.01
попробуй { Сч41_01 = ПланыСчетов.Хозрасчетный.НайтиПоКоду("41.01");
            Сыры = Справочники.Номенклатура.НайтиПоКоду("01829");
        Если (ТС.Номенклатура.ПринадлежитЭлементу(Справочники.Номенклатура.НайтиПоКоду("01829")) <> Истина) Тогда
            ТС.СчетУчета = ПланыСчетов.Хозрасчетный.НайтиПоКоду("004.01");
        ИначеЕсли ТС.Номенклатура.ПринадлежитЭлементу(Сыры) Тогда
            ТС.СчетУчета = Сч41_01;
        Иначе
            ТС.СчетУчета = ПланыСчетов.Хозрасчетный.НайтиПоКоду("41.04");
        КонецЕсли;
}
ВДРУГ получится... ;-)
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн lena.evdokimova

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-14
  • Сайт: 
  • Профессия: Программист 8.1
Спасибо уже нашли решение вопроса):zebzdr:


Теги:
 

Часть четвертая: переход на «1С» версии «3.0». Где в программе находятся «Параметры учета»? Алгоритм настройки кадрового учета в новой версии программы «1С»

Автор 1cwikiРаздел Зарплата и управление персоналом

Ответов: 0
Просмотров: 4779
Последний ответ 20 Мар 2015, 12:58
от 1cwiki
Часть вторая: основные отличия старой версии «2.5» от новой «3.0». Какие новинки в «1С ЗУП» версии «3.0»?

Автор 1cwikiРаздел Зарплата и управление персоналом

Ответов: 0
Просмотров: 4669
Последний ответ 23 Мар 2015, 15:42
от 1cwiki
Внесение Классификации видов экономической деятельности в ЕГРЮЛ при открытии новой деятельности организации

Автор topicsРаздел Статьи

Ответов: 0
Просмотров: 1472
Последний ответ 20 Июн 2015, 00:09
от topics
Как отключить показатели производительности в новой конфигурации (поставке конфигурации) или программно?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 285
Последний ответ 05 Мар 2018, 07:16
от alexandr_ll
Компаниям с конца сентября нужно подавать сведения в Пенсионный фонд по новой форме СПВ-2

Автор newsРаздел Новости

Ответов: 0
Просмотров: 2012
Последний ответ 25 Сен 2014, 13:25
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
alex0402
69 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
59 Сообщений
wise wise
39 Сообщений
buketov.av buketov.av
39 Сообщений
KOI8-R
34 Сообщений
ilyay ilyay
29 Сообщений
Alter
28 Сообщений
trialex3
25 Сообщений

* Кто онлайн

  • Точка Гостей: 759
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal