Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 14:49
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как внести проводку, новой позиции  (Прочитано 1798 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн lena.evdokimova

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-14
  • Сайт: 
  • Профессия: Программист 8.1
Есть новая позиция (Сыр) как ее внести в проводку чтобы он падал на счет 41.01 а он автоматически падает на счет 004.01. Подскажите как мне внести проводку? Спасибо
Код у сыров (02026) Помогите пожалуйта нужно срочно!(


//*************08.06

    ЭтотОбъект.СпособЗачетаАвансов = Перечисления.СпособыЗачетаАвансов.НеЗачитывать;
    ЭтотОбъект.СчетУчетаРасчетовСКонтрагентом = ПланыСчетов.Хозрасчетный.НайтиПоКоду("62.01");
    ЭтотОбъект.Склад = Справочники.Склады.НайтиПоКоду("00001");
    ЭтотОбъект.Организация = Справочники.Организации.НайтиПоКоду("00003");
    Выборка = Справочники.ДоговорыКонтрагентов.Выбрать(, ЭтотОбъект.Контрагент.Ссылка);
    ЭтотОбъект.ВалютаДокумента = Справочники.Валюты.НайтиПоКоду("643");
    Пока Выборка.Следующий()=Истина Цикл
        Если Выборка.Организация<>Справочники.Организации.НайтиПоКоду("00003") Тогда
            Продолжить;
        КонецЕсли;
       
        Если выборка.ПометкаУдаления<>Истина Тогда
        ЭтотОбъект.ДоговорКонтрагента = Выборка.Ссылка;
        КонецЕсли;
    КонецЦикла;
   
    Для каждого ТС из Товары Цикл
        Если (ТС.Номенклатура.ПринадлежитЭлементу(Справочники.Номенклатура.НайтиПоКоду("01829")) <> Истина) Тогда
            ТС.СчетУчета = ПланыСчетов.Хозрасчетный.НайтиПоКоду("004.01");
        иначе
            ТС.СчетУчета = ПланыСчетов.Хозрасчетный.НайтиПоКоду("41.04");
        КонецЕсли;
        ТС.СчетДоходов = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.01.1");
        ТС.СчетУчетаНДСПоРеализации = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.03");
        ТС.СчетРасходов = ПланыСчетов.Хозрасчетный.НайтиПоКоду("90.02.1");
        ТС.Субконто = ТС.Номенклатура.НоменклатурнаяГруппа;
               
        если (тс.ЦенаПоступления>тс.цена) или (тс.ЦенаПоступления=0)  тогда
        //    тс.ЦенаПоступления=тс.Цена;   

    конецесли;
КонецЦикла;
    //*************08.06
 :dfbsdfbsdf: :dfbsdfbsdf: :dfbsdfbsdf: :dfbsdfbsdf: :dfbsdfbsdf:


Оффлайн wise

  • ****
  • Сообщений: 428
  • РЕПУТАЦИЯ: 58
  • КПД: 14%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
        Если (ТС.Номенклатура.ПринадлежитЭлементу(Справочники.Номенклатура.НайтиПоКоду("01829")) <> Истина) Тогда            ТС.СчетУчета = ПланыСчетов.Хозрасчетный.НайтиПоКоду("004.01");        иначе            ТС.СчетУчета = ПланыСчетов.Хозрасчетный.НайтиПоКоду("41.04");         КонецЕсли;

Код у сыров (02026)
вот и ПОЛУЧАЕТСЯ 004.01
попробуй { Сч41_01 = ПланыСчетов.Хозрасчетный.НайтиПоКоду("41.01");
            Сыры = Справочники.Номенклатура.НайтиПоКоду("01829");
        Если (ТС.Номенклатура.ПринадлежитЭлементу(Справочники.Номенклатура.НайтиПоКоду("01829")) <> Истина) Тогда
            ТС.СчетУчета = ПланыСчетов.Хозрасчетный.НайтиПоКоду("004.01");
        ИначеЕсли ТС.Номенклатура.ПринадлежитЭлементу(Сыры) Тогда
            ТС.СчетУчета = Сч41_01;
        Иначе
            ТС.СчетУчета = ПланыСчетов.Хозрасчетный.НайтиПоКоду("41.04");
        КонецЕсли;
}
ВДРУГ получится... ;-)
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Оффлайн lena.evdokimova

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-06-14
  • Сайт: 
  • Профессия: Программист 8.1
Спасибо уже нашли решение вопроса):zebzdr:


Теги:
 

Часть четвертая: переход на «1С» версии «3.0». Где в программе находятся «Параметры учета»? Алгоритм настройки кадрового учета в новой версии программы «1С»

Автор 1cwikiРаздел Зарплата и управление персоналом

Ответов: 0
Просмотров: 3990
Последний ответ 20 Мар 2015, 12:58
от 1cwiki
Часть вторая: основные отличия старой версии «2.5» от новой «3.0». Какие новинки в «1С ЗУП» версии «3.0»?

Автор 1cwikiРаздел Зарплата и управление персоналом

Ответов: 0
Просмотров: 4153
Последний ответ 23 Мар 2015, 15:42
от 1cwiki
Внесение Классификации видов экономической деятельности в ЕГРЮЛ при открытии новой деятельности организации

Автор topicsРаздел Статьи

Ответов: 0
Просмотров: 1292
Последний ответ 20 Июн 2015, 00:09
от topics
Компаниям с конца сентября нужно подавать сведения в Пенсионный фонд по новой форме СПВ-2

Автор newsРаздел Новости

Ответов: 0
Просмотров: 1855
Последний ответ 25 Сен 2014, 13:25
от news
Отказ налоговиков в регистрации новой компании или ИП можно обжаловать в УФНС и в суде

Автор newsРаздел Новости

Ответов: 0
Просмотров: 587
Последний ответ 16 Май 2014, 12:03
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
58 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 269
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal