Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Дек 2017, 01:30
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Модуль документа  (Прочитано 3086 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.уатЗаказГрузоотправителя") тогда
СтандартнаяОбработка = Ложь;
ВидОперации = Перечисления.уатВидыОперацийМаршрутныйЛист.ПоЗаказуГрузоотправителя;
Организация = ДанныеЗаполнения.Организация;
ДатаИВремяВыполнения = ДанныеЗаполнения.КрайнийСрокОтработки;
Если Ложь тогда
ДанныеЗаполнения = Документы.уатЗаказГрузоотправителя.СоздатьДокумент();
КонецЕсли;
Для Каждого ТекСтрока ИЗ ДанныеЗаполнения.Товары Цикл
НовСтрока = Заказы.Добавить();
НовСтрока.ЗаказГрузоотправителя       = ДанныеЗаполнения;
НовСтрока.Пункт                       = ДанныеЗаполнения.АдресОтправления1;
НовСтрока.ТипТочкиМаршрута            = Перечисления.уатТипыТочекМаршрута.Погрузка;
НовСтрока.Номенклатура                = ТекСтрока.Номенклатура;
НовСтрока.ЕдиницаИзмерения            = ТекСтрока.ЕдиницаИзмерения;
НовСтрока.Количество                  = ТекСтрока.Количество;
НовСтрока.ЕдиницаИзмеренияПоЗаказу    = ТекСтрока.ЕдиницаИзмерения;
НовСтрока.КоличествоМест              = ТекСтрока.КоличествоМест;
НовСтрока.ПараметрВыработки           = ТекСтрока.ПараметрВыработки;
НовСтрока.КоличествоПараметрВыработки = ТекСтрока.КоличествоПараметрВыработки;
НовСтрока.ВесБрутто                   = ТекСтрока.ВесБрутто;
НовСтрока.Объем                       = ТекСтрока.Объем;
НовСтрока.Стоянка   = ДанныеЗаполнения.СтоянкаПунктОтправления;
Вот кусок модуля программа ругается на то что АдресОтправления1 не обнаруженно,это реквизит табл части документа уатЗаказГрузоотправителя .Подскажит что неправельно делаю?

Последний раз редактировалось: MuI_I_Ika; 12 Авг 2013, 16:35


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Re: Модуль документа
« Ответ #1: 12 Авг 2013, 16:37 »
Судя по коду у вас АдресОтправления1 это реквизит документа уатЗаказГрузоотправителя.

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Re: Модуль документа
« Ответ #2: 12 Авг 2013, 16:40 »
Судя по коду у вас АдресОтправления1 это реквизит документа уатЗаказГрузоотправителя.
Ну вообщето да,я незнаю как записпть чтоб это был реквизит табл части
пишу так тоже не работает
ДанныеЗаполнения.СтрТаблЧасти.АдресНазначения1

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Re: Модуль документа
« Ответ #3: 12 Авг 2013, 17:23 »
Вот у вас ТекСтрока - это строка табличной части. А то что вы пишете никак не будет строкой. Программе нужно указать какую строку вы хотите получить. Их же в табличной части много, а может и не быть совсем.

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Re: Модуль документа
« Ответ #4: 12 Авг 2013, 17:29 »
Вот у вас ТекСтрока - это строка табличной части. А то что вы пишете никак не будет строкой. Программе нужно указать какую строку вы хотите получить. Их же в табличной части много, а может и не быть совсем.
А как указать

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Re: Модуль документа
« Ответ #5: 12 Авг 2013, 17:35 »
А какая строка нужна? И какой табличной части?

Оффлайн Андрей Федотов

  • ***
  • Сообщений: 212
  • РЕПУТАЦИЯ: 36
  • КПД: 17%
  • Регистрация: 2011-07-07
  • Компания: Future IT Solutions
  • Профессия: Разработчик 1С
Re: Модуль документа
« Ответ #6: 12 Авг 2013, 22:40 »
Вариантов несколько.

Или Таблица[ИндексСтроки].АдресНазначения1
Или Для каждого СтрокаТаблицы Из Таблица Цикл СтрокаТаблицы.АдресНазначения1 ...
Или ТекущаяСтрока = ЭлементыФормы.Таблица.ТекущаяСтрока; ТекущаяСтрока.АдресНазначения1
С уважением,
Андрей Федотов
Future IT Solutions

Оффлайн markgenuine

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 18
  • КПД: 8%
  • Регистрация: 2012-11-17
  • Сайт: 
Re: Модуль документа
« Ответ #7: 12 Авг 2013, 22:49 »
ХЕх..тоже уат мучаете=))))
я на днях обмен прикручивал=)

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Re: Модуль документа
« Ответ #8: 13 Авг 2013, 08:44 »
ХЕх..тоже уат мучаете=))))
я на днях обмен прикручивал=)
Да вот тоже щас скоро буду прикручивать,табель
Добавлено: 13 Авг 2013, 09:55

Возвращаюсь к вчерашнему вопросу.Вот что у меня получилось
 Процедура ОбработкаЗаполнения(Основание)

Если ТипЗнч(Основание) = Тип("ДокументСсылка.уатЗаказГрузоотправителя") Тогда
   
      ДокументОснование = Основание.Ссылка;
      ДатаИВремяВыполнения = Основание.КрайнийСрокОтработки;
      Дата =  Основание.Дата;

            Для каждого СтрТаблЧасти ИЗ Основание.Маршруты Цикл
            Если   ЗначениеЗаполнено(СтрТаблЧасти.АдресНазначения1) тогда
                  
            НоваяСтрока= Заказы.Добавить();   
            НоваяСтрока.Пункт = СтрТаблЧасти.АдресНазначения1;
                КонецЕсли;
            КонецЦикла;
            КонецЕсли;
 КонецПроцедуры
НО.Почему при нажатии на кнопу пункт заполняется табличная часть а не сразу.Кнопка пункт это реквизит документа.В процедуре Добавить кнопку нету,такого.
Процедура КоманднаяПанельПоЗаказамДобавитьПункт(Кнопка)
   
   Если пДерево = 1 тогда
      НовСтрокаДерево = ЗаказыДерево.Строки.Добавить();
      НовСтрокаДерево.ПунктЗаказНоменклатура = "";
      ЭлементыФормы.ЗаказыДерево.ТекущаяСтрока  = НовСтрокаДерево;
      ЭлементыФормы.ЗаказыДерево.ТекущаяКолонка = ЭлементыФормы.ЗаказыДерево.Колонки.ПунктЗаказНоменклатура;
      ЭлементыФормы.ЗаказыДерево.ИзменитьСтроку();
   Иначе
      НовСтрока = Заказы.Добавить();
      НовСтрока.Пункт = "";
      ПараметрыМаршрута.Добавить();
      ЭлементыФормы.ЗаказыСписок.ТекущаяСтрока = НовСтрока;
      ЭлементыФормы.ЗаказыДерево.ТекущаяКолонка = ЭлементыФормы.ЗаказыСписок.Колонки.Пункт;
      ЭлементыФормы.ЗаказыСписок.ИзменитьСтроку();
   КонецЕсли;
   
КонецПроцедуры


Последний раз редактировалось: gliokker; 13 Авг 2013, 09:55. Причина: Объединение сообщений


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4491
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15972
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4215
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 651
Последний ответ 10 Май 2017, 20:44
от ilnur75
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7764
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
AIFrame
73 Сообщений
alex0402
52 Сообщений
ilyay ilyay
51 Сообщений
andron81_81
44 Сообщений
oleg-x
35 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 219
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal