Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 12:01
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите с расшифровкой области ячеек табличного документа  (Прочитано 4897 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн mindruk

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-08
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день.
Подскажите пожалуйста как попасть в процедуру расшифровки.
ТабДок находится на форме, после заполнения необходимо добавить расшифровку в одну ячейку.
Пишу следующим образом :
//начало пропущу
        ОбластьРасшифровкиДоговоров = ТабДок.Область("R"+5+"C"+ 6);   
   ОбластьРасшифровкиДоговоров.Расшифровка = "Расшифровать ЛицевыеСчетаБезДоговоров";
   ОбластьРасшифровкиДоговоров.ПараметрРасшифровки = ДатаОтчета;
   
КонецПроцедуры

&НаКлиенте
   процедура  ТабДокОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
      Рас = 1+1;// Попасть нужно, как я понимаю, сюда!
   КонецПроцедуры


В свойствах "Поля" указал ОбработкуРасшифроки и могу на нее попасть
но когда становлюсь на ячейку расшифровки нет

Подскажите как правильно обратиться к расшифровке
 


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Каким образом вы присваиваете значение расшифровки?

Оффлайн mindruk

  • *
  • Сообщений: 6
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-08
  • Сайт: 
  • Профессия: Ученик 1С
Я не могу понять немного... какие шаги мне следует выполнить.
Можете просто в теории сказать?
Как я понимаю - 1. Определитель область для расшифровки.
2. Задать параметр который будет передаваться в расшифровку
3. обеспечить вызов обработки расшифровки.

Как обеспечивается вызов обработкиРасшифровки???
Добавлено: 09 Авг 2013, 15:47

Спасибо за оказанную помощь.
Необходимо было сделать как-то так
\\ последний кусок
   ОбластьРасшифровкиДоговоров = ТабДок.Область("R"+5+"C"+ 6);   
   Элемент = ОбластьРасшифровкиДоговоров;   
   ОбластьРасшифровкиДоговоров.Расшифровка = "Расшифровать ЛицевыеСчетаБезДоговоров";
   Расшифровка = ОбластьРасшифровкиДоговоров.Расшифровка;
   ОбластьРасшифровкиДоговоров.ПараметрРасшифровки = ДатаОтчета;
   
   
КонецПроцедуры

&НаКлиенте
   процедура  ТабДокОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка)
   СтандартнаяОбработка = ложь;
   Рас = 1+1;
   КонецПроцедуры

Последний раз редактировалось: mindruk; 09 Авг 2013, 15:47. Причина: Объединение сообщений


 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4295
Последний ответ 24 Дек 2015, 15:34
от дфтын
Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4480
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 15943
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4201
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 638
Последний ответ 10 Май 2017, 20:44
от ilnur75

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 269
  • Точка Скрытых: 1
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal