Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 22:10
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Создание иерархии в Диаграмме Ганта  (Прочитано 3399 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Zuull

  • *
  • Сообщений: 11
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-08
  • Сайт: 
  • Профессия: Ученик 1С
Добрый День, Уважаемые Программисты!

Я новичок в программировании (1С:Предприятие 8.2, учебная версия (8.2.13.219)), поэтому возникли сложности.
Результат работы нижеприведенного кода: Во вложении.

Вопрос: В Диаграмме Ганта (Во вложении) все отображается линейно, а нужно в иерархическом виде: т.е в "Обычные номера" обычные номера, а в "Номера люкс" номера люкс. Как привязаться к Родительской точке??? Что неправильного в написанном коде??? Подскажите пожалуйста :(, заранее Спасибо!
 
&НаКлиенте
Процедура Сформировать(Команда)

СформироватьНаСервере(ДиаграммаГанта);

КонецПроцедуры

&НаСервереБезКонтекста
Процедура СформироватьНаСервере(Диаграмма)


Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ДляДиаграммыГантаФактическийПериодДействия.НомерВГостинице,
| ДляДиаграммыГантаФактическийПериодДействия.НомерВГостинице.ВидНомера,
| ДляДиаграммыГантаФактическийПериодДействия.ВидРасчета,
| ДляДиаграммыГантаФактическийПериодДействия.ПериодДействияНачало,
| ДляДиаграммыГантаФактическийПериодДействия.ПериодДействияКонец,
| ДляДиаграммыГантаФактическийПериодДействия.Регистратор,
| ДляДиаграммыГантаФактическийПериодДействия.Статус,
| ДляДиаграммыГантаФактическийПериодДействия.Постоялец
|ИЗ
| РегистрРасчета.ДляДиаграммыГанта.ФактическийПериодДействия КАК ДляДиаграммыГантаФактическийПериодДействия";


Результат = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = Результат.Выбрать();

Диаграмма.Очистить();
Диаграмма.Обновление = Ложь;

///////////////////////////////////////////////////////////

ТочкаРодитель = Диаграмма.УстановитьТочку("Обычные номера");
ТочкаРодитель1 = Диаграмма.УстановитьТочку("Люкс номера");

СерияРодитель = Диаграмма.УстановитьСерию("График работы обычных номеров");
СерияРодитель.Цвет = WebЦвета.Синий;

СерияРодитель1 = Диаграмма.УстановитьСерию("График работы номеров люкс");
СерияРодитель1.Цвет = WebЦвета.ВесеннеЗеленый;

ТекущееЗначениеРодитель = Диаграмма.ПолучитьЗначение(ТочкаРодитель,СерияРодитель);
ТекущееЗначениеРодитель1 = Диаграмма.ПолучитьЗначение(ТочкаРодитель1,СерияРодитель1);

///////////////////////////////////////////////////////////

ТекущийИнтервал = ТекущееЗначениеРодитель.Добавить();
ТекущийИнтервал.Начало = НачалоМесяца(ТекущаяДата());
ТекущийИнтервал.Конец = КонецМесяца(ТекущаяДата());


ТекущийИнтервал1 = ТекущееЗначениеРодитель1.Добавить();
ТекущийИнтервал1.Начало = НачалоМесяца(ТекущаяДата());
ТекущийИнтервал1.Конец = КонецМесяца(ТекущаяДата());

//////////////////////////////////////////////////////////

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл

Если ВыборкаДетальныеЗаписи.НомерВГостинице.ВидНомера = Перечисления.ВидНомера.Обычный Тогда

ТекущаяТочка = Диаграмма.УстановитьТочку(ВыборкаДетальныеЗаписи.НомерВГостинице,ТекущееЗначениеРодитель);
ТекущаяСерия = Диаграмма.УстановитьСерию(ВыборкаДетальныеЗаписи.ВидРасчета);

ТекущееЗначение = Диаграмма.ПолучитьЗначение(ТекущаяТочка,ТекущаяСерия);


ТекущийИнтервал2 = ТекущееЗначение.Добавить();
ТекущийИнтервал2.Начало = ВыборкаДетальныеЗаписи.ПериодДействияНачало;
ТекущийИнтервал2.Конец = ВыборкаДетальныеЗаписи.ПериодДействияКонец;
ТекущийИнтервал2.Текст = ВыборкаДетальныеЗаписи.Постоялец;
ТекущийИнтервал2.Расшифровка = ВыборкаДетальныеЗаписи.Регистратор;

Иначе

ТекущаяТочка1 = Диаграмма.УстановитьТочку(ВыборкаДетальныеЗаписи.НомерВГостинице,ТекущееЗначениеРодитель1);
ТекущаяСерия1 = Диаграмма.УстановитьСерию(ВыборкаДетальныеЗаписи.ВидРасчета);
ТекущееЗначение1 = Диаграмма.ПолучитьЗначение(ТекущаяТочка1,ТекущаяСерия1);


ТекущийИнтервал3 = ТекущееЗначение1.Добавить();
ТекущийИнтервал3.Начало = ВыборкаДетальныеЗаписи.ПериодДействияНачало;
ТекущийИнтервал3.Конец = ВыборкаДетальныеЗаписи.ПериодДействияКонец;
ТекущийИнтервал3.Текст = ВыборкаДетальныеЗаписи.Постоялец;
ТекущийИнтервал3.Расшифровка = ВыборкаДетальныеЗаписи.Регистратор;

КонецЕсли;

КонецЦикла;

Диаграмма.Обновление = Истина;


КонецПроцедуры


Теги:
 

Программное создание документа на основании документа

Автор GolickoffРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4478
Последний ответ 23 Апр 2015, 08:45
от Golickoff
Автоматическое создание " Заполнение" документа

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4443
Последний ответ 06 Мар 2014, 14:48
от mashencev_anton
Создание отчета "Отсутствие заказов"

Автор dronspartak9@gmail.comРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3874
Последний ответ 16 Апр 2014, 15:09
от dronspartak9@gmail.com
Создание заказаов на производство на основании заказа на производство.

Автор Елена1986Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 20
Просмотров: 7841
Последний ответ 09 Сен 2015, 13:01
от Елена1986
Создание плана закупок с использованием плана продаж

Автор NataVlРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 1186
Последний ответ 26 Сен 2016, 16:25
от NataVl

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
50 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 332
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal