Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 14:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Дата на англоязычном языке  (Прочитано 3094 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн _max_

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-07
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день уважаемые! Я только учусь программировать 1с 7.7. У меня такой вопрос как можно преобразовать дату в таблице в формате апрель 2013г на april 2013г. Подскажите пожайлуста, желательно с пояснениями...


Оффлайн dimalf

  • **
  • Сообщений: 62
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-01-13
  • Сайт: 
  • Профессия: Программист 1С
Добрый день!

1. Конфигуратор. Сервис - Параметры. Закладка Синтаксис-Помощник. Поставьте галочку "Использовать оба языка".

2. Попробуйте программно. Если Месяц = "апрель" Тогда
                        Месяц = "april";
                       КонецЕсли;

Оффлайн _max_

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-07
  • Сайт: 
  • Профессия: Ученик 1С
Функция АнглДата(Дат)
Мес=ДатаМесяц(Дат);
Англ="";
Если Мес=1 Тогда
Англ="January"
ИначеЕсли Мес=2 Тогда
Англ="February"
ИначеЕсли Мес=3 Тогда
   Анг =" March" ;
ИначеЕсли Мес=4 Тогда
   Анг =" April" ;
ИначеЕсли Мес=5 Тогда
   Анг =" May" ;
ИначеЕсли Мес=6 Тогда
   Анг =" June" ;
ИначеЕсли Мес=7 Тогда
   Анг =" July" ;   
ИначеЕсли Мес=8 Тогда
   Анг =" August" ;
ИначеЕсли Мес=9 Тогда
   Анг =" September" ;
ИначеЕсли Мес=10 Тогда
   Анг =" October" ;   
ИначеЕсли Мес=11 Тогда
   Анг =" November" ;   
ИначеЕсли Мес=12 Тогда
   Анг =" December" ;      
КонецЕсли;
Возврат (Англ+" "+ДатаГод(Дат));
КонецФункции
Типо того получается, а как теперь добавить в таблицу чтобы там там дата выводилась?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
ДатаАнгл = Формат(Дат,"Л=en; ДЛФ=DD");

Добавлено: 08 Авг 2013, 00:05

Правой кнопкой мыши - конструктор форматной строки!
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн _max_

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-07
  • Сайт: 
  • Профессия: Ученик 1С
ДатаАнгл = Формат(Дат,"Л=en; ДЛФ=DD");

Добавлено: 08 Авг 2013, 00:05

Правой кнопкой мыши - конструктор форматной строки!

Я так понимаю это доступно только в 1С 8, а у меня 1С 7.7

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Я так понимаю это доступно только в 1С 8, а у меня 1С 7.7
тогда почему тема в разделе "Конфигурирование, программирование в "1С - Предприятие 8""?
переношу...

Оффлайн _max_

  • *
  • Сообщений: 33
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-07
  • Сайт: 
  • Профессия: Ученик 1С
Что нету не у кого вариантов? А Пропись(КаталогИБ() + "Months.spl"); такой метод кто может объяснить! Как его задействовать правильно...
Months.spl:
{"Speller",
{"Money",
{"Рубль","Рубля","Рублей","Копейка","Копейки","Копеек","M"}},
{"Numbers",
{"Один","Два","Три","Четыре","Пять","Шесть","Семь","Восемь","Девять","Одна","Две",
"Десять","Одиннадцать","Двенадцать","Тринадцать","Четырнадцать","Пятнадцать","Шестнадцать","Семнадцать","Восемнадцать","Девятнадцать",
"Двадцать","Тридцать","Сорок","Пятьдесят","Шестьдесят","Семьдесят","Восемьдесят","Девяносто",
"Сто","Двести","Триста","Четыреста","Пятьсот","Шестьсот","Семьсот","Восемьсот","Девятьсот",
"Тысяча","Тысячи","Тысяч",
"Миллион","Миллиона","Миллионов",
"Миллиард","Миллиарда","Миллиардов",
"Триллион","Триллиона","Триллионов",
"Ноль"}},
{"Date",
{"January","February","March","April","May","June","July","August","September","October","November","December",
"Января","Февраля","Марта","Апреля","Мая","Июня","Июля","Августа","Сентября","Октября","Ноября","Декабря",
"г.","Квартал"}},
{"DateRange",
{"Полугодие","Месяцев"}},
{"WeekDay",
{"Понедельник","Вторник","Среда","Четверг","Пятница","Суббота","Воскресенье"}}
}
-----------------------------------------------------------------------------------------


Добавлено: 08 Авг 2013, 09:43

Вроде разобрался

Пропись("Months.spl");
Таб.ДобавитьСекцию("Дата");
Пропись("");

Правда может и коряво но зато работает!

Последний раз редактировалось: _max_; 08 Авг 2013, 09:43. Причина: Объединение сообщений


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
47 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 274
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal