Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2018, 05:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Расчёт ГСМ по норме  (Прочитано 2366 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Может вопрос покажется простым но подскажите вот кусок модуля
Для Каждого ТекСтрока Из РасходГСМ Цикл
Если ТекСтрока.Активен Тогда
#Если Клиент Тогда
ТекСтрока.РасходПоНорме = уатЗащищенныеФункции.РасчитатьРасходГСМПоНорме(ЭтотОбъект, ТекСтрока.ТС, ТекСтрока.ГСМ, Организация,Отказ,,Ложь);

ТекСтрока.РасходПоНорме = РасчётГСМПоНорме.РасчитатьРасходГСМПоНорме(ЭтотОбъект );

#КонецЕсли

Если Отказ Тогда
Возврат;
КонецЕсли;
Если Перечисления.уатВидыПЛ._4С Тогда
ТекСтрока.РасходПоНорме = РасчётГСМПоНорме.РасчитатьРасходГСМПоНорме(ЭтотОбъект );
Если Отказ Тогда
ТекСтрока.РасходПоНорме = уатЗащищенныеФункции.РасчитатьРасходГСМПоНорме(ЭтотОбъект, ТекСтрока.ТС, ТекСтрока.ГСМ, Организация,Отказ,,Ложь);
КонецЕсли;

Мне нужно чтоб когда выбирается определённый вид ПЛ (в нашем случае ._4С) должна выполнятся процедура
РасчётГСМПоНорме.РасчитатьРасходГСМПоНорме (эта моя самодельная процедура которая находится в общих модулях)

Последний раз редактировалось: MuI_I_Ika; 05 Авг 2013, 13:42


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6642
  • РЕПУТАЦИЯ: 783
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Один КонецЕсли забыли.

Ну собственно в коде прописан вызов процедуры. В чем проблема то? Приведите ошибку.

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Один КонецЕсли забыли.

Ну собственно в коде прописан вызов процедуры. В чем проблема то? Приведите ошибку.
проблема была в том то процедура вызывалась 2 раза ,сам понял свою ошибку спасибо что откликнулись.


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4677
Последний ответ 24 Дек 2015, 15:34
от дфтын
Как создать нескольких документов "расчет при увольнении" на основании кадрового документа "увольнение" как Отпуска

Автор cozuРаздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 3690
Последний ответ 21 Мар 2015, 20:24
от дфтын
1с82 ЗУП: Расчет по среднему:надбавка учитывается и не учитывается

Автор PushastРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4113
Последний ответ 05 Окт 2011, 11:13
от Pushast
Отчет о НЕ уволенных сотрудниках и расчет начислений, как для уволенных

Автор medoedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3952
Последний ответ 02 Фев 2012, 14:49
от medoed
Расчет процента автоматической скидки и скидки наценки

Автор Max99990Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 4928
Последний ответ 31 Янв 2016, 02:33
от дфтын

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
oleg-x
68 Сообщений
alex0402
64 Сообщений
AIFrame AIFrame
59 Сообщений
wise wise
39 Сообщений
buketov.av buketov.av
36 Сообщений
KOI8-R
34 Сообщений
ilyay ilyay
29 Сообщений
Alter
28 Сообщений
trialex3
25 Сообщений

* Кто онлайн

  • Точка Гостей: 207
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal