Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 09:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Переписать код с 1С 7.7 в 1С 8.2  (Прочитано 4110 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Mor_6

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-03
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте!
Я новичок в 1С и столкнулся с такой проблемой: не могу перевести коды из 1С 7.7 в 1С 8.2, так как пока не знаю языка и каких-либо команд.
Подскажите, как эта строка ---> Код=Строка(Ед); , написанная в 1С 7.7 должна выглядеть в 1С 8.2 ?
Буду благодарен откликнувшимся на вопрос.


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
точно так же

Оффлайн Mor_6

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-03
  • Сайт: 
  • Профессия: Ученик 1С
Когда я пытаюсь сохранить такой код в модуле:
Процедура Ед()
   Код=Строка(Ед);
   КонецПроцедуры
Появляется ошибка:
{Справочник.Единицы.Форма.ФормаЭлемента.Форма(2,13)}: Переменная не определена (Ед)
   Код=Строка(<<?>>Ед); (Проверка: Сервер)

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Сначала надо научиться читать, затем думать, а только потом программировать.

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Переменная не определена (Ед)
написано же, переменная не определена. как по вашему должна отработать эта строчка кода? при условии, что никому (видимо, включая и вас) не известно, что такое это ваше Ед
грубо говоря, вы пытаетесь заставить программу сделать строку из неведомой хрени: на тебе неведому хрень и сделай из нее строку.

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Переменная не определена (Ед)
написано же, переменная не определена. как по вашему должна отработать эта строчка кода? при условии, что никому (видимо, включая и вас) не известно, что такое это ваше Ед
грубо говоря, вы пытаетесь заставить программу сделать строку из неведомой хрени: на тебе неведому хрень и сделай из нее строку.

По логике если бы там была неведомая хрень, тогда получилась строка "неведомая хрень"  :bleh:

Оффлайн Mor_6

  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-08-03
  • Сайт: 
  • Профессия: Ученик 1С
Да я понимаю, что то, что пишу тут, выглядит как бред сумасшедшего... :D
Но я пока в 1С мало разобрался... Тем более, с командами.

Есть справочник "Единицы", в нём реквизит - Ед.

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
даже не знаю, с какого места начать подсказывать...
судя по всему, вы не понимаете совсем ничего или практически ничего ни в коде 7.7 ни в коде 8.2.
вижу несколько вариантов:
1. найдите литературу и изучите основы программирования на 1С (хотя бы на одной из версий - 7.7 и 8.2, но лучше на обоих)
2. найдите специалиста, который все сделает за вас (естественно, не бесплатно)
3. выложите некоторый ограниченный (не 10 страниц) кусок кода 7.7, который надо перевести на 8.2.

Смысл в том, что ответы на ваши отдельные вопросы в теме есть, однако это явно вам не помогло.
Добавлено: 04 Авг 2013, 00:16

и да, еще: не понял, какой смысл вы вкладывали вот в эти строки:
Процедура Ед()
   Код=Строка(Ед);
   КонецПроцедуры
какой результат вы надеялись получить?

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
даже не знаю, с какого места начать подсказывать...
судя по всему, вы не понимаете совсем ничего или практически ничего ни в коде 7.7 ни в коде 8.2.
вижу несколько вариантов:
1. найдите литературу и изучите основы программирования на 1С (хотя бы на одной из версий - 7.7 и 8.2, но лучше на обоих)
2. найдите специалиста, который все сделает за вас (естественно, не бесплатно)
3. выложите некоторый ограниченный (не 10 страниц) кусок кода 7.7, который надо перевести на 8.2.

Смысл в том, что ответы на ваши отдельные вопросы в теме есть, однако это явно вам не помогло.
Добавлено: 04 Авг 2013, 00:16

и да, еще: не понял, какой смысл вы вкладывали вот в эти строки:
Процедура Ед()
   Код=Строка(Ед);
   КонецПроцедуры
какой результат вы надеялись получить?

Хватит над программистом издеваться, ему помощь нужна! Лучше на мой вопрос ответь, я выложил текст запроса.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
КОд = Строка(Объект.Ед);
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
AIFrame
45 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 717
  • Точка Скрытых: 0
  • Точка Пользователей: 19
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal