Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 14:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблемы с конструкцией Если  (Прочитано 1842 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн bkmz_1_

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-07-18
    • Skype: bkmz_1_
  • Сайт: 
  • Профессия: Бухгалтер
Имею код:

&НаКлиенте
Процедура ВидЗаправкиПриИзменении(Элемент)
    Сообщить(Объект.ВидЗаправки);
    Если Объект.ВидЗаправки = "Склад" Тогда
  Сообщить("Работает");
   КонецЕсли;
КонецПроцедуры

Первое сообщение выдает "Склад", а второе не выдает "Работает". Что не правильно?
Чем ленивее человек, тем больше его труд похож на подвиг


Оффлайн bkmz_1_

  • *
  • Сообщений: 24
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-07-18
    • Skype: bkmz_1_
  • Сайт: 
  • Профессия: Бухгалтер
Объект.ВидЗаправки это выпадающий список (склад, талоны, наличка) который подтягивается из перечеслений (неизменяемых справочников). Может проблема в типах данных?
Чем ленивее человек, тем больше его труд похож на подвиг

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Может проблема в типах данных?
конечно в этом!
ставьте точку останова и смотрите значение Объект.ВидЗаправки и его тип.

если, как вы пишите, это перечисление, то естественно значение перечисления не равно строке, и ваше условие будет выглядеть так:
Если Объект.ВидЗаправки = Перечисления.ИмяПеречисления.Склад Тогда
  Сообщить("Работает");
КонецЕсли;
тут вместо ИмяПеречисления нужно подставить имя перечисления, как оно задано в конфигурации, вместо Склад - имя значения перечисления




Добавлено: 03 Авг 2013, 14:23

есть другой вариант - привести Объект.ВидЗаправки к типу строка:
Если Строка(Объект.ВидЗаправки) = "Склад" Тогда
  Сообщить("Работает");
КонецЕсли;
в любом случае если вы хотите, чтобы работало сравнение на равенство, сравниваемые значения должны быть одного типа (иначе всегда будет Ложь).

первый вариант (сравнивать со значением перечисления) предпочтительнее, скажем так, это просто более правильно


Теги:
 

Вывод информации: если поле не заполнено, то вывод иной информации. Новичок

Автор kiksiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 304
Последний ответ 10 Окт 2017, 12:33
от kiksi
Закрытие 97 счета, проблемы с закрытием 97 счета в НУ

Автор LisenokkРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 6845
Последний ответ 20 Июн 2011, 20:39
от Lisenokk
БГУ - проблемы с отчетом "ЖурналОпераций0504071"

Автор burbonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4250
Последний ответ 12 Окт 2011, 12:42
от burbon
Отсутствует кнопка "все функции" если аутентифицируешься по "Аутентификация 1С предприятие"

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 718
Последний ответ 04 Мар 2017, 16:45
от alex0402
Управление торговлей и управление складом. Проблемы обмена данными.

Автор CabinetonlineРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3025
Последний ответ 12 Мар 2013, 12:54
от Slin

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 830
  • Точка Скрытых: 0
  • Точка Пользователей: 17
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal