Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 18:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнять автоматом наименование  (Прочитано 2297 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет.Есть справочник маршруты В этом справочнике есть табл. часть Этапы, в которой есть 2 реквизита
ПунктОтправления и ПунктПрибытия .Как сдлать чтоб при заполнение этих 2-ух реквизитов наименование (самого справочника) выводилось автоматом?


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
2 варианта:
1. создать 2 обработчика событий ПриИзменении для реквизитов ПунктОтправления и ПунктПрибытия.
2. создать обработчик события табличного поля ПриОкончанииРедактирования.

Содержание обработчиков примерно одинаково: нужно проверять заполнение названия (ели уже заполнено, делать ничего не надо) и заполнение обоих реквизитов - ПунктОтправления и ПунктПрибытия - если заполнены, сформировать название

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
2 варианта:
1. создать 2 обработчика событий ПриИзменении для реквизитов ПунктОтправления и ПунктПрибытия.
2. создать обработчик события табличного поля ПриОкончанииРедактирования.

Содержание обработчиков примерно одинаково: нужно проверять заполнение названия (ели уже заполнено, делать ничего не надо) и заполнение обоих реквизитов - ПунктОтправления и ПунктПрибытия - если заполнены, сформировать название
Пойдём по первому варианту,не поможите с модулем?

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Процедура ЭтапыПунктОтправленияПриИзменении(Элемент)
ЗаполнитьНаименование();
КонецПроцедуры

Процедура ЭтапыПунктПрибытияПриИзменении(Элемент)
ЗаполнитьНаименование();
КонецПроцедуры

Процедура ЗаполнитьНаименование()

Если ЗначениеЗаполнено(Наименование) Тогда
Возврат
КонецЕсли;

ТекущаяСтрока = ЭлементыФормы.Этапы.ТекущаяСтрока;

Если ЗначениеЗаполнено(ТекущаяСтрока.ПунктОтправления) И ЗначениеЗаполнено(ТекущаяСтрока.ПунктПрибытия) Тогда
// тут алгоритм формирования наименования, например так:
Наименование = "Из " + ТекущаяСтрока.ПунктОтправления + " в " + ТекущаяСтрока.ПунктПрибытия;
КонецЕсли;

КонецПроцедуры
Добавлено: 02 Авг 2013, 09:31

да, я не спросил, форма то какая? обычная или управляемая?

приведенный пример для обычной формы


Теги:
 

1С 8.3 - Как присвоить стандартному реквизиту "Наименование" одного справочника, ссылку на реквизит другого справочника?

Автор АлирзаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 245
Последний ответ 09 Ноя 2017, 08:47
от alex0402
Как "Наименование" сделать числом

Автор zedikusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1732
Последний ответ 24 Авг 2015, 06:26
от cska-fanat-kz
Автоматическое заполнение реквизита "Наименование"

Автор AlieramadaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3365
Последний ответ 23 Фев 2014, 10:17
от sadovod
Запрещено изменение элемента справочника если наименование родителя равно "Х"

Автор Tgr11Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2426
Последний ответ 23 Янв 2014, 14:53
от Vit1501
Если организация изменяет наименование, с учета в налоговой службе она не снимается с учета

Автор newsРаздел Новости

Ответов: 0
Просмотров: 756
Последний ответ 09 Окт 2014, 12:24
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
184 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
40 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 476
  • Точка Скрытых: 0
  • Точка Пользователей: 8
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal