Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 09:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Два справочника на одной форме  (Прочитано 7046 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Tanya_Lo

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-07-19
  • Сайт: 
  • Профессия: Ученик 1С
Подскажи пожалуйста как правильно реализовать такую ситуацию:
есть справочник Контрагенты
        справочник Контактные лица (владелец - спр.Контрагенты).
Надо сделать  форму, содержащую списки двух справочников.
1. Открываю форму списка справочника Контрагенты.
2. Добавляю реквизит "Подчиненный" - тип ДинамическийСписок, основная Таблица - Справочник.КонтактныеЛица.
Как связь настроить??
Или может вообще по другому делать надо?


Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
форма обычная или управляемая?
по управляемой не подскажу (до исх пор толком с ними не работал, есть минимальный опыт).
в обычных все просто: пример можете подсмотреть в том же справочнике контрагентов - в нем 2 таб. поля, одно содержит группы, другое элементы и группы. при активации группы в одном таб поле отображается ее содержимое во второй. Работает это дело благодаря заполнению свойства "Связь по родителю".

с владельцем работает тот же принцип: размещаете 2 таб поля, у одного тип СправочникСписок.Контрагенты, у второго - СправочникСписок.КонтактныеЛица; в поле КонтактныеЛица заполняете свойство "Связь по владельцу" = событие "<Имя_Таб_Поля_Контрагенты>.ПриАктивизацииСтроки", где <Имя_Таб_Поля_Контрагенты> - имя первого табличного поля (СправочникСписок.Контрагенты), как вы его задали.

все :)

во вложении простой пример, правда на примере номенклатуры и единиц измерения, потому что у нас в базе Контактные лица не подчинены Контрагентам

Оффлайн Tanya_Lo

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-07-19
  • Сайт: 
  • Профессия: Ученик 1С
управляемое приложение

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
управляемое приложение

Для какой цели он подчинен? Только не говори, что для формы в котором будут 2 справочника )
Добавлено: 02 Авг 2013, 21:40

В управляемых формах все настройки такого вида делаются в форме, если надо открыть вать форму, то там надо указать отбор по владельцу (как то так)
Если 2 окошка в форме, то там все просто на интуитивном уровне. С открытием нового окна тоже проблем не должно возникнуть, так что пробуй.

Насчет создания реквизита, зачем? :bleh:

Последний раз редактировалось: GRADUS; 02 Авг 2013, 21:40. Причина: Объединение сообщений

Оффлайн sadovod

  • ****
  • Сообщений: 289
  • РЕПУТАЦИЯ: 53
  • КПД: 18%
  • Регистрация: 2012-02-19
  • Сайт: 
  • Профессия: Программист 1С
управляемое приложение
В управляемой форме такую штуку можно легко и удобно с помощью настройки динамического списка и нескольких строчек кода. Я бы сделал так:
1. В настройке динамического списка "КонтактныеЛица" (в его свойстве "Настройка списка") выбираете закладки "Настройки" -> "Отбор" и добавляете там элемент отбора, выбрав реквизит "Владелец". Нажмите кнопку "Подробно", чтобы увидеть все столбцы элемента отбора: "ЛевоеЗначение" = "Владелец", "ВидСравнения" = "Равно", "ПравоеЗначение" оставьте пустым, а для "Представления" задайте любой произвольное имя, например "ОтборПоВладельцу". Оно будет нужно, чтобы в коде найти именно этот элемент отбора.
2. В обработчике события "ПриАктивацииСтроки" элемента "СписокКонтрагентов" (ну, или как там он у вас называется :) ) пишете такой код для установки ПравогоЗначения отбора списка "КонтактныеЛица":
&НаКлиенте
Процедура СписокКонтрагентовПриАктивизацииСтроки(Элемент)
Для каждого текущий_элемент Из СписокКонтактныхЛиц.Отбор.Элементы Цикл
Если текущий_элемент.Представление = "ОтборПоВладельцу" Тогда        //  нашли нужный элемент отбора, ведь могут быть и другие
текущий_элемент.ПравоеЗначение = Элементы.СписокКонтрагентов.ТекущаяСтрока;    // а здесь установим нужное значение отбора
КонецЕсли;
КонецЦикла;
КонецПроцедуры
Разумеется, все наименования элементов формы у вас могут быть другими :)


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6506
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4212
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 646
Последний ответ 10 Май 2017, 20:44
от ilnur75
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2052
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Работа с формой Справочника "Физ.Лица" в ЗУП 2.5

Автор Митя_Просто_МитяРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3903
Последний ответ 15 Дек 2011, 00:04
от Vit1501

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
136 Сообщений
AIFrame
66 Сообщений
ilyay ilyay
63 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 755
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal