Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 09:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Окно выбора даты и времени перед печатью ВПЧ  (Прочитано 7305 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн DihlofoZ

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-22
  • Сайт: 
  • Профессия: Ученик 1С
Вопрос достаточно специфический, но хотел узнать, как реализовать такое:

Есть впч, после нажатия на печать:
  появлялся календарик с временем, сотрудник выбирает дату и время, значения присваиваются в переменную ЗаветнаяДата

Если ЗаветнаяДата = Неопределено Тогда
      Возврат Неопределено;
   КонецЕсли;


Оффлайн DihlofoZ

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-22
  • Сайт: 
  • Профессия: Ученик 1С

Если нельзя реализовать вызов календарика, то можно хотя бы вызвать окно для ввода произвольного текста?

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Что такое ВПЧ ?
Добавлено: 01 Авг 2013, 12:02

Перем ЗаветнаяДата;
Если НЕ ВвестиДату(ЗаветнаяДата,"Введите заветные дату и время") тогда
   Возврат Неопределено;
КонецЕсли;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн DihlofoZ

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-22
  • Сайт: 
  • Профессия: Ученик 1С
то есть ВПФ  :bleh: внешняя печатная форма

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С

Если нельзя реализовать вызов календарика, то можно хотя бы вызвать окно для ввода произвольного текста?

В процедурке "печать()" вызывай форму, где будет поле ввода с типом дата.

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
см. синтаксис-помощник ВвестиДату. там и пример есть:
ДатаНапоминания = РабочаяДата;
Подсказка = "Введите дату и время";
ЧастьДаты = ЧастиДаты.ДатаВремя;
Если ВвестиДату(ДатаНапоминания, Подсказка, ЧастьДаты) Тогда
// запомнить дату напоминания
КонецЕсли;
хотя в принципе, Dethmontt, уже писал об этом выше

Оффлайн DihlofoZ

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-22
  • Сайт: 
  • Профессия: Ученик 1С
Что такое ВПЧ ?
Добавлено: 01 Авг 2013, 12:02

Перем ЗаветнаяДата;
Если НЕ ВвестиДату(ЗаветнаяДата,"Введите заветные дату и время") тогда
   Возврат Неопределено;
КонецЕсли;

Спасибо, этот вариант подошел....
Появилось 2 дополнительных вопроса, надеюсь на вашу помощь :)

1. можно ли указать размер окна ввода? т.к.  окно маленькое и текст заголовка "Введите дату и время" не влазит....
2. и как таким же образом вместо окна ВвестиДату, создать окно ввода текста или еще лучше только для ввода цифр?

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
см. синтаксис-помощник ВвестиДату
вот этот совет вы похоже проигнорировали.
еще раз: СМОТРИТЕ СИНТАКСИС-ПОМОЩНИК!
Кроме ВвестиДату есть:
ВвестиЗначение
ВвестиЧисло
ВвестиСтроку

можно ли указать размер окна
ввода?
по этому поводу совет так же был в теме: если стандартная функция не устраивает, вы всегда можете создать свою форму для ввода любого значения.


Оффлайн DihlofoZ

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-22
  • Сайт: 
  • Профессия: Ученик 1С
см. синтаксис-помощник ВвестиДату
вот этот совет вы похоже проигнорировали.
еще раз: СМОТРИТЕ СИНТАКСИС-ПОМОЩНИК!
Кроме ВвестиДату есть:
ВвестиЗначение
ВвестиЧисло
ВвестиСтроку

можно ли указать размер окна
ввода?
по этому поводу совет так же был в теме: если стандартная функция не устраивает, вы всегда можете создать свою форму для ввода любого значения.

Спасибо, разобрался)
Просьба сильно не злиться на меня... я ведь все таки учусь...:)

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
просто читайте внимательнее, что вам пишут, вот и все.
если бы вы сразу открыли СП, продолжение вопроса не возникло бы вовсе


Теги:
 

Как из справочника вытащить список одной группы справочника и вставить его в поле документа для выбора одного элемента из полученного списка?

Автор ilnur75Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1676
Последний ответ 21 Сен 2016, 08:16
от GadLex
Как очистить текст в "Поле выбора"?

Автор rrr39Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 13228
Последний ответ 18 Авг 2011, 14:42
от has
Свойство "Связи параметров выбора"

Автор analitik777Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5998
Последний ответ 05 Фев 2014, 15:04
от analitik777
Перечисления и структура выбора "Если"

Автор СамоварРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 824
Последний ответ 22 Авг 2016, 10:55
от SGIRG
Добавление выбора аналитики в отчет "Закупки"

Автор ValentusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 6009
Последний ответ 31 Май 2010, 15:55
от Valentus

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 758
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal