Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 07:08
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Запрос  (Прочитано 7386 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн deringpavel

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-03-12
  • Сайт: 
  • Профессия: Программист 8.1
Запрос
« Первое сообщение: 29 Июл 2013, 18:58 »
Здравствуйте. Вопрос такой - имеется конфа Управление торговлей, версия 10.3. Имеется документ "план работ по ИТС", его вид прилагается в скриншоте.
Нужно сделать так, чтобы данные из колонок (номенклатура, ответственный, рег.номер и т.д.) остались без изменения, а добавились лишь только виды подписки (Проф, техно и т.д.). Где может быть ошибка?

Код такой:

Процедура ИТСНажатие(Кнопка)

ЗапросИТС = Новый Запрос;
ЗапросИТС.Текст = "ВЫБРАТЬ
                  | _2Н_ПодпискиИТССрезПоследних.Период,
                  | _2Н_ПодпискиИТССрезПоследних.Регистратор,
                  | _2Н_ПодпискиИТССрезПоследних.НомерСтроки,
                  | _2Н_ПодпискиИТССрезПоследних.Активность,
                  | _2Н_ПодпискиИТССрезПоследних.Контрагент,
                  | _2Н_ПодпискиИТССрезПоследних.Номенклатура,
                  | _2Н_ПодпискиИТССрезПоследних.РегистрационныйНомер,
                  | _2Н_ПодпискиИТССрезПоследних.ДатаНачалаПодписки,
                  | _2Н_ПодпискиИТССрезПоследних.ДатаОкончанияПодписки,
                  | _2Н_ПодпискиИТССрезПоследних.СрокПодписки,
                  | _2Н_ПодпискиИТССрезПоследних.ВидПодпискиИТС
                  |ИЗ
                  | РегистрСведений._2Н_ПодпискиИТС.СрезПоследних КАК _2Н_ПодпискиИТССрезПоследних";
 
ВыборкаИТС = ЗапросИТС.Выполнить();
Врем = ВыборкаИТС.Выгрузить();

Для Каждого Стр Из Врем Цикл
НоваяСтр = ЭтотОбъект.Работы.Добавить();
ЗаполнитьЗначенияСвойств(НоваяСтр, Стр);
КонецЦикла;
КонецПроцедуры



Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Запрос
« Ответ #1: 29 Июл 2013, 20:50 »
Ты постоянно добавляешь новые строки в ТЧ
 НоваяСтр = ЭтотОбъект.Работы.Добавить();
Добавлено: 29 Июл 2013, 20:51

А нужно искать по уже добавленным 
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Re: Запрос
« Ответ #2: 29 Июл 2013, 20:55 »
Надо в форме добавить колонку. Надо в ТЧ "Работы" добавить колонку и все будет работать.

Оффлайн deringpavel

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-03-12
  • Сайт: 
  • Профессия: Программист 8.1
Re: Запрос
« Ответ #3: 29 Июл 2013, 21:26 »
Попробовал сделать так:

	Для Каждого Стр Из ЭтотОбъект.Работы Цикл
               НайденнаяЗапись = ТЗВрем.Найти(ВидПодписки);
Стр.ВидПодписки = НайденнаяЗапись;
КонецЦикла;

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Запрос
« Ответ #4: 29 Июл 2013, 21:52 »
Так вам подписку в таблице надо искать или по подписке искать в таблице? (определитесь)
(P.S. сейчас вы ищите по подписке в таблице)
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн deringpavel

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-03-12
  • Сайт: 
  • Профессия: Программист 8.1
Re: Запрос
« Ответ #5: 29 Июл 2013, 21:53 »
Нет - вид подписки нужно добавить в табличную часть, при этом строки "контрагенты, ответственный" и т.д. должны остаться прежними.

То есть, искать подписку во временной таблице, созданной из запроса и вставить ее в табл. часть документа.

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Запрос
« Ответ #6: 29 Июл 2013, 22:07 »
Процедура ИТСНажатие(Кнопка)
ЗапросИТС = Новый Запрос("ВЫБРАТЬ
|         ТЗ.НомерСтроки,
|         ТЗ.Контрагент,
|         ТЗ.Номенклатура,
|         ТЗ.РегистрационныйНомер,
|         ТЗ.ДатаНачалаПодписки,
|         ТЗ.ДатаОкончанияПодписки,
|         ТЗ.СрокПодписки,
|         _2Н_ПодпискиИТССрезПоследних.ВидПодпискиИТС КАК ВидПодписки
|         ПОМЕСТИТЬ ВТ
|          ИЗ &ТЗ КАК ТЗ
|          ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений._2Н_ПодпискиИТС.СрезПоследних КАК _2Н_ПодпискиИТССрезПоследних
|          ПО ТЗ.Контрагент = РегистрНакопления1.Контрагент
|          И ТЗ.Номенклатура = РегистрНакопления1.Номенклатура
|          И ТЗ.РегистрационныйНомер = РегистрНакопления1.РегистрационныйНомер
|          И ТЗ.ДатаНачалаПодписки = РегистрНакопления1.ДатаНачалаПодписки
|          И ТЗ.ДатаОкончанияПодписки = РегистрНакопления1.ДатаОкончанияПодписки
|          ;
|          ВЫБРАТЬ * ИЗ ВТ");
ЗАпрос.УстановитьПараметр("ТЗ",Работы.Выгрузить());

Работы.Загрузить(Запрос.Выполнить().Выгрузить());
КонецПроцедуры
Добавлено: 29 Июл 2013, 22:08

Ход ваших мыслей верный...
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн deringpavel

  • *
  • Сообщений: 44
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-03-12
  • Сайт: 
  • Профессия: Программист 8.1
Re: Запрос
« Ответ #7: 29 Июл 2013, 22:17 »
Ничего не понял из того что прислано...

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Запрос
« Ответ #8: 29 Июл 2013, 22:25 »
Ничего не понял из того что прислано...
Запрос объединяет табличную часть и регистр сведений и загружает обратно в табличную часть
Добавлено: 29 Июл 2013, 22:34

Подправил
Процедура ИТСНажатие(Кнопка)
ЗапросИТС = Новый Запрос("ВЫБРАТЬ
|         ТЗ.НомерСтроки,
|         ТЗ.Контрагент,
|         ТЗ.Номенклатура,
|         ТЗ.РегистрационныйНомер,
|         ТЗ.ДатаНачалаПодписки,
|         ТЗ.ДатаОкончанияПодписки,
|         ТЗ.СрокПодписки,
|         ТЗ.Ответственный,
|         Регистр.ВидПодпискиИТС КАК ВидПодписки
|         ПОМЕСТИТЬ ВТ
|          ИЗ &ТЗ КАК ТЗ
|          ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений._2Н_ПодпискиИТС.СрезПоследних(&ДатаДокумента) КАК Регистр
|          ПО ТЗ.Контрагент = Регистр.Контрагент
|          И ТЗ.Номенклатура = Регистр.Номенклатура
|          И ТЗ.РегистрационныйНомер = Регистр.РегистрационныйНомер
|          И ТЗ.ДатаНачалаПодписки = Регистр.ДатаНачалаПодписки
|          И ТЗ.ДатаОкончанияПодписки = Регистр.ДатаОкончанияПодписки
|          И ТЗ.СрокПодписки = Регистр.СрокПодписки
|          ;
|          ВЫБРАТЬ * ИЗ ВТ");
ЗАпрос.УстановитьПараметр("ТЗ",Работы.Выгрузить());
Запрос.УстановитьПараметр("ДатаДокумента",Дата);

Работы.Загрузить(Запрос.Выполнить().Выгрузить());
КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Последний раз редактировалось: Dethmontt; 29 Июл 2013, 22:36

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Re: Запрос
« Ответ #9: 29 Июл 2013, 23:19 »
Да это не его запрос )


Теги:
 

Как можно подставлять цену из регистра сведений "Цены поставщиков" в документ"ПоступлениеТоваров" на актуальную дату? Необходимо использовать запрос в решении.

Автор Елена6666666666Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 9323
Последний ответ 24 Окт 2014, 13:30
от cska-fanat-kz
Запрос Параметры для "ИЗ"

Автор БерезинРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2990
Последний ответ 15 Май 2013, 23:27
от Березин
Что быстрее: Загрузить табличную часть в запрос и там добавить колонки, или пробежаться циклом по ТЧ и добавить значения в колонки

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 975
Последний ответ 11 Июл 2016, 09:00
от vitasw
Запрос по обработке "Согласование заявок"

Автор DenielAkreedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 676
Последний ответ 29 Сен 2016, 02:39
от DenielAkreed
8.2 Бух. Запрос с условием "комментарий содержит текст"

Автор bolobolРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 16497
Последний ответ 02 Сен 2011, 01:14
от bolobol

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 289
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal