Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 23:38
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнить комментарий через каждые 2 элемента справочника  (Прочитано 3672 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Добрый день!Есть справочник а в нем комментарий.В обработке при  нажатии Выполнить,я заполняю комментарии во всех элементах справочника.Хочу чтобы при вводе числа например 2 у меня заполнялись каждые два комментария через каждые два элемента.Подскажите каким методом можно это проделать?

Комментарий: Я тут был
Комментарий: Я тут был
Комментарий: (пусто)
Комментарий: (пусто)
Комментарий: Я тут был
Комментарий: Я тут был


Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Я хочу к тебе на работу :bleh:

Ведешь счетчик от 1 до 4 -ех. Каждый элемент делает +1 к счетчику, если счетчик равен 4, тогда 4+1 = 1.
А когда указываешь коментарий ?(Счетчик=1 или Счтчик=2,"Я тута было","Меня туто небыло")

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Я хочу к тебе на работу :bleh:

Ведешь счетчик от 1 до 4 -ех. Каждый элемент делает +1 к счетчику, если счетчик равен 4, тогда 4+1 = 1.
А когда указываешь коментарий ?(Счетчик=1 или Счтчик=2,"Я тута было","Меня туто небыло")

Да это к работе не имеет никакого отношения)Просто задания дают,для тренировки))

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Задания дают для тренировки - а чего не тренируетесь? ;)
Сами что-то написали? Что конкретно не получается?
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Задания дают для тренировки - а чего не тренируетесь? ;)
Сами что-то написали? Что конкретно не получается?

Тренируюсь для опыта)Заполнить все комментарии получается а вот через каждые два как-то не очень...))

Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С
Задания дают для тренировки - а чего не тренируетесь? ;)
Сами что-то написали? Что конкретно не получается?

Тренируюсь для опыта)Заполнить все комментарии получается а вот через каждые два как-то не очень...))

я же написал как это сделать

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
	Текст = "Комментарий";

м=0;
т=0;

Для сч=1 По 30 Цикл
Если м<2 Тогда
Сообщить(Текст+ " Я тут был");
м=м+1;
КонецЕсли;
Если м=2 Тогда
Сообщить(Текст);
т=т+1;
КонецЕсли;
Если т=2 Тогда
т=0;
м=0;
КонецЕсли;
КонецЦикла;
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Свинтуз

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 1
  • КПД: 13%
  • Регистрация: 2010-11-02
  • Сайт: 
Если долго смотреть на учебник, то учебник начинает смотреть на тебя :)

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Задания дают для тренировки - а чего не тренируетесь? ;)
Сами что-то написали? Что конкретно не получается?

Тренируюсь для опыта)Заполнить все комментарии получается а вот через каждые два как-то не очень...))

я же написал как это сделать

Так я же ничего не говорю))Большое спасибо))


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6507
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4215
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 650
Последний ответ 10 Май 2017, 20:44
от ilnur75
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2058
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 278
Последний ответ 12 Окт 2017, 14:02
от wise

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
73 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
BuhRust
31 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 281
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal