Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 21:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Произвольное число  (Прочитано 3213 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Всем привет!Есть обработка Формирование Цен,я туда добавил реквизит ТипыЦен. Я выбираю Установить цену,после этого появляется рядом реквизит для ввода числа (Произвольно),но у меня вводится округление.Как передать введеное число, вместо округления, при нажатии выполнить, в ТабЧасть?Заранее спасибо!

1С:Предприятие 8.2 (8.2.18.61) У  ЧП Украины Базовая



Последний раз редактировалось: Kostik2013; 25 Июл 2013, 17:37


Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Такой код у меня

Процедура КнопкаВыполнитьНажатиеУстановитьЦену(Элемент) // Подключение данной процедуры-обработчика выполняется из кода конфигурации

   // Должен быть выбран прядок округления
   Если ОбщегоНазначения.ЗначениеНеЗаполнено(ВариантЗначения) Тогда
      
      Предупреждение(" Не указана цена!", 60, );
      Возврат;
      
   КонецЕсли;

   Для каждого СтрокаТабличнойЧасти Из Товары Цикл
      Если СтрокаТабличнойЧасти.Пометка Тогда

         // Установим.
   СтрокаТабличнойЧасти.Цена = Ценообразование.УстановитьЦену(СтрокаТабличнойЧасти.Цена,
                                   ВариантЗначения, Ложь);
      КонецЕсли;
   КонецЦикла;
   ДействиеНеВыполнено = Ложь;


КонецПроцедуры // КнопкаВыполнитьНажатиеУстановитьЦену()

Добавлено: 25 Июл 2013, 18:02

Такой код у меня

Процедура КнопкаВыполнитьНажатиеУстановитьЦену(Элемент) // Подключение данной процедуры-обработчика выполняется из кода конфигурации

   // Должен быть выбран прядок округления
   Если ОбщегоНазначения.ЗначениеНеЗаполнено(ВариантЗначения) Тогда
      
      Предупреждение(" Не указана цена!", 60, );
      Возврат;
      
   КонецЕсли;

   Для каждого СтрокаТабличнойЧасти Из Товары Цикл
      Если СтрокаТабличнойЧасти.Пометка Тогда

         // Установим.
   СтрокаТабличнойЧасти.Цена = Ценообразование.УстановитьЦену(СтрокаТабличнойЧасти.Цена,
                                   ВариантЗначения, Ложь);
      КонецЕсли;
   КонецЦикла;
   ДействиеНеВыполнено = Ложь;


КонецПроцедуры // КнопкаВыполнитьНажатиеУстановитьЦену()
Добавлено: 25 Июл 2013, 18:07

Оооооочень срочно люди добрые!
Добавлено: 25 Июл 2013, 18:32

Такой код у меня

Процедура КнопкаВыполнитьНажатиеУстановитьЦену(Элемент) // Подключение данной процедуры-обработчика выполняется из кода конфигурации

   // Должен быть выбран прядок округления
   Если ОбщегоНазначения.ЗначениеНеЗаполнено(ВариантЗначения) Тогда
      
      Предупреждение(" Не указана цена!", 60, );
      Возврат;
      
   КонецЕсли;

   Для каждого СтрокаТабличнойЧасти Из Товары Цикл
      Если СтрокаТабличнойЧасти.Пометка Тогда

         // Установим.
   СтрокаТабличнойЧасти.Цена = Ценообразование.УстановитьЦену(СтрокаТабличнойЧасти.Цена,
                                   ВариантЗначения, Ложь);
      КонецЕсли;
   КонецЦикла;
   ДействиеНеВыполнено = Ложь;


КонецПроцедуры // КнопкаВыполнитьНажатиеУстановитьЦену()

Добавлено: 25 Июл 2013, 18:02

Такой код у меня

Процедура КнопкаВыполнитьНажатиеУстановитьЦену(Элемент) // Подключение данной процедуры-обработчика выполняется из кода конфигурации

   // Должен быть выбран прядок округления
   Если ОбщегоНазначения.ЗначениеНеЗаполнено(ВариантЗначения) Тогда
      
      Предупреждение(" Не указана цена!", 60, );
      Возврат;
      
   КонецЕсли;

   Для каждого СтрокаТабличнойЧасти Из Товары Цикл
      Если СтрокаТабличнойЧасти.Пометка Тогда

         // Установим.
   СтрокаТабличнойЧасти.Цена = Ценообразование.УстановитьЦену(СтрокаТабличнойЧасти.Цена,
                                   ВариантЗначения, Ложь);
      КонецЕсли;
   КонецЦикла;
   ДействиеНеВыполнено = Ложь;


КонецПроцедуры // КнопкаВыполнитьНажатиеУстановитьЦену()
Добавлено: 25 Июл 2013, 18:07

Оооооочень,очеееень  срочно люди добрые!
Добавлено: 25 Июл 2013, 18:33




Оооооочень,очеееень  срочно люди добрые!

Последний раз редактировалось: Kostik2013; 25 Июл 2013, 18:33. Причина: Объединение сообщений

Оффлайн mixqn

  • Администратор
  • *****
  • Сообщений: 1346
  • РЕПУТАЦИЯ: 166
  • КПД: 12%
  • Who is John Galt?
  • Регистрация: 2012-08-15
  • Сайт: 3gmaster.net
  • Профессия: Программист 1С
Всем привет!Есть обработка Формирование Цен,я туда добавил реквизит ТипыЦен. Я выбираю Установить цену,после этого появляется рядом реквизит для ввода числа (Произвольно),но у меня вводится округление.Как передать введеное число, вместо округления, при нажатии выполнить, в ТабЧасть?Заранее спасибо!

1С:Предприятие 8.2 (8.2.18.61) У  ЧП Украины Базовая

либо я дурак, либо вопрос у вас сформулирован непонятно.

если проблема в том, что у вас число округляется до какого-то количества знаков после запятой, проверьте тип данных (сколько там знаков после запятой может быть).

если проблема в чем-то другом, попробуйте переформулировать или уточнить вопрос

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Всем привет!Есть обработка Формирование Цен,я туда добавил реквизит ТипыЦен. Я выбираю Установить цену,после этого появляется рядом реквизит для ввода числа (Произвольно),но у меня вводится округление.Как передать введеное число, вместо округления, при нажатии выполнить, в ТабЧасть?Заранее спасибо!

1С:Предприятие 8.2 (8.2.18.61) У  ЧП Украины Базовая

либо я дурак, либо вопрос у вас сформулирован непонятно.

если проблема в том, что у вас число округляется до какого-то количества знаков после запятой, проверьте тип данных (сколько там знаков после запятой может быть).

если проблема в чем-то другом, попробуйте переформулировать или уточнить вопрос

Разобрался!Спасибо)


Теги:
 

Конвертация данных, ошибка "Преобразование значения к типу Число не может быть выполнено"

Автор CerebrinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1956
Последний ответ 10 Май 2015, 21:51
от Дмитрий@
Как вывести ноли в значении реквизита таблицы "Число"

Автор AndrepanРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 346
Последний ответ 01 Фев 2017, 15:01
от Andrepan
УТ 10.3 Допустимое число дней задолженности: .., дата самой старой задолженности: ..

Автор Татьяна БыковаРаздел Беседка

Ответов: 2
Просмотров: 240
Последний ответ 07 Сен 2017, 13:51
от Татьяна Быкова
Управляемое приложение.Как предустановить значение реквизита с Типом "Число".

Автор |R|U|D|E|NРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 6019
Последний ответ 22 Мар 2011, 06:04
от cska-fanat-kz
Операции сравнения на больше-меньше допустимы только для значений совпадающих примитивных типов (Булево, Число, Строка, Дата)

Автор ktu78Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4012
Последний ответ 04 Сен 2015, 21:50
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
157 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
51 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
33 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 215
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal