Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 01:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: подписки на события  (Прочитано 1852 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет,помогите пожалуйста.Я сделал роль для пользователя с определённым набором прав.Мне нужно создать подписку на событие чтоб она выгледела примерно так,что у кого не стоит эта роль ,тот не может пользоваться справочниками.Начало есть

Процедура ЗапретДляБухгалтераПередЗаписью(Источник, Отказ) Экспорт
     Если РольДоступна("уатБухгалтерия") Тогда
    Отказ = Ложь;
   Предупреждение("В целях безопасности данная функция отключена!");
        Возврат;
    Иначе
    Отказ = Истина;   
КонецЕсли;

КонецПроцедуры
как сделать чтоб она работала?


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Создать подписку - выбрать в метод эту процедуру - а в источник выбрать СправочникОбъект
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн gliokker

  • ***
  • Сообщений: 231
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Создать подписку - выбрать в метод эту процедуру - а в источник выбрать СправочникОбъект
ну да работает,только чуть переделал,можа кому нужна
Процедура ЗапретДляБухгалтераПередЗаписью(Источник, Отказ) Экспорт
   Если Источник.ОбменДанными.Загрузка = Ложь И НЕ РольДоступна("уатБухгалтерия") Тогда
      Отказ = Истина;
# Если Клиент Тогда      
      Предупреждение("В целях безопасности данная функция отключена!");
#КонецЕсли
   КонецЕсли; 
КонецПроцедуры



Теги:
 

Подписка на события "ПриЗаписи", как достать измененные категории

Автор blackbeardРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3688
Последний ответ 17 Окт 2014, 09:19
от blackbeard
Немогу найти нужного события((поможите

Автор AxOnРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 50
Просмотров: 13879
Последний ответ 16 Окт 2010, 13:33
от Makifka
Обработчик события не найден при заполнении документа

Автор boldinovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3393
Последний ответ 12 Сен 2014, 13:00
от LexaK
Дополнительный обработчик бизнес-события, Документооборот 2.1

Автор mokidРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 665
Последний ответ 12 Янв 2017, 16:29
от mokid
Обработчик события формы документа

Автор lonselotРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1350
Последний ответ 28 Июл 2015, 08:48
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
29 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 173
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal