Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Май 2018, 14:18
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Таблица значений  (Прочитано 2874 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Всем добрый вечер!Пытаюсь заполнить ТЗ а ничего не выходит.Подскажите что не так.Заранее благодарен!

1С:Предприятие 8.2 (8.2.15.310)  Торговля для частных предпринимателей Украины базовая

&НаКлиенте
Процедура УстановкаЦенНажатие(Элемент)
   ПолучитьОбщуюФорму("Форма").Открыть();
   ЗаполнитьФорму ();
КонецПроцедуры
&НаСервере
Функция ЗаполнитьФорму ()
   
   
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |   ЦеныНоменклатурыСрезПоследних.Регистратор,
   |   ЦеныНоменклатурыСрезПоследних.Номенклатура ,
   |   ЦеныНоменклатурыСрезПоследних.ТипЦен ,
   |   ЦеныНоменклатурыСрезПоследних.Цена 
   |ИЗ
   |   РегистрСведений.ЦеныНоменклатуры.СрезПоследних КАК ЦеныНоменклатурыСрезПоследних";
      
   Результат = Запрос.Выполнить();
   
   ВыборкаДетальныеЗаписи = Результат.Выбрать();
   
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      
   НоваяСтрока = ТаблицаЦен.Добавить();
    НоваяСтрока.Номенклатура = Номенклатура;
   НоваяСтрока.ТипЦен = ТипЦен;
   НоваяСтрока.Цена = Цена;
            
   КонецЦикла;
   


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2861
  • РЕПУТАЦИЯ: 548
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Таблица значений
« Ответ #1: 25 Июл 2013, 01:54 »
Ну а в чем проблема то?
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
Re: Таблица значений
« Ответ #2: 25 Июл 2013, 10:00 »
Предполагаю должно быть так:
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
     
   НоваяСтрока = ТаблицаЦен.Добавить();
    НоваяСтрока.Номенклатура = ВыборкаДетальныеЗаписи.Номенклатура;
   НоваяСтрока.ТипЦен = ВыборкаДетальныеЗаписи.ТипЦен;
   НоваяСтрока.Цена = ВыборкаДетальныеЗаписи.Цена;
           
   КонецЦикла;

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Re: Таблица значений
« Ответ #3: 25 Июл 2013, 11:09 »
Вопрос закрыт.Всем спасибо,что уделили внимание и время.


Теги:
 

Обнаружено дублирование ключевых значений в колонке ссылка ["обнаружено дублирование ключевых з

Автор lianinfoРаздел Пользователям "1С - Предприятие 8"

Ответов: 10
Просмотров: 685
Последний ответ 20 Мар 2018, 16:54
от alex0402
Ошибка - Обнаружено дублирование ключевых значений в колонке "Ссылка". Отображение данных в списке не возможно.

Автор welldoneРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 5469
Последний ответ 24 Ноя 2015, 15:38
от welldone
"Проверка мутабельных значений на заполненность не поддерживается"

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 22889
Последний ответ 13 Фев 2011, 17:36
от proofet
Почему реквизит типа "список значений" может оказаться недоступным для изменения

Автор VdegРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 6616
Последний ответ 28 Июл 2011, 23:55
от Dethmontt
1C ЗУП 2.5 Помогите с отчетом "Списки сотрудников организации" Объединение значений ячеек

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1394
Последний ответ 10 Фев 2017, 10:49
от ksander-fars

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
159 Сообщений
alex0402
73 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
59 Сообщений
buketov.av buketov.av
42 Сообщений
wise wise
39 Сообщений
KOI8-R
34 Сообщений
ilyay ilyay
29 Сообщений
Alter
28 Сообщений
trialex3
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal