Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 14:39
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Таблица значений  (Прочитано 2657 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Всем добрый вечер!Пытаюсь заполнить ТЗ а ничего не выходит.Подскажите что не так.Заранее благодарен!

1С:Предприятие 8.2 (8.2.15.310)  Торговля для частных предпринимателей Украины базовая

&НаКлиенте
Процедура УстановкаЦенНажатие(Элемент)
   ПолучитьОбщуюФорму("Форма").Открыть();
   ЗаполнитьФорму ();
КонецПроцедуры
&НаСервере
Функция ЗаполнитьФорму ()
   
   
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |   ЦеныНоменклатурыСрезПоследних.Регистратор,
   |   ЦеныНоменклатурыСрезПоследних.Номенклатура ,
   |   ЦеныНоменклатурыСрезПоследних.ТипЦен ,
   |   ЦеныНоменклатурыСрезПоследних.Цена 
   |ИЗ
   |   РегистрСведений.ЦеныНоменклатуры.СрезПоследних КАК ЦеныНоменклатурыСрезПоследних";
      
   Результат = Запрос.Выполнить();
   
   ВыборкаДетальныеЗаписи = Результат.Выбрать();
   
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      
   НоваяСтрока = ТаблицаЦен.Добавить();
    НоваяСтрока.Номенклатура = Номенклатура;
   НоваяСтрока.ТипЦен = ТипЦен;
   НоваяСтрока.Цена = Цена;
            
   КонецЦикла;
   


Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Re: Таблица значений
« Ответ #1: 25 Июл 2013, 01:54 »
Ну а в чем проблема то?
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
Re: Таблица значений
« Ответ #2: 25 Июл 2013, 10:00 »
Предполагаю должно быть так:
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
     
   НоваяСтрока = ТаблицаЦен.Добавить();
    НоваяСтрока.Номенклатура = ВыборкаДетальныеЗаписи.Номенклатура;
   НоваяСтрока.ТипЦен = ВыборкаДетальныеЗаписи.ТипЦен;
   НоваяСтрока.Цена = ВыборкаДетальныеЗаписи.Цена;
           
   КонецЦикла;

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Re: Таблица значений
« Ответ #3: 25 Июл 2013, 11:09 »
Вопрос закрыт.Всем спасибо,что уделили внимание и время.


Теги:
 

Ошибка - Обнаружено дублирование ключевых значений в колонке "Ссылка". Отображение данных в списке не возможно.

Автор welldoneРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 4659
Последний ответ 24 Ноя 2015, 15:38
от welldone
"Проверка мутабельных значений на заполненность не поддерживается"

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 20703
Последний ответ 13 Фев 2011, 17:36
от proofet
Почему реквизит типа "список значений" может оказаться недоступным для изменения

Автор VdegРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 6210
Последний ответ 28 Июл 2011, 23:55
от Dethmontt
1C ЗУП 2.5 Помогите с отчетом "Списки сотрудников организации" Объединение значений ячеек

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1046
Последний ответ 10 Фев 2017, 10:49
от ksander-fars
Обход дерева значений на клиенте / развернуть многоуровневое дерево на клиенте

Автор virtusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5154
Последний ответ 01 Ноя 2015, 10:07
от Азиман

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 843
  • Точка Скрытых: 0
  • Точка Пользователей: 12
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal