Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Май 2018, 18:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Поле ЗачетАванса не доступно для записи  (Прочитано 2556 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dim3740

  • *
  • Сообщений: 47
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-16
  • Сайт: 

8.2. обычные формы, код во внешней обработке... СпособЗачетаАвансов в шапке документа. Ошибка в названии топика.


Процедура НеЗачитыватьНажатие(Элемент)
   Док=Документы.РеализацияТоваровУслуг.Выбрать(НачалоДня(НачПериода),КонецДня(КонПериода));
   Пока Док.Следующий() Цикл
      ТЭ= Док.ПолучитьОбъект();
      ТЭ.ЗачетАвансов=Перечисления.СпособыЗачетаАвансов.НеЗачитывать;
      ТЭ.Записать(РежимЗаписиДокумента.Запись);
   КонецЦикла;
КонецПроцедуры


 Чем реквизит отличается от иных, того же контрагента, к примеру, что не хочет перезаписываться..?  не понятно...


Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С

8.2. обычные формы, код во внешней обработке... СпособЗачетаАвансов в шапке документа. Ошибка в названии топика.


Процедура НеЗачитыватьНажатие(Элемент)
   Док=Документы.РеализацияТоваровУслуг.Выбрать(НачалоДня(НачПериода),КонецДня(КонПериода));
   Пока Док.Следующий() Цикл
      ТЭ= Док.ПолучитьОбъект();
      ТЭ.ЗачетАвансов=Перечисления.СпособыЗачетаАвансов.НеЗачитывать;
      ТЭ.Записать(РежимЗаписиДокумента.Запись);
   КонецЦикла;
КонецПроцедуры


 Чем реквизит отличается от иных, того же контрагента, к примеру, что не хочет перезаписываться..?  не понятно...

Код верный, что то намудрил с реквизитами. Возможно, у документа ЗачетАвансов не реквезит, а табличная часть или еще чтонить. В общем по предоставленному коду нечего сказать.

Оффлайн dim3740

  • *
  • Сообщений: 47
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-16
  • Сайт: 
Спасибо. Отличие в наличии, действительно, также еще и ТЧ по авансам. Прошу помощи в обучении метода работы с Формой документа из внешней обработкой. Думаю, что решение по сабжу именно в таком способе....


Теги:
 

Поле не найдено"ЗаказПокупателя.Услуги.Ссылка"<<?>>ЗаказПокупателя.Услуги.Ссылка

Автор romanprogrammistРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 7838
Последний ответ 05 Дек 2013, 00:01
от romanprogrammist
{Форма.Форма.Форма(11)}: Поле объекта не обнаружено

Автор OksРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2768
Последний ответ 09 Дек 2015, 19:33
от Oks
Вывод информации: если поле не заполнено, то вывод иной информации. Новичок

Автор kiksiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 636
Последний ответ 10 Окт 2017, 12:33
от kiksi
Добавить поле "Свойство" в "Печать прайс-листа"

Автор useronforumРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 312
Последний ответ 24 Фев 2018, 14:40
от useronforum
Добавить поле "Комментарий" в "Печать прайс-листа"

Автор useronforumРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 272
Последний ответ 03 Мар 2018, 16:14
от useronforum

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
67 Сообщений
oleg-x
56 Сообщений
AIFrame AIFrame
56 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
trialex3
30 Сообщений

* Кто онлайн

  • Точка Гостей: 238
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal