Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 01:44
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Поле ЗачетАванса не доступно для записи  (Прочитано 2306 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн dim3740

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-16
  • Сайт: 

8.2. обычные формы, код во внешней обработке... СпособЗачетаАвансов в шапке документа. Ошибка в названии топика.


Процедура НеЗачитыватьНажатие(Элемент)
   Док=Документы.РеализацияТоваровУслуг.Выбрать(НачалоДня(НачПериода),КонецДня(КонПериода));
   Пока Док.Следующий() Цикл
      ТЭ= Док.ПолучитьОбъект();
      ТЭ.ЗачетАвансов=Перечисления.СпособыЗачетаАвансов.НеЗачитывать;
      ТЭ.Записать(РежимЗаписиДокумента.Запись);
   КонецЦикла;
КонецПроцедуры


 Чем реквизит отличается от иных, того же контрагента, к примеру, что не хочет перезаписываться..?  не понятно...


Оффлайн GRADUS

  • *****
  • Сообщений: 699
  • РЕПУТАЦИЯ: 51
  • КПД: 7%
  • Регистрация: 2013-06-08
  • Сайт: 
  • Профессия: Программист 1С

8.2. обычные формы, код во внешней обработке... СпособЗачетаАвансов в шапке документа. Ошибка в названии топика.


Процедура НеЗачитыватьНажатие(Элемент)
   Док=Документы.РеализацияТоваровУслуг.Выбрать(НачалоДня(НачПериода),КонецДня(КонПериода));
   Пока Док.Следующий() Цикл
      ТЭ= Док.ПолучитьОбъект();
      ТЭ.ЗачетАвансов=Перечисления.СпособыЗачетаАвансов.НеЗачитывать;
      ТЭ.Записать(РежимЗаписиДокумента.Запись);
   КонецЦикла;
КонецПроцедуры


 Чем реквизит отличается от иных, того же контрагента, к примеру, что не хочет перезаписываться..?  не понятно...

Код верный, что то намудрил с реквизитами. Возможно, у документа ЗачетАвансов не реквезит, а табличная часть или еще чтонить. В общем по предоставленному коду нечего сказать.

Оффлайн dim3740

  • *
  • Сообщений: 45
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-08-16
  • Сайт: 
Спасибо. Отличие в наличии, действительно, также еще и ТЧ по авансам. Прошу помощи в обучении метода работы с Формой документа из внешней обработкой. Думаю, что решение по сабжу именно в таком способе....


Теги:
 

Поле не найдено"ЗаказПокупателя.Услуги.Ссылка"<<?>>ЗаказПокупателя.Услуги.Ссылка

Автор romanprogrammistРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 6930
Последний ответ 05 Дек 2013, 00:01
от romanprogrammist
{Форма.Форма.Форма(11)}: Поле объекта не обнаружено

Автор OksРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2283
Последний ответ 09 Дек 2015, 19:33
от Oks
Вывод информации: если поле не заполнено, то вывод иной информации. Новичок

Автор kiksiРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 311
Последний ответ 10 Окт 2017, 12:33
от kiksi
Поле "ВаловаяПрибыль" не может быть использовано в группировке "Store" СКД

Автор virtusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 6402
Последний ответ 10 Июл 2014, 15:16
от virtus
Не заполняется поле "Цена" при формировании документа "Пересчет товаров"

Автор InnakechaРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 1080
Последний ответ 29 Дек 2016, 09:54
от Innakecha

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 192
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal