Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 03:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Доступ к внешнему отчету  (Прочитано 7680 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн DihlofoZ

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-22
  • Сайт: 
  • Профессия: Ученик 1С
собственно сабж

альфа авто 4.1. : есть внешний отчет, хотел бы узнать как можно запретить к нему доступ всем кроме (к примеру): васи, пети, саши ?
у всех троих разные шаблоны прав.....


Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
У каждой роли есть право "Интерактивное открытие внешних отчетов". Можно проверить, чтоб у васи, саши, пети была хоть одна роль с этим правом, а у остальных пользователей нет. Правда при таком раскладе права будут действовать не только на этот отчет, но и на все внешние отчеты.

Оффлайн DihlofoZ

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-22
  • Сайт: 
  • Профессия: Ученик 1С
в том то и дело, что внешних отчетов N-ое кол-во, а закрыть доступ нужно именно к одному....

Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
Тогда в коде отчета жестко прописать проверку что-то типа Если РольДоступна("Название роли") То ок - открываем Иначе выдаем пользователю сообщение и закрываем отчет КонецЕсли.

Оффлайн DihlofoZ

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-22
  • Сайт: 
  • Профессия: Ученик 1С
т.к. роли у нужных людей разные, сделал немного по другому....

Процедура ДействияФормыОтчетСформировать(Кнопка)

Если ПараметрыСеанса.Пользователь.Наименование = "вася" ИЛИ ПараметрыСеанса.Пользователь.Наименование = "петя" ИЛИ ПараметрыСеанса.Пользователь.Наименование = "дима" Тогда
бла бла бла.......
Иначе 
Сообщить("У вас не достаточно прав для использования данного отчета");
Возврат;
КонецЕсли
КонецПроцедуры

но не хотелось бы ставить условие по имени.... дурной тон что ли)) можно ли придумать какой то другой способ решения моей задачи?

Оффлайн Vit1501

  • ****
  • Сообщений: 360
  • РЕПУТАЦИЯ: 60
  • КПД: 17%
  • Регистрация: 2010-06-05
  • Сайт: 
  • Профессия: Программист 1С
внести отчет в конфигурацию и настроить права ролей к нему, или создать отдельную роль чисто для этого отчета и в коде отчета проверять есть ли у пользователя эта роль

Оффлайн DihlofoZ

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-22
  • Сайт: 
  • Профессия: Ученик 1С
ну как бы вводить отчет в конфигурацию это не вариант....
и у людей которым нужно дать доступ совершенно разные роли...

Оффлайн Dethmontt

  • Денис
  • Модератор
  • *****
  • Сообщений: 2857
  • РЕПУТАЦИЯ: 546
  • КПД: 19%
  • Адын Эс
  • Регистрация: 2010-11-01
  • Сайт: 
  • Профессия: Программист 1С
Создаем свою роль "Доступ к очень "страшным" внешним обработкам"

В коде "страшных" внешних обработок проверяем роль
Процедура ПередОткрытием(Отказ)
Если РольДоступна("ДоступКОченьСтрашнымОбработкам") или РольДоступна("ПолныеПрава") Тогда
Иначе
   Предупреждение("Вам запрещено запускать эту обработку!");
   Отказ = истина;
КонецЕсли;

Ну и нужным пользователя ставим эту роль... (при обновлении проблем не будет с ролью т.к. просто добавлена)
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Доступ к реквизитам формы из другой формы? 8.x, работа с табличным полем формы

Автор nick_EРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 5869
Последний ответ 24 Окт 2011, 03:00
от nick_E
"Доступ к информационной базе разрешен" программно

Автор 12040Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1129
Последний ответ 10 Янв 2017, 10:20
от LexaK
Как ограничить доступ к изменению графы в сдельном наряде и табеля учета рабочего времени для пользователей с определённым интерфейсом

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 868
Последний ответ 23 Сен 2016, 10:45
от ksander-fars
Настроить доступ посредством RLS. Необходимо, чтобы каждый менеджер мог видеть только свой счет.

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 13
Просмотров: 10845
Последний ответ 04 Апр 2015, 01:22
от Дмитрий@
Все официальные порталы государственных услуг предоставят россиянам доступ к единому личному кабинету

Автор newsРаздел Новости

Ответов: 0
Просмотров: 482
Последний ответ 24 Июл 2015, 11:13
от news

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 160
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal