Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 05:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Записать комментарий в элементах справочника  (Прочитано 3815 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Всем доброго дня!Необходимо чтоб при нажатии Кнопки Выполнить  обработка перебрала справочник и в комментарии каждого элемента написала *Я тут был*.Подскажите пожалуйста,что не так я сделал (не кидайте тапками)) ). Зараннее благодарен.
1С:Предприятие 8.2 (8.2.15.310) УТП


Процедура КнопкаВыполнитьНажатие(Кнопка) 
Комментарий = Комментарий;

Заполнение (Комментарий);

    Сообщить ("Готово!");

КонецПроцедуры

&НаСервере
Функция Заполнение (Комментарий)
Номенклатура = Неопределено;

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Номенклатура.Родитель,
| Номенклатура.Наименование,
| Номенклатура.Комментарий
|ИЗ
| Справочник.Номенклатура КАК Номенклатура";

Результат = Запрос.Выполнить();
Пока Результат.Следующий() Цикл
Наименование = Результат.Наименование;
Комментарий = Комментарий.ЗаписатьКомментарий("я тут был");

КонецЦикла;   

КонецФункции




Последний раз редактировалось: MuI_I_Ika; 20 Июл 2013, 16:18


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Функция Заполнение (Комментарий)
    Номенклатура = Неопределено;
   
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    Номенклатура.Ссылка,
    |    Номенклатура.Родитель,
    |    Номенклатура.Наименование,
    |    Номенклатура.Комментарий
    |ИЗ
    |    Справочник.Номенклатура КАК Номенклатура";
   
    Выборка= Запрос.Выполнить().Выбрать();
        Пока Выборка.Следующий() Цикл
             
             НоменклатураОбъект = Выборка.Ссылка.ПолучитьОбъект();
             НоменклатураОбъект.Комментарий = "Я тут был";
             НоменклатураОбъект.Записать();

        КонецЦикла;       
   
КонецФункции

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Функция Заполнение (Комментарий)
    Номенклатура = Неопределено;
   
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    |    Номенклатура.Ссылка,
    |    Номенклатура.Родитель,
    |    Номенклатура.Наименование,
    |    Номенклатура.Комментарий
    |ИЗ
    |    Справочник.Номенклатура КАК Номенклатура";
   
    Выборка= Запрос.Выполнить().Выбрать();
        Пока Выборка.Следующий() Цикл
             
             НоменклатураОбъект = Выборка.Ссылка.ПолучитьОбъект();
             НоменклатураОбъект.Комментарий = "Я тут был";
             НоменклатураОбъект.Записать();

        КонецЦикла;       
   
КонецФункции

Большое спасибо за помощь! Выскаквает такая ошибка значит надо сделать проверку на группу? 

{Обработка.ЯТутБыл.Форма.Форма.Форма(47)}: Ошибка при установке значения атрибута контекста (Комментарий)
             НоменклатураОбъект.Комментарий = "Я тут был";
по причине:
Реквизит недоступен для группы

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6558
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Да, на группу надо проверить

Оффлайн Kostik2013

  • ***
  • Сообщений: 114
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-02-11
  • Сайт: 
  • Профессия: Программист 8.1
Да, на группу надо проверить

Огромное вам спасибо!Хороших выходных))


Теги:
 

Как вызвать "Анализ субконто" из справочника "Контрагенты"

Автор EnigManРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6496
Последний ответ 06 Фев 2012, 10:46
от cska-fanat-kz
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4199
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 629
Последний ответ 10 Май 2017, 20:44
от ilnur75
Как сделать, чтобы поле в документе имело тип "ссылка на поле справочника"?

Автор друганРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2036
Последний ответ 05 Мар 2017, 14:36
от Igor100500
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 270
Последний ответ 12 Окт 2017, 14:02
от wise

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
175 Сообщений
ilyay ilyay
69 Сообщений
oleg-x
48 Сообщений
alex0402
44 Сообщений
AIFrame
39 Сообщений
andron81_81
38 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 278
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal