Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 20:27
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как обновить данные на форме.  (Прочитано 14633 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Tanya_Lo

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-07-19
  • Сайт: 
  • Профессия: Ученик 1С
Ситуация такая. Открывается форма документа договора, на ней есть кнопка - заполнить на основании доп.соглашение. Нажимаю - открывается форма Доп.Соглашения. Создаю доп.соглашение и вношу изменения в Договор. Сохраняю - форма Доп.соглашения закрывается - а на форме Договора данные не обновились, их видно только при повторном открытии формы Договор.
Подскажите пожалуйста как обновлять данные на форме?


Оффлайн andryscha92

  • ****
  • Сообщений: 267
  • РЕПУТАЦИЯ: 4
  • КПД: 1%
  • Регистрация: 2012-01-31
  • Сайт: 
  • Профессия: Программист 1С
Попробуйте программно.Используйте метод Обновить()

Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Приведите код.

Оффлайн Tanya_Lo

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-07-19
  • Сайт: 
  • Профессия: Ученик 1С
вот процедура которая выполняется Подпиской на событие перед записию Доп.соглашения.
Процедура ПодпискаСозданиеДопСоглашенияПередЗаписью(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт
ДогСсылка=Источник.ДоговорСсылка;
ДоговорОбъект = ДогСсылка.ПолучитьОбъект();
     ДоговорОбъект.СрокДоговора = Источник.СрокДоговора;
     ДоговорОбъект.Записать();
КонецПроцедуры

Данные меняются, но только при повторном открытии формыЭлемента Договора.
такая же ситуация с созданием дополнительного соглашения - создаю на ОСНОВАНИИ
Если ТипЗнч(ДанныеЗаполнения) = Тип("ДокументСсылка.Договор") Тогда
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ДопСоглашения.Ссылка
|ИЗ
| Документ.ДопСоглашения КАК ДопСоглашения
|ГДЕ
| ДопСоглашения.НомерДоговора = &НомерДоговора";

Запрос.УстановитьПараметр("НомерДоговора", ДанныеЗаполнения.Номер);

Результат = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = Результат.Выбрать();
кол=ВыборкаДетальныеЗаписи.Количество();
Номер=Кол+1;
        ДоговорСсылка = ДанныеЗаполнения.Ссылка;
ВидАвансовыйПлатеж = ДанныеЗаполнения.ВидАвансовыйПлатеж;
ВидДоговора = ДанныеЗаполнения.ВидДоговора;
ВидКонтрагента = ДанныеЗаполнения.ВидКонтрагента;
ИсполнительДолжность = ДанныеЗаполнения.ИсполнительДолжность;
ИсполнительФИО = ДанныеЗаполнения.ИсполнительФИО;
Контрагент = ДанныеЗаполнения.Контрагент;
КонтрагентИП = ДанныеЗаполнения.КонтрагентИП;
КонтрагентИсполнитель = ДанныеЗаполнения.КонтрагентИсполнитель;
КонтрагентФиз = ДанныеЗаполнения.КонтрагентФиз;
НомерДоговораКонтрагента = ДанныеЗаполнения.НомерДоговораКонтрагента;
Организация = ДанныеЗаполнения.Организация;
НомерДоговора = ДанныеЗаполнения.Номер;
ОтметкаОбОплатеДляПериодических = ДанныеЗаполнения.ОтметкаОбОплатеДляПериодических;
ПериодНеопределенногоДоговора = ДанныеЗаполнения.ПериодНеопределенногоДоговора;
ОкончательныйРасчет = ДанныеЗаполнения.ОкончательныйРасчет;
ПорядокОплаты = ДанныеЗаполнения.ПорядокОплаты;
Предмет = ДанныеЗаполнения.Предмет;
СрокДоговора = ДанныеЗаполнения.СрокДоговора;
СрокДоговораДатаНачала = ДанныеЗаполнения.СрокДоговораДатаНачала;
СрокДоговораДатаОкончания = ДанныеЗаполнения.СрокДоговораДатаОкончания;
СрокДоговораОпределенного = ДанныеЗаполнения.СрокДоговораОпределенного;
Сумма = ДанныеЗаполнения.Сумма;
Для Каждого ТекСтрокаСрокИсполнения Из ДанныеЗаполнения.СрокИсполнения Цикл
НоваяСтрока = СрокИсполнения.Добавить();
НоваяСтрока.Конец = ТекСтрокаСрокИсполнения.Конец;
НоваяСтрока.Начало = ТекСтрокаСрокИсполнения.Начало;
КонецЦикла;
КонецЕсли;

Нажимаю на кнопку "ПРОВЕСТИ И ЗАКРЫТЬ" - Форма закрывается, но данные сразу тоже обновляется. Придумла кнопку - на нее нажимаю и

&НаКлиенте
Процедура ОбновитьДанные(Команда)
Доп.Очистить();
МассивДоп=Новый Массив;
МассивДоп=ОбщиеМеханизмы.ЗаполнениеНомеровДопСоглашений(Объект.Номер);
Для Каждого ЭлементМассива Из МассивДоп Цикл
    НоваяСтрока = Доп.Добавить();
НоваяСтрока.НомерДопСоглашения=ЭлементМассива;
КонецЦикла;

КонецПроцедуры


 &НаСервере
   Функция ЗаполнениеНомеровДопСоглашений (НомерДоговора) экспорт
   ВидДокумента="ДОП";
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ДоговораИДопСоглашения.НомерДопСоглашения
|ИЗ
| РегистрСведений.ДоговораИДопСоглашения КАК ДоговораИДопСоглашения
|ГДЕ
| ДоговораИДопСоглашения.ВидДокумента = &ВидДокумента
| И ДоговораИДопСоглашения.НомерДоговора = &НомерДоговора";

Запрос.УстановитьПараметр("ВидДокумента", ВидДокумента);
Запрос.УстановитьПараметр("НомерДоговора", НомерДоговора);

Результат = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = Результат.Выбрать();
    МасДоп  = Новый Массив;
Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
//НоваяСтрока = Доп.Добавить();
        МасДоп.Добавить(ВыборкаДетальныеЗаписи.НомерДопСоглашения);
КонецЦикла;

СписокЗначений = Новый СписокЗначений;
    СписокЗначений.ЗагрузитьЗначения(МасДоп);
    СписокЗначений.СортироватьПоЗначению();
    МасДоп = СписокЗначений.ВыгрузитьЗначения();

    возврат МасДоп;
КонецФункции

Последний раз редактировалось: MuI_I_Ika; 20 Июл 2013, 13:38

Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
В 1С есть такой метод как Оповестить() в форме нужно будет отлавливать обработкой оповещения

Оффлайн Новенькая

  • ****
  • Сообщений: 250
  • РЕПУТАЦИЯ: 21
  • КПД: 8%
  • Регистрация: 2011-02-21
  • Сайт: 
  • Профессия: Программист 1С
А вот этот метод не поможет ЭтаФорма.Прочитать(); ?

Онлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 6555
  • РЕПУТАЦИЯ: 775
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
скорее всего поможет, надо попробовать

Оффлайн Tanya_Lo

  • *
  • Сообщений: 37
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2013-07-19
  • Сайт: 
  • Профессия: Ученик 1С
помогло. спасибо.


Теги:
 

Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1753
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 263
Последний ответ 12 Окт 2017, 14:02
от wise
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2271
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Добавление строки и заполнение строки в ТЗ на форме

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 283
Последний ответ 25 Сен 2017, 09:00
от Св Ч
Ребята, срочно нужна помощь. Какую процедуру нужно написать в форме справочника, чтобы таблица заполнялась данными из другого справочника?

Автор Олька БякинаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2751
Последний ответ 27 Май 2016, 15:19
от Олька Бякина

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
163 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
28 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 345
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal